Announcement

Collapse

Welcome to the New Seqanswers!

Welcome to the new Seqanswers! We'd love your feedback, please post any you have to this topic: New Seqanswers Feedback.
See more
See less

why low mapping rates for RNAseq?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Hello to everyone and thanks for adding to the discussion here. Sorry I did not have the time to reply. I really appreciated everyone's input and I even learned more things than I expected.

    Alim, so from what I understand from your post, you think that the ~60% mapping rate of raw 25bp reads from your experiment is most likely due to the higher error rates of the old illumina sequencing chemistry.

    The newer chemistry then, should be better and help to increase the mapping rates by reducing the sequencing errors. I will take a closer look at this once the longer read data sets are available.

    Comment


    • #32
      RNA-Seq reads mapping very low

      Hi All
      I have been mapping reads generated on a MiSeq instrument (150bp) against the apple genome. Reads were processed (trimmed and filtered using the fastx_toolkit). Reads mapped are over a 100bp long. Using Tophat (version 1.4) to align the reads, I got an average of 12% of reads mapped for e.g. out of 5 Gb of reads (read1 and read2) only 600 Mb of data in the accepted_hits.bam file. I take this as reads mapped. Is there something wrong or am I missing something here? Any suggestions as to how address this very low mapping. I'm sure that the percentage reads should be much better than 12%?

      Comment


      • #33
        Originally posted by Lizex View Post
        Hi All
        I have been mapping reads generated on a MiSeq instrument (150bp) against the apple genome. Reads were processed (trimmed and filtered using the fastx_toolkit). Reads mapped are over a 100bp long. Using Tophat (version 1.4) to align the reads, I got an average of 12% of reads mapped for e.g. out of 5 Gb of reads (read1 and read2) only 600 Mb of data in the accepted_hits.bam file. I take this as reads mapped. Is there something wrong or am I missing something here? Any suggestions as to how address this very low mapping. I'm sure that the percentage reads should be much better than 12%?
        Since you have paired-end data, be careful using fastx_toolkit. I've seen a lot of people desyncing their paired-end reads with it.

        Comment


        • #34
          Did you check for adapter contamination of your reads?

          Comment


          • #35
            Why low mapping

            Thanks for the reply. I removed adaptors from the reads with cutadapt. I'm also curious how the reads map. Attached please see pic for how these map and also the presence of such a lot of N's. Should I worry about the N's and remove it or should I rather leave it. Any suggestions?
            Attached Files

            Comment


            • #36
              Originally posted by dpryan View Post
              Since you have paired-end data, be careful using fastx_toolkit. I've seen a lot of people desyncing their paired-end reads with it.
              Thanks, dpryan. What do suggest I use?

              Comment


              • #37
                Originally posted by Lizex View Post
                Thanks, dpryan. What do suggest I use?
                trim_galore or trimmomatic are common suggestions. I've had good luck in the past with trim_galore, which is also quite flexible.

                Comment


                • #38
                  Originally posted by dpryan View Post
                  trim_galore or trimmomatic are common suggestions. I've had good luck in the past with trim_galore, which is also quite flexible.
                  Thanks. I'll give it a try.

                  Comment


                  • #39
                    Originally posted by Lizex View Post
                    Thanks. I'll give it a try.
                    Hi dpryan

                    I've tried Trimmomatic. The number of reads i.e read1.fq and read2.fq are 1 492 345 for each. After mapping using Tophat 1.4.0, the stats of the accepted_hits.bam file looks like this:

                    samtools flagstat /Data_Analysis/E0.2.3/E0_tophat/accepted_hits.bam 1404454 + 0 in total (QC-passed reads + QC-failed reads)
                    0 + 0 duplicates
                    1404454 + 0 mapped (100.00%:nan%)
                    1404454 + 0 paired in sequencing
                    682904 + 0 read1
                    721550 + 0 read2
                    1200618 + 0 properly paired (85.49%:nan%)
                    1243330 + 0 with itself and mate mapped
                    161124 + 0 singletons (11.47%:nan%)
                    0 + 0 with mate mapped to a different chr
                    0 + 0 with mate mapped to a different chr (mapQ>=5)

                    Is this a good mapping or bad? How should I interpret this result?

                    Comment


                    • #40
                      That looks pretty reasonable. You started with ~1.5 million reads and aligned ~1.4 million, of which ~85% were properly paired. That's certainly a vast improvement over the original 12% mapping rate that you reported!

                      Comment


                      • #41
                        Originally posted by dpryan View Post
                        That looks pretty reasonable. You started with ~1.5 million reads and aligned ~1.4 million, of which ~85% were properly paired. That's certainly a vast improvement over the original 12% mapping rate that you reported!
                        Thanks for the reply. This result was for the paired reads (output from Trimmomatic). What should I do for the unpaired reads (output from Trimmomatic) which don't have an even number of reads, read1 has 896 804 reads and read2, 13 476. Should I map them also using Tophat.

                        Comment


                        • #42
                          Depending on exactly what you want to do with the reads, you can either map read1 as single-ended with tophat or just ignore them (the read2 file will mostly be crap in my experience). Given how many of your pairs became singletons, you might want to go ahead and align read1 just so you have a bit more data (I haven't ever lost many reads).

                          Comment


                          • #43
                            Originally posted by dpryan View Post
                            Depending on exactly what you want to do with the reads, you can either map read1 as single-ended with tophat or just ignore them (the read2 file will mostly be crap in my experience). Given how many of your pairs became singletons, you might want to go ahead and align read1 just so you have a bit more data (I haven't ever lost many reads).
                            Thanks for the advice.

                            Comment


                            • #44
                              Hi, I have run RNA-seq on human samples and got very low alignment percentages in Tophat and RSEM. I had used Illumina ribo zero Truseq kit for library prep. What could be the reason of low alignment? Right now only 11% of my reads are aligning with the transcriptome in RSEM. Can I do something to fix this?

                              Comment


                              • #45
                                Replying to a ~year old thread is not normally the most efficient route to get help.

                                Did you adapter trim your data? Have you tried aligning to the genome? Have you tried blasting a few unaligned reads?

                                Comment

                                Working...
                                X