Announcement

Collapse

Welcome to the New Seqanswers!

Welcome to the new Seqanswers! We'd love your feedback, please post any you have to this topic: New Seqanswers Feedback.
See more
See less

CummeRbund installation failing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    CummeRbund installation error on Linux Redhat Enterprise6.5

    I am trying to install cummeRbund in R (version 3.1.0) on a 64-bit Linux Redhat Enterprise 6.5 and I am getting errors similar to those posted on this thread. However, when I try to install several of the packages suggested, I get the response: 1. already installed or 2. no package is available. Specifics below:

    When I try to install CummeRbund:

    $ sudo R
    [sudo] password for cjsifuen:

    R version 3.1.0 (2014-04-10) -- "Spring Dance"
    Copyright (C) 2014 The R Foundation for Statistical Computing
    Platform: x86_64-redhat-linux-gnu (64-bit)

    R is free software and comes with ABSOLUTELY NO WARRANTY.
    You are welcome to redistribute it under certain conditions.
    Type 'license()' or 'licence()' for distribution details.

    Natural language support but running in an English locale

    R is a collaborative project with many contributors.
    Type 'contributors()' for more information and
    'citation()' on how to cite R or R packages in publications.

    Type 'demo()' for some demos, 'help()' for on-line help, or
    'help.start()' for an HTML browser interface to help.
    Type 'q()' to quit R.

    > source('http://www.bioconductor.org/biocLite.R')
    Bioconductor version 2.14 (BiocInstaller 1.14.2), ?biocLite for help
    > biocLite('cummeRbund')
    BioC_mirror: http://bioconductor.org
    Using Bioconductor version 2.14 (BiocInstaller 1.14.2), R version
    3.1.0.
    Installing package(s) 'cummeRbund'
    also installing the dependencies ‘VariantAnnotation’, ‘XML’, ‘RCurl’, ‘biomaRt’, ‘GenomicFeatures’, ‘biovizBase’, ‘rtracklayer’, ‘Gviz’

    trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/VariantAnnotation_1.10.1.tar.gz'
    Content type 'application/x-gzip' length 1300279 bytes (1.2 Mb)
    opened URL
    ==================================================
    downloaded 1.2 Mb

    trying URL 'http://cran.fhcrc.org/src/contrib/XML_3.98-1.1.tar.gz'
    Content type 'application/x-gzip' length 1582216 bytes (1.5 Mb)
    opened URL
    ==================================================
    downloaded 1.5 Mb

    trying URL 'http://cran.fhcrc.org/src/contrib/RCurl_1.95-4.1.tar.gz'
    Content type 'application/x-gzip' length 870915 bytes (850 Kb)
    opened URL
    ==================================================
    downloaded 850 Kb

    trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/biomaRt_2.20.0.tar.gz'
    Content type 'application/x-gzip' length 276933 bytes (270 Kb)
    opened URL
    ==================================================
    downloaded 270 Kb

    trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/GenomicFeatures_1.16.2.tar.gz'
    Content type 'application/x-gzip' length 765846 bytes (747 Kb)
    opened URL
    ==================================================
    downloaded 747 Kb

    trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/biovizBase_1.12.1.tar.gz'
    Content type 'application/x-gzip' length 2429449 bytes (2.3 Mb)
    opened URL
    ==================================================
    downloaded 2.3 Mb

    trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/rtracklayer_1.24.2.tar.gz'
    Content type 'application/x-gzip' length 1337492 bytes (1.3 Mb)
    opened URL
    ==================================================
    downloaded 1.3 Mb

    trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/Gviz_1.8.3.tar.gz'
    Content type 'application/x-gzip' length 2541759 bytes (2.4 Mb)
    opened URL
    ==================================================
    downloaded 2.4 Mb

    trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/cummeRbund_2.6.1.tar.gz'
    Content type 'application/x-gzip' length 2291914 bytes (2.2 Mb)
    opened URL
    ==================================================
    downloaded 2.2 Mb

    * installing *source* package ‘XML’ ...
    ** package ‘XML’ successfully unpacked and MD5 sums checked
    checking for gcc... gcc
    checking for C compiler default output file name... rm: cannot remove `a.out.dSYM': Is a directory
    a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking how to run the C preprocessor... gcc -E
    checking for sed... /bin/sed
    checking for pkg-config... /usr/bin/pkg-config
    checking for xml2-config... no
    Cannot find xml2-config
    ERROR: configuration failed for package ‘XML’
    * removing ‘/usr/lib64/R/library/XML’
    * installing *source* package ‘RCurl’ ...
    ** package ‘RCurl’ successfully unpacked and MD5 sums checked
    checking for curl-config... no
    Cannot find curl-config
    ERROR: configuration failed for package ‘RCurl’
    * removing ‘/usr/lib64/R/library/RCurl’
    ERROR: dependencies ‘XML’, ‘RCurl’ are not available for package ‘biomaRt’
    * removing ‘/usr/lib64/R/library/biomaRt’
    ERROR: dependencies ‘XML’, ‘RCurl’ are not available for package ‘rtracklayer’
    * removing ‘/usr/lib64/R/library/rtracklayer’
    ERROR: dependencies ‘rtracklayer’, ‘biomaRt’, ‘RCurl’ are not available for package ‘GenomicFeatures’
    * removing ‘/usr/lib64/R/library/GenomicFeatures’
    ERROR: dependencies ‘GenomicFeatures’, ‘rtracklayer’ are not available for package ‘VariantAnnotation’
    * removing ‘/usr/lib64/R/library/VariantAnnotation’
    ERROR: dependencies ‘GenomicFeatures’, ‘VariantAnnotation’ are not available for package ‘biovizBase’
    * removing ‘/usr/lib64/R/library/biovizBase’
    ERROR: dependencies ‘rtracklayer’, ‘biomaRt’, ‘GenomicFeatures’, ‘biovizBase’ are not available for package ‘Gviz’
    * removing ‘/usr/lib64/R/library/Gviz’
    ERROR: dependencies ‘rtracklayer’, ‘Gviz’ are not available for package ‘cummeRbund’
    * removing ‘/usr/lib64/R/library/cummeRbund’

    The downloaded source packages are in
    ‘/tmp/Rtmp4tvQHn/downloaded_packages’
    Updating HTML index of packages in '.Library'
    Making 'packages.html' ... done
    Warning messages:
    1: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
    installation of package ‘XML’ had non-zero exit status
    2: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
    installation of package ‘RCurl’ had non-zero exit status
    3: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
    installation of package ‘biomaRt’ had non-zero exit status
    4: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
    installation of package ‘rtracklayer’ had non-zero exit status
    5: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
    installation of package ‘GenomicFeatures’ had non-zero exit status
    6: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
    installation of package ‘VariantAnnotation’ had non-zero exit status
    7: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
    installation of package ‘biovizBase’ had non-zero exit status
    8: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
    installation of package ‘Gviz’ had non-zero exit status
    9: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
    installation of package ‘cummeRbund’ had non-zero exit status
    > library(cummeRbund)
    Error in library(cummeRbund) : there is no package called ‘cummeRbund’
    > quit()

    When I try to install some of the mentioned packages:

    $ sudo yum install libxml2 libcurl
    [sudo] password for cjsifuen:
    Loaded plugins: downloadonly, product-id, refresh-packagekit, rhnplugin, security, subscription-manager, verify
    This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
    This system is receiving updates from RHN Classic or RHN Satellite.
    Setting up Install Process
    Package libxml2-2.7.6-14.el6_5.1.x86_64 already installed and latest version
    Package libcurl-7.19.7-37.el6_5.3.x86_64 already installed and latest version
    Nothing to do

    $ sudo yum install libxml2-dev
    Loaded plugins: downloadonly, product-id, refresh-packagekit, rhnplugin, security, subscription-manager, verify
    This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
    This system is receiving updates from RHN Classic or RHN Satellite.
    Setting up Install Process
    No package libxml2-dev available.
    Error: Nothing to do

    $ sudo yum install libcurl4-openssl-dev
    Loaded plugins: downloadonly, product-id, refresh-packagekit, rhnplugin, security, subscription-manager, verify
    This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
    This system is receiving updates from RHN Classic or RHN Satellite.
    Setting up Install Process
    No package libcurl4-openssl-dev available.
    Error: Nothing to do

    $ sudo yum install zlib1g
    Loaded plugins: downloadonly, product-id, refresh-packagekit, rhnplugin, security, subscription-manager, verify
    This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
    This system is receiving updates from RHN Classic or RHN Satellite.
    Setting up Install Process
    No package zlib1g available.
    Error: Nothing to do

    $ sudo yum install zlib1g-dev
    Loaded plugins: downloadonly, product-id, refresh-packagekit, rhnplugin, security, subscription-manager, verify
    This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
    This system is receiving updates from RHN Classic or RHN Satellite.
    Setting up Install Process
    No package zlib1g-dev available.
    Error: Nothing to do

    I am at a loss for what to try next. Any help would be greatly appreciated.

    Thanks,

    Chris

    Comment


    • #62
      Chris,

      I think the package names for RHEL are as below. I assume you have access to a redhat satellite for installation.

      zlib
      libxml2-devel
      zlib-devel
      openssl-devel

      Comment


      • #63
        CummeRbund installation still not working

        Originally posted by GenoMax View Post
        Chris,

        I think the package names for RHEL are as below. I assume you have access to a redhat satellite for installation.

        zlib
        libxml2-devel
        zlib-devel
        openssl-devel
        Thank you for the quick reply. I do have access to redhat satellite for installation. I tried installing the packages, 2 were already installed and the other 2 installed sucessfully.

        I tried to install CummeRbund again and received the following errors:

        $ sudo R

        R version 3.1.0 (2014-04-10) -- "Spring Dance"
        Copyright (C) 2014 The R Foundation for Statistical Computing
        Platform: x86_64-redhat-linux-gnu (64-bit)

        R is free software and comes with ABSOLUTELY NO WARRANTY.
        You are welcome to redistribute it under certain conditions.
        Type 'license()' or 'licence()' for distribution details.

        Natural language support but running in an English locale

        R is a collaborative project with many contributors.
        Type 'contributors()' for more information and
        'citation()' on how to cite R or R packages in publications.

        Type 'demo()' for some demos, 'help()' for on-line help, or
        'help.start()' for an HTML browser interface to help.
        Type 'q()' to quit R.

        > source('http://www.bioconductor.org/biocLite.R')
        Bioconductor version 2.14 (BiocInstaller 1.14.2), ?biocLite for help
        > biocLite('cummeRbund')
        BioC_mirror: http://bioconductor.org
        Using Bioconductor version 2.14 (BiocInstaller 1.14.2), R version
        3.1.0.
        Installing package(s) 'cummeRbund'
        also installing the dependencies ‘VariantAnnotation’, ‘RCurl’, ‘biomaRt’, ‘GenomicFeatures’, ‘biovizBase’, ‘rtracklayer’, ‘Gviz’

        trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/VariantAnnotation_1.10.1.tar.gz'
        Content type 'application/x-gzip' length 1300279 bytes (1.2 Mb)
        opened URL
        ==================================================
        downloaded 1.2 Mb

        trying URL 'http://cran.fhcrc.org/src/contrib/RCurl_1.95-4.1.tar.gz'
        Content type 'application/x-gzip' length 870915 bytes (850 Kb)
        opened URL
        ==================================================
        downloaded 850 Kb

        trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/biomaRt_2.20.0.tar.gz'
        Content type 'application/x-gzip' length 276933 bytes (270 Kb)
        opened URL
        ==================================================
        downloaded 270 Kb

        trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/GenomicFeatures_1.16.2.tar.gz'
        Content type 'application/x-gzip' length 765846 bytes (747 Kb)
        opened URL
        ==================================================
        downloaded 747 Kb

        trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/biovizBase_1.12.1.tar.gz'
        Content type 'application/x-gzip' length 2429449 bytes (2.3 Mb)
        opened URL
        ==================================================
        downloaded 2.3 Mb

        trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/rtracklayer_1.24.2.tar.gz'
        Content type 'application/x-gzip' length 1337492 bytes (1.3 Mb)
        opened URL
        ==================================================
        downloaded 1.3 Mb

        trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/Gviz_1.8.3.tar.gz'
        Content type 'application/x-gzip' length 2541759 bytes (2.4 Mb)
        opened URL
        ==================================================
        downloaded 2.4 Mb

        trying URL 'http://bioconductor.org/packages/2.14/bioc/src/contrib/cummeRbund_2.6.1.tar.gz'
        Content type 'application/x-gzip' length 2291914 bytes (2.2 Mb)
        opened URL
        ==================================================
        downloaded 2.2 Mb

        * installing *source* package ‘RCurl’ ...
        ** package ‘RCurl’ successfully unpacked and MD5 sums checked
        checking for curl-config... no
        Cannot find curl-config
        ERROR: configuration failed for package ‘RCurl’
        * removing ‘/usr/lib64/R/library/RCurl’
        ERROR: dependency ‘RCurl’ is not available for package ‘biomaRt’
        * removing ‘/usr/lib64/R/library/biomaRt’
        ERROR: dependency ‘RCurl’ is not available for package ‘rtracklayer’
        * removing ‘/usr/lib64/R/library/rtracklayer’
        ERROR: dependencies ‘rtracklayer’, ‘biomaRt’, ‘RCurl’ are not available for package ‘GenomicFeatures’
        * removing ‘/usr/lib64/R/library/GenomicFeatures’
        ERROR: dependencies ‘GenomicFeatures’, ‘rtracklayer’ are not available for package ‘VariantAnnotation’
        * removing ‘/usr/lib64/R/library/VariantAnnotation’
        ERROR: dependencies ‘GenomicFeatures’, ‘VariantAnnotation’ are not available for package ‘biovizBase’
        * removing ‘/usr/lib64/R/library/biovizBase’
        ERROR: dependencies ‘rtracklayer’, ‘biomaRt’, ‘GenomicFeatures’, ‘biovizBase’ are not available for package ‘Gviz’
        * removing ‘/usr/lib64/R/library/Gviz’
        ERROR: dependencies ‘rtracklayer’, ‘Gviz’ are not available for package ‘cummeRbund’
        * removing ‘/usr/lib64/R/library/cummeRbund’

        The downloaded source packages are in
        ‘/tmp/RtmpBn4iVY/downloaded_packages’
        Updating HTML index of packages in '.Library'
        Making 'packages.html' ... done
        Warning messages:
        1: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
        installation of package ‘RCurl’ had non-zero exit status
        2: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
        installation of package ‘biomaRt’ had non-zero exit status
        3: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
        installation of package ‘rtracklayer’ had non-zero exit status
        4: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
        installation of package ‘GenomicFeatures’ had non-zero exit status
        5: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
        installation of package ‘VariantAnnotation’ had non-zero exit status
        6: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
        installation of package ‘biovizBase’ had non-zero exit status
        7: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
        installation of package ‘Gviz’ had non-zero exit status
        8: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
        installation of package ‘cummeRbund’ had non-zero exit status

        Could there be something else I am missing?

        Thanks,

        Chris

        Comment


        • #64
          Can you see if "curl-config" is installed on your server?

          Code:
          $ which curl-config
          You may need to install the curl-devel library.

          Comment


          • #65
            Originally posted by GenoMax View Post
            Can you see if "curl-config" is installed on your server?

            Code:
            $ which curl-config
            You may need to install the curl-devel library.
            I checked the curl-config version

            $ which curl-config
            ~/Enthought/Canopy_64bit/User/bin/curl-config

            $ curl-config --version
            libcurl 7.25.0

            I installed the curl-devel library successfully. I then tried to install CummeRbund sucessfully and loaded the library succesfully (the end of the installation is shown):

            ** building package indices
            ** installing vignettes
            ** testing if installed package can be loaded
            * DONE (cummeRbund)
            Making 'packages.html' ... done

            The downloaded source packages are in
            ‘/tmp/Rtmp0oui45/downloaded_packages’
            Updating HTML index of packages in '.Library'
            Making 'packages.html' ... done
            > library(cummeRbund)
            Loading required package: BiocGenerics
            Loading required package: parallel

            Attaching package: ‘BiocGenerics’

            The following objects are masked from ‘packagearallel’:

            clusterApply, clusterApplyLB, clusterCall, clusterEvalQ,
            clusterExport, clusterMap, parApply, parCapply, parLapply,
            parLapplyLB, parRapply, parSapply, parSapplyLB

            The following object is masked from ‘package:stats’:

            xtabs

            The following objects are masked from ‘package:base’:

            anyDuplicated, append, as.data.frame, as.vector, cbind, colnames,
            do.call, duplicated, eval, evalq, Filter, Find, get, intersect,
            is.unsorted, lapply, Map, mapply, match, mget, order, paste, pmax,
            pmax.int, pmin, pmin.int, Position, rank, rbind, Reduce, rep.int,
            rownames, sapply, setdiff, sort, table, tapply, union, unique,
            unlist

            Loading required package: RSQLite
            Loading required package: DBI
            Loading required package: ggplot2
            Loading required package: reshape2
            Loading required package: fastcluster

            Attaching package: ‘fastcluster’

            The following object is masked from ‘package:stats’:

            hclust

            Loading required package: rtracklayer
            Loading required package: GenomicRanges
            Loading required package: IRanges
            Loading required package: GenomeInfoDb
            Loading required package: Gviz
            Loading required package: grid

            Attaching package: ‘cummeRbund’

            The following object is masked from ‘package:GenomicRanges’:

            promoters

            The following object is masked from ‘package:IRanges’:

            promoters

            I will try using it now.

            Thank you so much!

            Comment


            • #66
              This site might help. I ended up needing to install curl for my Debian machine and I don't have root permissions. So I went ahead and loaded my user directory up with a bunch of programs.

              This was the command that I ended up using to install it. (From ~/src/curl-7.38.0):
              configure --prefix=/home/{user}/bin/curl-7.38.0 CPPFLAGS="-I/home/{user}/bin/libcurl/include"
              make
              make install


              One last trick,

              export LD_LIBRARY_PATH=/home/{user}/bin/curl-7.38.0/lib

              (There's a whole long story behind this one for the non-C programmer)


              Then going back into R I was able to install RCurl and it found everything! Then all the other packages of course that follow.

              Comment


              • #67
                Hi all,
                I have two groups. One group has 3 varieties (which presumably have extreme low expression for all the genes) and another group has also 3 varieties (which have extreme high expression for all the genes). Now, I want to know how many genes (with the average value of each gene taken from 3 varieties) between these 2 groups are significant? And what are those genes? Please can you tell me what is the appropriate code to be used in cummerbund?

                Thank you,

                Mahbuba Siddiqua

                Comment


                • #68
                  Hello,
                  first of all thanks to all the people for posting so many solutions and help messages for starters like me! This is the first time I write, but I read many of the threads!

                  My problem is comparable to the first problems:

                  > library(cummeRbund)
                  Error in library(cummeRbund) : there is no package called ‘cummeRbund’

                  I installed the recommended packages in this forum:

                  $ sudo apt-get install libxml2-dev
                  $ sudo apt-get install libcurl4-openssl-dev

                  Then, re-installed cummeRbund:
                  > source('http://www.bioconductor.org/biocLite.R')
                  > biocLite('cummeRbund')

                  The process was different compared to the process before installing those packages, but the final message was the same, including:

                  Warning messages:
                  1: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
                  installation of package ‘GenomicFeatures’ had non-zero exit status
                  2: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
                  installation of package ‘biovizBase’ had non-zero exit status
                  3: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
                  installation of package ‘Gviz’ had non-zero exit status
                  4: In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
                  installation of package ‘cummeRbund’ had non-zero exit status
                  5: installed directory not writable, cannot update packages 'boot', 'class',
                  'cluster', 'codetools', 'foreign', 'KernSmooth', 'lattice', 'Matrix', 'mgcv',
                  'nlme', 'nnet', 'rpart', 'spatial', 'survival'

                  Has anyone any more brilliant ideas to get this working? I would be really, really thankful!

                  Comment


                  • #69
                    Originally posted by mcm View Post
                    5: installed directory not writable, cannot update packages 'boot', 'class',
                    'cluster', 'codetools', 'foreign', 'KernSmooth', 'lattice', 'Matrix', 'mgcv',
                    'nlme', 'nnet', 'rpart', 'spatial', 'survival'

                    Has anyone any more brilliant ideas to get this working? I would be really, really thankful!
                    See bold text above. Is this a personal machine or you are on a server without necessary privileges to install software?

                    Comment


                    • #70
                      (wow fast response, thanks! )

                      This is a machine at work for which I am the only user and I have admin rights. In fact I could install all programmes I needed so far (contrary to other machines at work for which I needed to call IT for installations).

                      Comment


                      • #71
                        What OS are you using (should have asked before)? Was the original R install done using a different account? Are you using latest R available?

                        Comment


                        • #72
                          Ubuntu. And yes, the original R was installed with a different account because it was "here" when I arrived. It is version 3.0.2. Shall I uninstall and install again?
                          thank you so much...

                          Comment


                          • #73
                            Since you are the only user on this machine (and have admin rights) you could recursively change the ownership (chown -R) of the directories in question to your account and then try the install. Make sure the group matches as well.

                            Current R is 3.1.3, so installing the latest version is an option as well.
                            Last edited by GenoMax; 03-10-2015, 07:10 AM.

                            Comment


                            • #74
                              Good morning! Thank your for the last post. That makes a lot of sense. I did not manage, though, but this is only due to my lack of IT knowledge. I appreciate a lot your help, I will keep on trying myself reading a bit more and (hopefully not but) I may come back soon!
                              Thank you once again!

                              Comment


                              • #75
                                It is simple actually. Find our where your R is installed?

                                Code:
                                $ which R
                                Then find out which account owns that top level directory

                                Code:
                                $ ls -l /path_on_your_server/r-3.x
                                Then do

                                Code:
                                $ chown -R your_acct_name /path_on_your_server/r-3.x
                                Make sure the group is also changed to match yours

                                Code:
                                $ chgrp -R your_group /path_on_your_server/r-3.x
                                You should be able to upgrade the libraries at that point.

                                Comment

                                Working...
                                X