Announcement

Collapse

Welcome to the New Seqanswers!

Welcome to the new Seqanswers! We'd love your feedback, please post any you have to this topic: New Seqanswers Feedback.
See more
See less

ALLPATHS: does it work?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ALLPATHS: does it work?

    Hi,
    I downloaded ALLPATHS from MIT site ftp://ftp.broad.mit.edu/pub/crd/ALLPATHS/Release-2-0/ but I have a lot of problems running it on the test example that you can download with the program.
    I spend almost one day to compile it, and I was also oblige to comment a line of the makefile.
    Now I'm trying to use it but I'm having troubles. The first step of the procedure consist in exporting the data calling allpath with the option TARGETS=import .
    After few second I received the error message:

    PrepareAllPathsInput SOURCE_DIR=$(SOURCE) DATA_DIR=$(DATA) READS_OUT="reads_orig" STATS_IN=expected_lib_stats
    /bin/sh: PrepareAllPathsInput: not found
    make: *** [example/Staph/MyTestData/ploidy] Error 127


    My question are: anybody has this problem? There is somebody that was able to install and use ALLPATHS?

    Francesco

  • #2
    I can't even get as far as you have! It seems to require gcc 4.3.2, I only have 4.1.2.

    Have you looked at http://www.broad.mit.edu/crd/wiki/index.php/Build_FAQ ?

    Comment


    • #3
      In order to overcame this problem you have only to edit a bit the Makefile, changing the compiler that is required.
      I think that this operation doesn't create troubles.

      Comment


      • #4
        But it seems not to be suit for anyone. Many people maybe not work with C/C++. To change the MakeFile, it is not practical. So, I guess it should decrease the version of GCC


        Originally posted by francesco.vezzi View Post
        In order to overcame this problem you have only to edit a bit the Makefile, changing the compiler that is required.
        I think that this operation doesn't create troubles.

        Comment


        • #5
          Originally posted by anyone1985 View Post
          But it seems not to be suit for anyone. Many people maybe not work with C/C++. To change the MakeFile, it is not practical. So, I guess it should decrease the version of GCC
          You can achieve the same result without having to edit "mysterious" files with:

          ./configure --with-no_gcc_check

          Hope this helps.

          Comment


          • #6
            "./configure --with-no_gcc_check" can help me configure the program smoothly. However, when I "make -j4", the program come across the fatal error. The compiler can not identify some string.

            Originally posted by Torst View Post
            You can achieve the same result without having to edit "mysterious" files with:

            ./configure --with-no_gcc_check

            Hope this helps.

            Comment


            • #7
              Hi,

              I have similar problem with allpaths. I've compiled Allpath ver3.2
              with following command.

              %autoconf
              %./configure CC=gcc44 CXX=g++44
              %make

              It looks successesful but I got following error when I have tried to import
              the sample S.pombe data.
              (ftp://ftp.broadinstitute.org/pub/crd...S/Release-2-0/ )
              -------------------------------------------------------------------------


              Tue Jun 01 18:58:26 2010 Removed 866 out of 10636466 reads
              Tue Jun 01 18:58:26 2010 Writing reads
              Tue Jun 01 18:58:38 2010 Writing quals
              Tue Jun 01 18:58:51 2010 Building pairing information
              Tue Jun 01 18:58:53 2010 Closing open files
              Program PrepareAllPathsInput failed to make target $(DATA)/frag_reads_orig.pairs
              /bin/sh: @echo: command not found
              make: *** [assembly/Spombe/MyData/frag_reads_orig.fastb] Error 1
              make: *** Deleting file `assembly/Spombe/MyData/frag_reads_orig.fastb'


              Looks like the command PrepareAllPathsInput did not complete:
              The following files are missing: 1
              $(DATA)/frag_reads_orig.fastb
              The following files are incomplete: 1
              $(DATA)/frag_reads_orig.qualb
              Cleaning up all targets of this command...
              Moving $(DATA)/frag_reads_orig.qualb to $(DATA)/makeinfo/frag_reads_orig.qualb.incomplete

              Tue Jun 01 18:59:12 2010 : Pipeline Finished. Run directory was
              assembly/Spombe/MyData/MyRun

              *** Make encountered an error, see above for error messages. ***
              -------------------------------------------------------------------------

              Is there anyone who had the same problem before ?

              Thanks,
              Corthay

              Comment


              • #8
                Hi
                I spend one week trying to install ALLPATHS without results. It seems that the source code is designed to be compiled only on the machines of the authors... I never heard somebody that was able to install this assembler

                My suggestion... don't loose time and use one between SOAPdenovo or ABySS

                F.

                Comment


                • #9
                  Hi
                  I am new in allpaths as well.
                  I am also now having the same problem as Corthay
                  Hi Corthay, if you have solved the problem, please post it.
                  Thank you

                  Comment


                  • #10
                    Hi Himalaya,

                    I've used ver. 3-33800 for import as ver 3.2 have not worked and
                    I've used ver. 3.2 (stable version) for standard as ver 3-33800 have not worked.
                    You can get latest source code from following site.
                    ftp://ftp.broadinstitute.org/pub/crd...t_source_code/

                    Apparently, it's successful but I am still checking the result.
                    For your information, I've prepared E.coli simulated reads as following.
                    - insert length : 180bp +/- 18bp, read length : 110bp, 45x (fragment)
                    - insert length : 3000bp +/- 300bp, read length : 110bp, 45x (jumping)

                    Hope that this is of some use to you.

                    Thanks
                    Corthay

                    Comment


                    • #11
                      Hi Corthay
                      I downloaded allpaths3-33685 and i am also trying to import only.
                      But there is error. In the error there is following messge

                      Looks like the command PrepareAllPathsInput did not complete:
                      The following files are missing: 1
                      $(DATA)/frag_reads_orig.fastb
                      The following files are incomplete: 1
                      $(DATA)/frag_reads_orig.qualb
                      Cleaning up all targets of this command...

                      What is this file "frag_reads_orig.fastb" and its quala file.
                      I have paired end files, pair.a.fasta and pair.b.fasta and their files pair.a.quala and pair.b.quala. Lets assume these all files are in folder "unknown" in my home directory.
                      Then my command was
                      RunAllPaths3G PRE=$HOME/allpaths_test DATA_SUBDIR=mytestdata RUN=mytestrun EVALUATION=NONE REFERENCE_NAME=Unknown TARGETS=import SOURCE_DIR=~/unknown_sp/ OVERWRITE=True
                      This command gave the above error.
                      Please help me. Can you please provide me your sample command for "TARGET=IMPORT" and "TARGET=STANDARD"

                      Thanks a lot for the help
                      Himalaya

                      Comment


                      • #12
                        Hi Himalaya,

                        The file "frag_reads_orig.fastb" is a binary sequence
                        file as input for allpaths. It's generated in import step.

                        I've used following command for import and standard.
                        ----- import -----
                        RunAllPaths3G \
                        PRE=assembly \
                        DATA_SUBDIR=MyData \
                        RUN=MyRun \
                        REFERENCE_NAME=Ecoli \
                        TARGETS=import \
                        SOURCE_DIR=simrd \
                        K=96 \
                        OVERWRITE=True
                        -------------------
                        ---- standard -----
                        RunAllPaths3G \
                        PRE=assembly \
                        DATA_SUBDIR=MyData \
                        RUN=MyRun \
                        REFERENCE_NAME=Ecoli \
                        TARGETS=standard \
                        K=96 \
                        OVERWRITE=True
                        -------------------

                        Thanks.
                        Corthay

                        Comment


                        • #13
                          Hi Corthay
                          Thanks a lot for reply.
                          seems like my command is not different than yours while importing. The only difference is that you have given the value of k while importing but when i give the value of k, it gives error saying -

                          You should not have specified a value for k.
                          To see the syntax for this command, type "RunAllPaths3G -h".

                          Did you get this error?
                          And this you get the error saying "frag_reads_orig.fastb" is missing. if this file is created during import then in my case this file is not created. Any idea what might be wrong.

                          Thanks again.

                          Comment


                          • #14
                            Hi Corthay again
                            I tried some more options and got different errors now
                            Well there was not much different command than the one i posted. I only change the lowercase k to uppercase K and gave the value 31. The error generated was

                            Not implemented for K=31.
                            This makes sense as my reads length were 100 bp.
                            so i changed K=96 and this time the error message has following:
                            Metric "SEP" is undefined.
                            ...
                            ...
                            ...
                            Looks like the command PrepareAllPathsInput did not complete:
                            The following files are missing: 1
                            $(DATA)/frag_reads_orig.fastb
                            The following files are incomplete: 1
                            $(DATA)/frag_reads_orig.qualb
                            Cleaning up all targets of this command...

                            Do we have to prepare the file frag_reads_lib_stat file that was specified in manual, which has five values: file library_name paired jumping sep dev
                            and put that file in the SOURCE_DIR.

                            Waiting for the reply
                            Thanks
                            Himalaya

                            Comment


                            • #15
                              Hi Himalaya,

                              You can use only following values for K-mer, as I've roughly checked the source code.
                              12,20,26,40,64,80,88,96

                              The "Metric "SEP" is undefined" error is occured when you do not prepare
                              "frag_reads_lib_stats" or "jump_reads_lib_stats" in the SOURCE_DIR.
                              Here is my sample files.

                              ::::::::::::::
                              frag_reads_lib_stats
                              ::::::::::::::
                              FILE LIBRARY_NAME PAIRED JUMPING SEP DEV
                              ecolisim.180.A.fasta Solexa180 T F 180 18
                              ecolisim.180.B.fasta Solexa180 T F 180 18

                              ::::::::::::::
                              jump_reads_lib_stats
                              ::::::::::::::
                              FILE LIBRARY_NAME PAIRED JUMPING SEP DEV
                              ecolisim.3000.compl.A.fasta Solexa3000 T T 3000 300
                              ecolisim.3000.compl.B.fasta Solexa3000 T T 3000 300

                              ::::::::::::::
                              ploidy
                              ::::::::::::::
                              1

                              Good Luck !
                              Corthay

                              Comment

                              Working...
                              X