Announcement

Collapse

Welcome to the New Seqanswers!

Welcome to the new Seqanswers! We'd love your feedback, please post any you have to this topic: New Seqanswers Feedback.
See more
See less

Aligning paired end Illumina data with Bowtie

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Aligning paired end Illumina data with Bowtie

    I have 2 fastq files read1.fastq and read2.fastq.
    If I align read1.fastq to the reference genome, I get a set of readids that align. Lets say a1, a2, a3, a4, a5, a6, a7, a8, a9 for simplicity.
    If I align read2.fastq to the reference genome, I get another set of readids: a1, a2, a4, a5, a6, a8, a9, a10.
    But when I align both together as paired end data using -1 and -2 Bowtie command line options, I get only a1, a9 (I expected a1, a2, a4, a5, a6, a8, a9, i.e. common to read1 and read2) along with a bunch of memory warnings that look like this:

    Warning: Exhausted best-first chunk memory for read HWI-XXXXX:103046AACXX:5:1101:4313:3969 1:N:0:CAGATC/1 (patid 7142); skipping read

    Can someone explain this?
    Thanks,
    Vishal

  • #2
    I don't know bowtie well, but what do the single end .sam entries look like for A2-8? Are they repetative? Are they way far apart?

    Comment


    • #3
      It seems that bowtie does not guarantee to find the best match, after several tries, it may give up.

      Comment


      • #4
        A couple of the default bowtie parameters for paired end data can cause you to lose hits you might want to keep.

        The 'exhausted memory' error can be fixed by adding --chunkmbs 512 to the bowtie options.

        Bowtie also has a strict limit (250bp) on the distance between paired sequences which is quite low. We tend to use --maxins 1000 to allow hits which are a bit further apart.

        Comment


        • #5
          I'm having similar problem. Currently using Bowtie for Illumina on Galaxy

          Single-end mapping with each dataset yield high number (similar number) of reads and coverage. However when I used paired-end mapping number of stacks were dramatically reduced (after applying filter). Regions of genome where you expect to have stacks aren't there?

          Tried increasing the insert size, it did yield more coverage.
          Is it because it needs to be in a proper pair?

          Also does seed length affect the outcome? E.g. sequences trimmed to 40bp and 25bp, for read1 and read2, respectively. When -l = 28, would read2 be considered as valid sequences?

          Comment


          • #6
            Yes, proper pairing does indeed matter. When both paired-ends are aligned together, the results will include only the alignments in which the paired-end are within a certain distance apart, and in the proper orientation. With SOLiD reads, properly paired-end reads must be directed toward each other, and on opposite strands. I'm not surprised that increasing the insertion size improves the results slightly. But when the reads of a pair are mapped to different chromosomes, then increasing the insertion size won't help.

            If your results are in BAM format, try running "flagstat" from samtools on it. This will give you pairing stats. In my experience, when the percentage of properly paired reads is very low (e.g. 5% - 10%), that indicates that the sequences may not be good.

            Adjusting the seed length probably won't improve the paired-end results. If you increase the seed length from 25 to 28, then read2 will probably have fewer alignments -- but they will be more confident alignments. If you shorten the seed length, then the reads will align in more places, and the number of paired-reads may increase slightly. But I believe that this approach simply creates false positives.

            Comment

            Working...
            X