No announcement yet.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error installing vcftools

    Hi! I downloaded the latest vcftools, moved it into my desktop file, then commanded:
    tar -zxvf vcftools_0.1.8a.tar.gz
    cd vcftools_0.1.8a

    However, I received the following error:

    make[1]: Entering directory `/home/lab/Desktop/linux files/vcftools_0.1.8a/cpp'
    g++ -O2 -Wall -Wextra vcftools.cpp vcf_file.cpp vcf_entry.cpp vcf_entry_getters.cpp vcf_entry_setters.cpp vcf_file_filters.cpp vcf_file_output.cpp vcf_file_format_convert.cpp vcf_file_diff.cpp parameters.cpp vcf_file_index.cpp output_log.cpp -o vcftools -lz
    vcf_file_output.cpp: In member function ‘void vcf_file:utput_PCA(const string&, bool, int)’:
    vcf_file_output.cpp:2774:6: warning: parameter ‘use_normalisation’ set but not used [-Wunused-but-set-parameter]
    vcf_file_output.cpp:2774:6: warning: parameter ‘SNP_loadings_N_PCs’ set but not used [-Wunused-but-set-parameter]
    vcf_file_format_convert.cpp: In member function ‘void vcf_file:utput_as_012_matrix(const string&)’:
    vcf_file_format_convert.cpp:453:7: warning: variable ‘phase’ set but not used [-Wunused-but-set-variable]
    cp /home/lab/Desktop/linux files/vcftools_0.1.8a/cpp/vcftools /home/lab/Desktop/ ./ ./ ./ 2012/vcftools_0.1.8a//bin/vcftools
    /bin/sh: Syntax error: Unterminated quoted string
    make[1]: *** [vcftools] Error 2
    make[1]: Leaving directory `/home/lab/Desktop/linux files/vcftools_0.1.8a/cpp'
    cd: 2: can't cd to perl
    make: *** [install] Error 2

    Any help would be very appreciated! Thanks!

  • #2
    It's possible that the space in "/home/lab/Desktop/linux files" is making trouble. Remove the space, or move the vcftools_0.1.8a directory to the Desktop, and try again.
    Last edited by Alex Renwick; 03-28-2012, 12:58 PM.


    • #3
      Awesome! That worked. Thank you!


      • #4
        Trouble installing vcf tools

        I downloaded vcf tools in my Mac. I had to download make, Tabix and vcf tools. I put the path for the perl directories in these two directories in my PATH variable. I ran make without error msgs. When I go into my vcftools and type per/test.t I am getting this msg.

        SARASHOMENWerl saras$ test.t
        Can't locate Test/ in @INC (@INC contains: /Users/saras/src/vcftools_0.1.8a/perl /saras/vcftools/perl /Library/Perl/Updates/5.10.0 /System/Library/Perl/5.10.0/darwin-thread-multi-2level /System/Library/Perl/5.10.0 /Library/Perl/5.10.0/darwin-thread-multi-2level /Library/Perl/5.10.0 /Network/Library/Perl/5.10.0/darwin-thread-multi-2level /Network/Library/Perl/5.10.0 /Network/Library/Perl /System/Library/Perl/Extras/5.10.0/darwin-thread-multi-2level /System/Library/Perl/Extras/5.10.0 .) at /Users/saras/src/vcftools_0.1.8a/perl/test.t line 17.
        BEGIN failed--compilation aborted at /Users/saras/src/vcftools_0.1.8a/perl/test.t line 17.
        SARASHOMENWerl saras$

        What is missing ? Please help. Thanks.



        • #5
          Trouble installing vcftools on a mac

          Hi everyone,
          I've got a similar problem as Saras and would really appreciate some help.

          I've downloaded vcftools to my /opt/local/bin directory (Mac), unpacked it, and have typed "make" in the vcftools folder. All but two lines in the output look good, however the two "problem" lines already show that something didn't work properly:

          cp: /opt/local/bin/vcftools_0.1.10/perl/fill-rsIDs: No such file or directory
          cp: /opt/local/bin/vcftools_0.1.10/perl/vcf-filter: No such file or directory

          When I try to run the test.t script with the following command:


          I get the following error message:

          Can't locate Test/ in @INC (@INC contains: /opt/local/bin/vcftools_0.1.10/perl /lib /Library/Perl/5.12/darwin-thread-multi-2level /Library/Perl/5.12 /Network/Library/Perl/5.12/darwin-thread-multi-2level /Network/Library/Perl/5.12 /Library/Perl/Updates/5.12.4 /System/Library/Perl/5.12/darwin-thread-multi-2level /System/Library/Perl/5.12 /System/Library/Perl/Extras/5.12/darwin-thread-multi-2level /System/Library/Perl/Extras/5.12 .) at /opt/local/bin/vcftools_0.1.10/perl/test.t line 17.
          BEGIN failed--compilation aborted at /opt/local/bin/vcftools_0.1.10/perl/test.t line 17.

          Has anyone run into something like this?

          Thanks in advance for any help.


          • #6
            Hi again, I've now got the first few problems solved:

            cp: /opt/local/bin/vcftools_0.1.10/perl/fill-rsIDs: No such file or directory
            cp: /opt/local/bin/vcftools_0.1.10/perl/vcf-filter: No such file or directory

            can be fixed if you "touch" the files fill-rsIDs and vcf-filter... the files don't do anything, but there is no error message anymore.

            Apparently the test.t executable doesn't work unless the the Test::Most package (perl) is installed. This can be installed using "cpan":
            1) export PERL5LIB=/path/to/your/installation/perl
            2) cpanm Test::Most
            3) cpan App::cpanminus

            Unfortunately I still can't get test.t to run smoothly....
            here the last 3 lines of output....

            # Looks like you planned 74 tests but ran 9.
            # Looks like you failed 6 tests of 9 run.
            # Looks like your test exited with 2 just after 9.


            • #7
              Hello CowGirl,

              I had the same issues with the two missing files. Thanks for suggesting the 'touch' fix, as it seems to have fixed the problem (fingers crossed)!

              In case you are still looking for a method to test the program: I found a fantastic website which gives really nice instructions on how to install all of the programs needed to run vcftools (g++, zlib, tabix, vcftools) and also contains a method for testing tabix and vcftools at the end of the page. See the following link:

              Getting Genetics Done (GGD) is a blog with tips, reviews, tutorials, and pointers to relevant literature in genetics and bioinformatics research.


              • #8
                Hey LML,
                thanks for the tip. I can't take credit for the "touch" strategy (a big "Thank you" to the colleaugues in Austria!).
                Unforunately I've already installed everything else (i.e. g++, zlib, tabix, vcftools) "the hard way" ;-) , but I'm sure others will find the information useful as well. Cheers
                Last edited by CowGirl; 04-17-2013, 09:25 PM.


                • #9
                  Hi all,

                  I have encountered an error when install vcftools version 9, 10 and 11 as following, but successfully for version 4a.

                  I also searched the problem "warning: the use of `tmpnam' is dangerous, better use `mkstemp'" and got this web page:

                  Any suggestions will be appreciated.


                  make[1]: Entering directory `/panfs/home/yangpc/soft/07.reseq/vcftools_0.1.11/cpp'
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  vcftools.cpp -o vcftools.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  vcftools.cpp > vcftools.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  bcf_file.cpp -o bcf_file.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  bcf_file.cpp > bcf_file.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  vcf_file.cpp -o vcf_file.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  vcf_file.cpp > vcf_file.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  variant_file.cpp -o variant_file.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  variant_file.cpp > variant_file.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  bcf_entry.cpp -o bcf_entry.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  bcf_entry.cpp > bcf_entry.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  vcf_entry.cpp -o vcf_entry.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  vcf_entry.cpp > vcf_entry.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  entry.cpp -o entry.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  entry.cpp > entry.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  entry_setters.cpp -o entry_setters.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  entry_setters.cpp > entry_setters.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  entry_getters.cpp -o entry_getters.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  entry_getters.cpp > entry_getters.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  vcf_entry_setters.cpp -o vcf_entry_setters.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  vcf_entry_setters.cpp > vcf_entry_setters.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  bcf_entry_setters.cpp -o bcf_entry_setters.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  bcf_entry_setters.cpp > bcf_entry_setters.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  variant_file_filters.cpp -o variant_file_filters.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  variant_file_filters.cpp > variant_file_filters.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  variant_file_output.cpp -o variant_file_output.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  variant_file_output.cpp > variant_file_output.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  variant_file_format_convert.cpp -o variant_file_format_convert.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  variant_file_format_convert.cpp > variant_file_format_convert.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  variant_file_diff.cpp -o variant_file_diff.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  variant_file_diff.cpp > variant_file_diff.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  header.cpp -o header.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  header.cpp > header.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  parameters.cpp -o parameters.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  parameters.cpp > parameters.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  variant_file_index.cpp -o variant_file_index.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  variant_file_index.cpp > variant_file_index.d
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  output_log.cpp -o output_log.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  output_log.cpp > output_log.d
                  gcc -O2 -m64 -O2 -D_FILE_OFFSET_BITS=64   -c -o bgzf.o bgzf.c
                  g++ -c -O2 -D_FILE_OFFSET_BITS=64  gamma.cpp -o gamma.o
                  g++ -MM -O2 -D_FILE_OFFSET_BITS=64  gamma.cpp > gamma.d
                  g++ -O2 -D_FILE_OFFSET_BITS=64  vcftools.o bcf_file.o vcf_file.o variant_file.o bcf_entry.o vcf_entry.o entry.o entry_setters.o entry_getters.o vcf_entry_setters.o   bcf_entry_setters.o variant_file_filters.o variant_file_output.o variant_file_format_convert.o variant_file_diff.o header.o parameters.o variant_file_index.o output_log.o bgzf.o gamma.o -o vcftools -lz 
                  variant_file_format_convert.o: In function `variant_file::output_as_LDhat_phased(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)':
                  variant_file_format_convert.cpp:(.text+0x41d3): warning: the use of `tmpnam' is dangerous, better use `mkstemp'
                  bcf_file.o: In function `bcf_file::get_filepos()':
                  bcf_file.cpp:(.text+0x125): undefined reference to `gztell64'
                  bcf_file.o: In function `bcf_file::get_eof()':
                  bcf_file.cpp:(.text+0x811): undefined reference to `gzseek64'
                  bcf_file.cpp:(.text+0x840): undefined reference to `gzseek64'
                  bcf_file.o: In function `bcf_file::open()':
                  bcf_file.cpp:(.text+0x1e27): undefined reference to `gzopen64'
                  bcf_file.cpp:(.text+0x1ec0): undefined reference to `gzbuffer'
                  bcf_file.o: In function `bcf_file::set_filepos(std::fpos<__mbstate_t>&)':
                  bcf_file.cpp:(.text+0x76): undefined reference to `gzseek64'
                  vcf_file.o: In function `vcf_file::get_filepos()':
                  vcf_file.cpp:(.text+0xd2): undefined reference to `gztell64'
                  vcf_file.o: In function `vcf_file::open()':
                  vcf_file.cpp:(.text+0xa5d): undefined reference to `gzopen64'
                  vcf_file.cpp:(.text+0xaf6): undefined reference to `gzbuffer'
                  vcf_file.o: In function `vcf_file::set_filepos(std::fpos<__mbstate_t>&)':
                  vcf_file.cpp:(.text+0x85): undefined reference to `gzseek64'
                  variant_file_filters.o: In function `variant_file::filter_sites_by_positions(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)':
                  variant_file_filters.cpp:(.text+0x630b): undefined reference to `gzopen64'
                  variant_file_filters.cpp:(.text+0x6ce3): undefined reference to `gzopen64'
                  variant_file_index.o: In function `variant_file::write_index_file(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)':
                  variant_file_index.cpp:(.text+0x1ca): undefined reference to `gzopen64'
                  variant_file_index.o: In function `variant_file::read_index_file(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)':
                  variant_file_index.cpp:(.text+0x7a1): undefined reference to `gzopen64'
                  collect2: ld returned 1 exit status
                  make[1]: *** [vcftools] Error 1
                  make[1]: Leaving directory `/panfs/home/yangpc/soft/07.reseq/vcftools_0.1.11/cpp'
                  /bin/sh: line 1: cd: perl: No such file or directory
                  make: *** [install] Error 1
                  Last edited by pengchy; 07-03-2013, 01:31 AM. Reason: add information


                  • #10
                    What version of zlib do you have currently installed? The "gz*" undefined references would point to absence (or presence of an older) version of zlib.


                    • #11
                      thanks GenoMax,

                      I have compiled successfully in another node, it seems caused by the absence of libz version.

                      Thank you.


                      • #12

                        I also have problems installing vcftools. More precisely:
                        I executed the test.t script, as suggested, and could solve nearly all problems instead vcf-stats

                        ok 13 - Testing next_data_array
                        not ok 14 - Testing vcf-stats .. perl -I/home/nancy/programs/vcftools_0.1.11/perl -MVcf /home/nancy/programs/vcftools_0.1.11/perl/vcf-stats /home/nancy/programs/vcftools_0.1.11/perl/../examples/valid-4.0.vcf
                        # Failed test 'Testing vcf-stats .. perl -I/home/nancy/programs/vcftools_0.1.11/perl -MVcf /home/nancy/programs/vcftools_0.1.11/perl/vcf-stats /home/nancy/programs/vcftools_0.1.11/perl/../examples/valid-4.0.vcf'
                        # at /home/nancy/programs/vcftools_0.1.11/perl/test.t line 165.
                        # Structures begin differing at:
                        # $got->[47] = ' 'other_count' => 2,
                        # '
                        # $expected->[47] = ' 'hom_AA_count' => 4,
                        # '
                        ok 15 - Testing add_columns with genotypes full, 4.0.

                        i have no clue what goes wrong here. anyone an idea?



                        • #13
                          when i am trying to install vcftools_0.1.12b:
                          kurban@kurban-X550VC:~/Downloads/vcftools_0.1.12b$ make
                          and it showed this:
                          make[1]: Entering directory `/home/kurban/Downloads/vcftools_0.1.12b/cpp'
                          g++ -c -O2 -D_FILE_OFFSET_BITS=64  vcftools.cpp -o vcftools.o
                          make[1]: g++: Command not found
                          make[1]: *** [vcftools.o] Error 127
                          make[1]: Leaving directory `/home/kurban/Downloads/vcftools_0.1.12b/cpp'
                          /bin/sh: 3: cd: can't cd to perl
                          make: *** [install] Error 2
                          before i do make ,it is required to do this:
                          export PERL5LIB=/path/to/your/vcftools-directory/perl/
                          and i expressed it in this way:
                          export PERL5LIB=/home/kurban/Downloads/vcftools_0.1.12b/perl
                          i am new at linux, so i did not know where i did wrong or what should i do. please give some corrections on this!!!


                          • #14
                            you're missing the C++ compiler.

                            If you're on a debian-based distro just do
                            sudo apt-get install g++
                            and try again.


                            • #15
                              Originally posted by Cytosine View Post
                              you're missing the C++ compiler.

                              If you're on a debian-based distro just do
                              sudo apt-get install g++
                              and try again.
                              thank you, that worked .
                              Last edited by kurban910; 08-10-2014, 06:19 AM.


                              Latest Articles


                              • seqadmin
                                Advanced Tools Transforming the Field of Cytogenomics
                                by seqadmin

                                At the intersection of cytogenetics and genomics lies the exciting field of cytogenomics. It focuses on studying chromosomes at a molecular scale, involving techniques that analyze either the whole genome or particular DNA sequences to examine variations in structure and behavior at the chromosomal or subchromosomal level. By integrating cytogenetic techniques with genomic analysis, researchers can effectively investigate chromosomal abnormalities related to diseases, particularly...
                                09-26-2023, 06:26 AM
                              • seqadmin
                                How RNA-Seq is Transforming Cancer Studies
                                by seqadmin

                                Cancer research has been transformed through numerous molecular techniques, with RNA sequencing (RNA-seq) playing a crucial role in understanding the complexity of the disease. Maša Ivin, Ph.D., Scientific Writer at Lexogen, and Yvonne Goepel Ph.D., Product Manager at Lexogen, remarked that “The high-throughput nature of RNA-seq allows for rapid profiling and deep exploration of the transcriptome.” They emphasized its indispensable role in cancer research, aiding in biomarker...
                                09-07-2023, 11:15 PM
                              • seqadmin
                                Methods for Investigating the Transcriptome
                                by seqadmin

                                Ribonucleic acid (RNA) represents a range of diverse molecules that play a crucial role in many cellular processes. From serving as a protein template to regulating genes, the complex processes involving RNA make it a focal point of study for many scientists. This article will spotlight various methods scientists have developed to investigate different RNA subtypes and the broader transcriptome.

                                Whole Transcriptome RNA-seq
                                Whole transcriptome sequencing...
                                08-31-2023, 11:07 AM





                              Topics Statistics Last Post
                              Started by seqadmin, 09-27-2023, 06:57 AM
                              0 responses
                              Last Post seqadmin  
                              Started by seqadmin, 09-26-2023, 07:53 AM
                              0 responses
                              Last Post seqadmin  
                              Started by seqadmin, 09-25-2023, 07:42 AM
                              0 responses
                              Last Post seqadmin  
                              Started by seqadmin, 09-22-2023, 09:05 AM
                              0 responses
                              Last Post seqadmin