Announcement

Collapse

Welcome to the New Seqanswers!

Welcome to the new Seqanswers! We'd love your feedback, please post any you have to this topic: New Seqanswers Feedback.
See more
See less

Celera Assembler runCA failed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Celera Assembler runCA failed

    Hello

    I would like to use the Celera assembler on a small data set for testing the installation.

    First, I made the frg file based on the sff file
    ~/apps/Celera/c/sffToCA -libraryname 0 -output my001.1.frg F032I7H01.sff

    Then, runCA
    ~/apps/Celera/c/runCA -p t -d . my001.1.frg

    The end of output, shortly before the error happens is:

    ----------------------------------------START CONCURRENT Tue Sep 8 09:27:41 2009
    /data/Celera/my001.1-test/./5-consensus/consensus.sh 1 > /dev/null 2>&1
    /data/Celera/my001.1-test/./5-consensus/consensus.sh 2 > /dev/null 2>&1
    /data/Celera/my001.1-test/./5-consensus/consensus.sh 3 > /dev/null 2>&1
    /data/Celera/my001.1-test/./5-consensus/consensus.sh 4 > /dev/null 2>&1
    /data/Celera/my001.1-test/./5-consensus/consensus.sh 5 > /dev/null 2>&1
    ----------------------------------------END CONCURRENT Tue Sep 8 09:31:57 2009 (256 seconds)
    /data/Celera/my001.1-test/./5-consensus/t_002 failed -- no .success or no .cgi!
    ================================================================================

    runCA failed.

    ----------------------------------------
    Stack trace:

    at /home/apps/Celera/c/runCA line 1005
    main::caFailure('1 consensusAfterUnitigger jobs failed', 'undef') called at /home/apps/Celera/c/runCA line 2252
    main:ostUnitiggerConsensus('/data/Celera/my001.1-test/./4-unitigge...', '/data/Celera/my001.1-test/./4-unitigge...', '/data/Celera/my001.1-test/./4-unitigge...', '/data/Celera/my001.1-test/./4-unitigge...', '/data/Celera/my001.1-test/./4-unitigge...') called at /home/apps/Celera/c/runCA line 4988

    ----------------------------------------
    Failure message:

    1 consensusAfterUnitigger jobs failed


    Does anybody have a solution?

    Thank you for your suggestions!

  • #2
    Originally posted by DNAjunk View Post
    Hello

    I would like to use the Celera assembler on a small data set for testing the installation.

    First, I made the frg file based on the sff file
    ~/apps/Celera/c/sffToCA -libraryname 0 -output my001.1.frg F032I7H01.sff

    Then, runCA
    ~/apps/Celera/c/runCA -p t -d . my001.1.frg
    What version of CA you are using?

    The end of output, shortly before the error happens is:

    ----------------------------------------START CONCURRENT Tue Sep 8 09:27:41 2009
    /data/Celera/my001.1-test/./5-consensus/consensus.sh 1 > /dev/null 2>&1
    /data/Celera/my001.1-test/./5-consensus/consensus.sh 2 > /dev/null 2>&1
    /data/Celera/my001.1-test/./5-consensus/consensus.sh 3 > /dev/null 2>&1
    /data/Celera/my001.1-test/./5-consensus/consensus.sh 4 > /dev/null 2>&1
    /data/Celera/my001.1-test/./5-consensus/consensus.sh 5 > /dev/null 2>&1
    ----------------------------------------END CONCURRENT Tue Sep 8 09:31:57 2009 (256 seconds)
    /data/Celera/my001.1-test/./5-consensus/t_002 failed -- no .success or no .cgi!
    ================================================================================

    runCA failed.

    ----------------------------------------
    Stack trace:

    at /home/apps/Celera/c/runCA line 1005
    main::caFailure('1 consensusAfterUnitigger jobs failed', 'undef') called at /home/apps/Celera/c/runCA line 2252
    main:ostUnitiggerConsensus('/data/Celera/my001.1-test/./4-unitigge...', '/data/Celera/my001.1-test/./4-unitigge...', '/data/Celera/my001.1-test/./4-unitigge...', '/data/Celera/my001.1-test/./4-unitigge...', '/data/Celera/my001.1-test/./4-unitigge...') called at /home/apps/Celera/c/runCA line 4988

    ----------------------------------------
    Failure message:

    1 consensusAfterUnitigger jobs failed


    Does anybody have a solution?

    Thank you for your suggestions!
    You should have a look at http://sourceforge.net/apps/mediawik...sensus_failure

    Let us know, if this has worked for you.

    cheers,
    Sven

    Comment


    • #3
      Thanks for your response.
      1)
      The version is

      [my001.1-test] ~/apps/Celera/c/runCA -version
      CA version 5.4 ($Id: AS_GKP_main.c,v 1.79 2009/03/05 18:36:04 skoren Exp $).
      CA version 5.4 ($Id: AS_OVL_overlap_common.h,v 1.54 2009/05/21 02:24:37 brianwalenz Exp $).
      CA version 5.4 ($Id: AS_CGB_unitigger.c,v 1.38 2009/05/21 02:24:37 brianwalenz Exp $).
      CA version 5.4 ($Id: BuildUnitigs.cc,v 1.57 2009/02/02 13:51:13 brianwalenz Exp $).
      CA version 5.4 ($Id: AS_CGW_main.c,v 1.70 2009/05/11 05:36:03 brianwalenz Exp $).
      CA version 5.4 ($Id: Consensus_CNS.c,v 1.77 2009/05/21 03:50:03 brianwalenz Exp $).
      CA version 5.4 ($Id: AS_TER_terminator.c,v 1.30 2008/10/29 06:34:30 brianwalenz Exp $).

      2)
      There is no 'Project'_xxx.failed but another "failed"-file called t_002.autofix.cgi.failed

      This is the content of the 5-consensus directory:
      t.partFile
      t.partitioned.err
      t.partitioned
      consensus.sh*
      consensus.cgi.input
      t_002.autofix.orig
      t_001.success
      t_001.err
      t_001.cgi
      t_002.err
      t_002.cgi
      t_002.autofix.log
      t_002.autofix.err
      t_002.autofix.cgi.failed
      t_002.autofix.cgi
      t_002.autofix
      t_003.success
      t_003.err
      t_003.cgi
      t_004.success
      t_004.err
      t_004.cgi
      t_005.success
      t_005.err
      t_005.cgi

      And the 4-unitigger directory:
      best.edges
      best.contains
      t.breaks.ovl
      unitigger.success
      unitigger.err
      t.unused.ovl
      t.iidmap
      t.cga.0
      t_005.cgb
      t_004.cgb
      t_003.cgb
      t_002.cgb
      t_001.cgb


      I couldn't find anything related to "autofix.cgi.failed".

      By the way, I didn't install the perl statistics module yet. But I guess the current error is due to something else.

      Comment

      Working...
      X