Announcement

Collapse
No announcement yet.

tophat installing problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • tophat installing problem

    Hi,

    I have installed tophat (v1.0.12) on Mac (10.6, gcc 4.2.1) and it works fine. Now I need to install tophat on Linux boxes (Debian gcc4.4 and Redhat gcc4.1.2), all failed.

    Here is the configure result:

    ======================

    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for g++... g++
    checking whether we are using the GNU C++ compiler... yes
    checking whether g++ accepts -g... yes
    checking for gawk... gawk
    checking for a BSD-compatible install... /usr/bin/install -c
    checking for ranlib... ranlib
    checking for ar... ar
    checking for perl... /usr/local/bin/perl
    checking for bash... /bin/bash
    checking for a Python interpreter with version >= 2.4... python
    checking for python... /usr/bin/python
    checking for python version... 2.4
    checking for python platform... linux2
    checking for python script directory... ${prefix}/lib/python2.4/site-packages
    checking for python extension module directory... ${exec_prefix}/lib/python2.4/site-packages
    checking if gcc accepts -m64... yes
    checking for gzread in -lz... no
    checking how to run the C++ preprocessor... g++ -E
    checking for grep that handles long lines and -e... /bin/grep
    checking for egrep... /bin/grep -E
    checking for ANSI C header files... no
    checking for sys/types.h... no
    checking for sys/stat.h... no
    checking for stdlib.h... no
    checking for string.h... no
    checking for memory.h... no
    checking for strings.h... no
    checking for inttypes.h... no
    checking for stdint.h... no
    checking for unistd.h... no
    checking for stdlib.h... (cached) no
    checking for string.h... (cached) no
    checking for unistd.h... (cached) no
    checking for stdbool.h that conforms to C99... no
    checking for _Bool... no
    checking for an ANSI C-conforming const... no
    checking for int32_t... no
    checking for size_t... no
    checking for uint32_t... no
    checking for uint64_t... no
    checking for uint8_t... no
    checking for special C compiler options needed for large files... no
    checking for _FILE_OFFSET_BITS value needed for large files... unknown
    checking for _LARGE_FILES value needed for large files... unknown
    checking for stdlib.h... (cached) no
    checking for GNU libc compatible malloc... no
    checking for memset... no
    checking for strdup... no
    checking for strrchr... no
    checking for strtol... no
    checking for strsep... no
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    checking whether make sets $(MAKE)... yes
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc3
    checking dependency style of g++... gcc3
    configure: creating ./config.status
    config.status: creating Makefile
    config.status: creating src/Makefile
    config.status: creating config.h
    config.status: config.h is unchanged
    config.status: executing depfiles commands

    -- TopHat 1.0.12 Configuration Results --
    C compiler: gcc -Wall -g -m64 -O3 -DNDEBUG
    C++ compiler: g++ -Wall -g -m64 -O3 -DNDEBUG
    GCC version: gcc (GCC) 4.1.2 20080704 (Red Hat 4.1.2-44)
    Host System type: i686-pc-linux-gnu
    Install prefix: /home/ds/software/tophat-1.0.12
    Install eprefix: ${prefix}

    See config.h for further configuration information.
    Email <[email protected]> with questions and bug reports.

    ======================
    Then make:

    make all-recursive
    make[1]: Entering directory `/home/ds/software/tophat-1.0.12'
    Making all in src
    make[2]: Entering directory `/home/ds/software/tophat-1.0.12/src'
    g++ -DHAVE_CONFIG_H -I. -I.. -Wall -g -m64 -O3 -DNDEBUG -I./SeqAn-1.1 -Wall -g -m64 -O3 -DNDEBUG -MT reads.o -MD -MP -MF .deps/reads.Tpo -c -o reads.o reads.cpp
    reads.cpp:1: sorry, unimplemented: 64-bit mode not compiled in
    /usr/lib/gcc/i386-redhat-linux/4.1.2/../../../../include/c++/4.1.2/cstddef:55: error: expected unqualified-id before 'unsigned'
    /usr/lib/gcc/i386-redhat-linux/4.1.2/../../../../include/c++/4.1.2/cstddef:55: error: expected `;' before 'unsigned'
    ....

    ======================


    I found there were several posts about similar installation problems of tophat, but couldn't find a solution for my case.

    Any suggestions? Thanks a lot!

  • #2
    I have the same problem.

    Installed fine on Mac, but same issue on current release of 64 bit Ubuntu.

    Comment


    • #3
      Problem solved. I mean I don't know the exact reason but I found it works well on Ubuntu 8.04.

      ChrisL, you might want to the trick of adding a "#include <cstdio>" line in gff_juncs.cpp. Good luck!

      Comment


      • #4
        Originally posted by deepsea View Post
        Here is the configure result:
        ======================
        checking build system type... i686-pc-linux-gnu
        checking host system type... i686-pc-linux-gnu
        [...]
        checking if gcc accepts -m64... yes
        [...]
        C compiler: gcc -Wall -g -m64 -O3 -DNDEBUG
        C++ compiler: g++ -Wall -g -m64 -O3 -DNDEBUG
        [...]
        reads.cpp:1: sorry, unimplemented: 64-bit mode not compiled in
        The problem is that you do not have an x86-64 compiler installed. The configure script should have detected this, but there is a bug that means it is not really "checking if gcc accepts -m64".

        You can try changing CFLAGS="-m64" on line 4028 of configure to CXXFLAGS="-m64" and rerunning configure, which will hopefully cause different flags to be shown on the "C compiler" and "C++ compiler" lines shown above and will build a 32-bit executable, which you do have a compiler for.

        (If you know autoconf, the bug is that it should be using CXXFLAGS before AC_COMPILE_IFELSE rather than CFLAGS due to AC_LANG(C++), and I've emailed Cole to that effect.)

        -- John

        Comment


        • #5
          Thanks John!

          Now it works! Thank you so much! :-D

          Comment


          • #6
            I have tried to Install this on Mac however I seem unable to. I have moved all the bowtie files and installed Python. I get stuck on this bit:

            ./configure --prefix=/path/to/install/directory/

            I get this:

            ./configure: No such file or directory

            I'm a bit of a newbie to UNIX is there a different command for 'configure' and 'make' in bash on OSX?

            I'm running bash on OS X Leopard.

            Thanks, James

            Comment


            • #7
              James, try running ./autogen.sh first, then proceed with ./configure.

              Comment


              • #8
                hey guys, want to install tophat on ubuntu 10.4 64 bit but get this freakin error:...

                the configure seems to be well:
                ./configure CFLAGS="-m64" CXXFLAGS="-m64"
                checking build system type... x86_64-unknown-linux-gnu
                checking host system type... x86_64-unknown-linux-gnu
                checking for gcc... gcc
                checking for C compiler default output file name... a.out
                checking whether the C compiler works... yes
                checking whether we are cross compiling... no
                checking for suffix of executables...
                checking for suffix of object files... o
                checking whether we are using the GNU C compiler... yes
                checking whether gcc accepts -g... yes
                checking for gcc option to accept ISO C89... none needed
                checking for g++... g++
                checking whether we are using the GNU C++ compiler... yes
                checking whether g++ accepts -g... yes
                checking for gawk... gawk
                checking for a BSD-compatible install... /usr/bin/install -c
                checking for ranlib... ranlib
                checking for ar... ar
                checking for perl... /usr/bin/perl
                checking for bash... /bin/bash
                checking for a Python interpreter with version >= 2.4... python
                checking for python... /usr/bin/python
                checking for python version... 2.6
                checking for python platform... linux2
                checking for python script directory... ${prefix}/lib/python2.6/site-packages
                checking for python extension module directory... ${exec_prefix}/lib/python2.6/site-packages
                checking if gcc accepts -m64... yes
                checking for gzread in -lz... no
                checking how to run the C++ preprocessor... g++ -E
                checking for grep that handles long lines and -e... /bin/grep
                checking for egrep... /bin/grep -E
                checking for ANSI C header files... yes
                checking for sys/types.h... yes
                checking for sys/stat.h... yes
                checking for stdlib.h... yes
                checking for string.h... yes
                checking for memory.h... yes
                checking for strings.h... yes
                checking for inttypes.h... yes
                checking for stdint.h... yes
                checking for unistd.h... yes
                checking for stdlib.h... (cached) yes
                checking for string.h... (cached) yes
                checking for unistd.h... (cached) yes
                checking for stdbool.h that conforms to C99... yes
                checking for _Bool... no
                checking for an ANSI C-conforming const... yes
                checking for int32_t... yes
                checking for size_t... yes
                checking for uint32_t... yes
                checking for uint64_t... yes
                checking for uint8_t... yes
                checking for special C compiler options needed for large files... no
                checking for _FILE_OFFSET_BITS value needed for large files... no
                checking for stdlib.h... (cached) yes
                checking for GNU libc compatible malloc... yes
                checking for memset... yes
                checking for strdup... yes
                checking for strrchr... yes
                checking for strtol... yes
                checking for strsep... yes
                checking whether build environment is sane... yes
                checking for a thread-safe mkdir -p... /bin/mkdir -p
                checking whether make sets $(MAKE)... yes
                checking for style of include used by make... GNU
                checking dependency style of gcc... gcc3
                checking dependency style of g++... gcc3
                configure: creating ./config.status
                config.status: creating Makefile
                config.status: creating src/Makefile
                config.status: creating config.h
                config.status: config.h is unchanged
                config.status: executing depfiles commands

                -- TopHat 1.0.12 Configuration Results --
                C compiler: gcc -Wall -g -m64 -O3 -m64 -DNDEBUG
                C++ compiler: g++ -Wall -g -m64 -O3 -m64 -DNDEBUG
                GCC version: gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
                Host System type: x86_64-unknown-linux-gnu
                Install prefix: /home/lokadmin/.local/share/Trash/files/tophat-1.3.0.12
                Install eprefix: ${prefix}

                See config.h for further configuration information.
                Email <[email protected]> with questions and bug reports.


                but then when typing make error occurs:

                [email protected]:~/Desktop/Mapping/tophat-1.0.12$ make
                make all-recursive
                make[1]: Betrete Verzeichnis '/home/lokadmin/.local/share/Trash/files/tophat-1.3.0.12'
                Making all in src
                make[2]: Betrete Verzeichnis '/home/lokadmin/.local/share/Trash/files/tophat-1.3.0.12/src'
                g++ -DHAVE_CONFIG_H -I. -I.. -Wall -g -m64 -O3 -m64 -DNDEBUG -I./SeqAn-1.1 -Wall -g -m64 -O3 -m64 -DNDEBUG -MT gff_juncs.o -MD -MP -MF .deps/gff_juncs.Tpo -c -o gff_juncs.o gff_juncs.cpp
                gff_juncs.cpp: In function ‘void print_usage()’:
                gff_juncs.cpp:25: error: ‘stderr’ was not declared in this scope
                gff_juncs.cpp:25: error: ‘fprintf’ was not declared in this scope
                gff_juncs.cpp: In function ‘uint32_t get_junctions_from_gff(const fsa::GFF_database&)’:
                gff_juncs.cpp:144: error: ‘stderr’ was not declared in this scope
                gff_juncs.cpp:144: error: ‘fprintf’ was not declared in this scope
                gff_juncs.cpp:153: error: ‘stdout’ was not declared in this scope
                gff_juncs.cpp:157: error: ‘fprintf’ was not declared in this scope
                gff_juncs.cpp: In function ‘int main(int, char**)’:
                gff_juncs.cpp:189: error: ‘stderr’ was not declared in this scope
                gff_juncs.cpp:189: error: ‘fprintf’ was not declared in this scope
                make[2]: *** [gff_juncs.o] Fehler 1
                make[2]: Verlasse Verzeichnis '/home/lokadmin/.local/share/Trash/files/tophat-1.3.0.12/src'
                make[1]: *** [all-recursive] Fehler 1
                make[1]: Verlasse Verzeichnis '/home/lokadmin/.local/share/Trash/files/tophat-1.3.0.12'
                make: *** [all] Fehler 2


                didnt know how to fix it, can u help me?


                regards sphil

                Comment


                • #9
                  I believe the problem is the older version.. I think I had similar issues when I tried using that one. Instead try to install this one: http://tophat.cbcb.umd.edu/downloads...-1.0.13.tar.gz

                  Comment


                  • #10
                    Hello Sphil I'm having a similar problem as you but I'm using the 1.0.14 version. The configure works just fine but after trying make I get this error

                    if g++ -DHAVE_CONFIG_H -I. -I. -I.. -Wall -m64 -O3 -DNDEBUG -I./SeqAn-1.1 -Wall -m64 -O3 -DNDEBUG -MT common.o -MD -MP -MF ".deps/common.Tpo" -c -o common.o common.cpp; \
                    then mv -f ".deps/common.Tpo" ".deps/common.Po"; else rm -f ".deps/common.Tpo"; exit 1; fi
                    common.cpp: In function ‘void err_exit(const char*, ...)’:
                    common.cpp:311: error: ‘stderr’ was not declared in this scope
                    common.cpp:311: error: ‘vfprintf’ was not declared in this scope
                    make[2]: *** [common.o] Error 1
                    make[2]: Leaving directory `/home/doggysaywhat/share/apps/tophat-1.0.14/src'
                    make[1]: *** [all-recursive] Error 1
                    make[1]: Leaving directory `/home/doggysaywhat/share/apps/tophat-1.0.14'
                    make: *** [all] Error 2

                    I did some reading looking for what could cause this in various programs and it could be a problem with the GCC compiler I was using. I went through the suggestion of adding the line
                    #include <cstdio> to each .cpp file but I kept getting the same error.

                    Where you ever able to find a solution to the problem?

                    Comment


                    • #11
                      Hey,ya i was able to solve it, just tried the other version ,as mentioned to me ,and then it works fine. Currently i don't know where the problem is of u won't Change the version.

                      Cheers phil

                      Comment


                      • #12
                        Hello Sphil, I also switched to version 1.0.13 and so far it seems to compile. Odd though that the newer version is having the problem but the older version runs fine. I noticed that they had a pre-compiled version 1.0.14 on their website and I'm probably going to try it since it was supposed to have improved error checking.

                        Thanks for the help,
                        Doggysaywhat

                        Comment


                        • #13
                          Originally posted by doggysaywhat View Post
                          common.cpp:311: error: ‘stderr’ was not declared in this scope
                          common.cpp:311: error: ‘vfprintf’ was not declared in this scope

                          I went through the suggestion of adding the line #include <cstdio> to each .cpp file but I kept getting the same error.
                          I found adding #include <cstdio> to the top of src/common.cpp to be sufficient to make tophat 1.0.14 compile successfully with a recent version of GCC that doesn't let you get away with forgetting this header.

                          -- John

                          Comment


                          • #14
                            oh, thanks a lot. this might be quiet helpful for further mappings...

                            Comment

                            Working...
                            X