Announcement

Collapse
No announcement yet.

Strange memory corruption error in BFAST match step

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Excellent, could you post your fastq, how you created your indexes, and the small test FASTQ, so I can try to reproduce the behavior on my own machine?

    Comment


    • #17
      Thanks.
      Here is how I converted the reference genome, indexed it and tried to make the alignment.
      - converting genome
      /mnt/fastfs/bin/bfast fasta2brg -A 1 -f refseq.fas

      - INDEXING
      qsub -q cb_quad -b y -e /mnt/fastfs/KW_Temp/bfast -o /mnt/fastfs/KW_Temp/bfast "/mnt/fastfs/bin/bfast index -f /mnt/fastfs/KW_Temp/bfast/refseq.fas -m <for each mask> -w 14 -A 1 -i <mask number>"

      MASKS
      M1 = 1111111111111111111111
      M2 = 111110100111110011111111111
      M3 = 10111111011001100011111000111111
      M4 = 1111111100101111000001100011111011
      M5 = 111111110001111110011111111
      M6 = 11111011010011000011000110011111111
      M7 = 1111111111110011101111111
      M8 = 111011000011111111001111011111
      M9 = 1111111111110011101111111
      M10 = 1110110001011010011100101111101111

      -ALIGNING:
      qsub -q cb_quad -b y -e /mnt/fastfs/KW_Temp/bfast -o /mnt/fastfs/KW_Temp/bfast "/mnt/fastfs/bin/bfast match -f /mnt/fastfs/KW_Temp/bfast/refseq.fas -A 1 -r /mnt/fastfs/KW_Temp/input.fastq > /mnt/fastfs/KW_Temp/bfast/output.bmf"

      I have done one test:
      I extracted 5 seqs from fastq file and run test against this tiny file. It run without the problem.
      It is really strange as using "-s 1 -e 5" options on full data set, so in fact providing the same sequences, causes the error reported earlier.

      K

      Comment


      • #18
        Could you post a link to the files?

        Comment


        • #19
          After we encountered the malloc error, we noticed our fastq was in color space but our bfast commands were for nucleotide space. We then created brg and index files in color space, then successfully ran match in color space.

          Comment


          • #20
            Bfast Malloc memory error

            Hi,
            Has there been a solution to the Malloc memory error when running Bfast?

            I am having the same problem when trying to run bfast bwaaln

            bfast+bwa-0.7.0a/bfast/bfast bwaaln -n 0.04 -o 1 -e -1 -d 5 -i 5 -l 25 -k 2 -M 3 -t 8 -O 11 -E 4 -c -q 20 bfast_bwa_index/hg18_noran_mask.fa T3460_R3.fastq > bfast_matches_R3_bwa_T3460.bmf
            [bwa_aln] 17bp reads: max_diff = 2
            [bwa_aln] 38bp reads: max_diff = 3
            [bwa_aln] 64bp reads: max_diff = 4
            [bwa_aln] 93bp reads: max_diff = 5
            [bwa_aln] 124bp reads: max_diff = 6
            [bwa_aln] 157bp reads: max_diff = 7
            [bwa_aln] 190bp reads: max_diff = 8
            [bwa_aln] 225bp reads: max_diff = 9
            [bwa_read_seq] 2.0% bases are trimmed.
            [bwa_aln_core] calculate SA coordinate... 138.80 sec
            [bwa_aln_core] write to the disk... ************************************************************
            In function "bwa_aln_core": Fatal Error[MallocMemory]. Message: Could not allocate (malloc) memory.
            ***** Exiting due to errors *****

            I am running on Ubuntu with 32 Gb RAM.

            Any help would be greatly appreciated

            thanks alig

            Comment


            • #21
              Could you post your data somewhere so that I can try to reproduce?

              Each option has a default setting, which you seem to be using, so you can omit specifying them.

              Comment


              • #22
                Bfast Malloc memory error

                Hi,

                I tried with a hugely smaller dataset & didn't get the error. So then I tried with a different fastq file which I had run through a script to remove any entries which look broken and also had run through fastq_quality_filter. This also did not produce the error.

                So I am hopeful that this was an issue with poor quality data.

                Thanks

                alig

                Comment

                Working...
                X