No announcement yet.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Troubleshooting installation of BLAST+


    I've got a copy of ncbi-blast-2.2.30+.dmg. The installer runs as expected and reports successful installation to my HD. However, I then can't find the application anywhere on my HD.

    What's up?

    I have an Administrator account on a Mac running OS X 10.10.2.

    Any advice would be most welcome.

    Thanks in advance.

  • #2
    In "/usr/local/ncbi/blast/bin".

    Even though installer has a GUI you will need to run blast using command line in a terminal.


    • #3
      Thanks for your reply.

      Apologies as I should have also said in my earlier post that I've checked, both through the Terminal and through the Finder, and it seems I don't have a file of directory named 'Local'.

      Still no Blast+.


      • #4
        Can you try making a directory called local in /usr (I had one from a different install)? Blast may assume that the directory exists (it does on linux where blast development likely occurs). I am surprised that the installer did not throw an error.

        Are you doing the install from an account that has admin privileges?
        Last edited by GenoMax; 03-12-2015, 04:23 AM.


        • #5
          Thanks again for your reply.

          I tried as you suggested but had the same result. The /Local (or /local) folder remains empty even though the installer says everything went well.

          Very frustrating.


          • #6
            BTW: I am running as Administrator on my machine.


            • #7
              Directory needs to be under /usr (not as /local). You will have to do

              $ sudo mkdir /usr/local
              $ sudo mkdir /usr/local/ncbi
              $ sudo mkdir /usr/local/ncbi/blast
              Is this where you made the directories?


              • #8
                I did it in Finder at my home folder. I haven't made subfolders for ncbi or blast.

                Hopefully that wasn't a #facepalm I just heard from over there.

                I assume usr is my user name as it appears on my home folder?


                • #9
                  Originally posted by AGL View Post
                  Hopefully that wasn't a #facepalm I just heard from over there.

                  I assume usr is my user name as it appears on my home folder?

                  "usr" is a real system directory (off the root "/" partition). It is NOT your user account directory. Issue the commands I posted above from a terminal window (you will need to provide your password again, you said you have admin privileges on your account).

                  If /usr does not exist on your machine then make that directory first.

                  $ sudo mkdir /usr


                  • #10

                    I ran through all sudo commands. In all cases the terminal returned 'File exists'

                    I hate to say I don't get it but I don't. Guess I've got a lot of reading to do on basic Terminal commands before I can access BLAST.

                    Thanks for taking the time.


                    • #11
                      Can you do the following (in a terminal window) and tell us what happens?

                      $ ls -l /usr/local/ncbi/blast/bin
                      $ /usr/local/ncbi/blast/bin/blastn -help
                      I have a feeling you have the programs installed (if you are getting that files exists message).


                      • #12

                        However, this is what I get from the bin:

                        Sebastians-iMac:~ Seb$ ls -l /usr/local/ncbi/blast/bin
                        total 1527440
                        -rwxrwxr-x 1 3755 5333 46133784 27 Oct 23:09 blast_formatter
                        -rwxrwxr-x 1 3755 5333 28238464 27 Oct 23:09 blastdb_aliastool
                        -rwxrwxr-x 1 3755 5333 32282276 27 Oct 23:09 blastdbcheck
                        -rwxr-xr-x 1 3755 5333 40530656 27 Oct 23:09 blastdbcmd
                        -rwxr-xr-x 1 3755 5333 46121556 27 Oct 23:08 blastn
                        -rwxr-xr-x 1 3755 5333 46113260 27 Oct 23:08 blastp
                        -rwxr-xr-x 1 3755 5333 46113260 27 Oct 23:08 blastx
                        -rwxrwxr-x 1 3755 5333 29698756 27 Oct 23:09 convert2blastmask
                        -rwxrwxr-x 1 3755 5333 46369232 27 Oct 23:09 deltablast
                        -rwxr-xr-x 1 3755 5333 29935496 27 Oct 23:09 dustmasker
                        -rwxr-xr-x 1 3755 5333 51345 28 Jun 2010
                        -rwxr-xr-x 1 3755 5333 32293864 27 Oct 23:09 makeblastdb
                        -rwxr-xr-x 1 3755 5333 31012976 27 Oct 23:09 makembindex
                        -rwxrwxr-x 1 3755 5333 30376380 27 Oct 23:09 makeprofiledb
                        -rwxr-xr-x 1 3755 5333 46208788 27 Oct 23:08 psiblast
                        -rwxr-xr-x 1 3755 5333 46180436 27 Oct 23:09 rpsblast
                        -rwxr-xr-x 1 3755 5333 46180440 27 Oct 23:09 rpstblastn
                        -rwxr-xr-x 1 3755 5333 30537996 27 Oct 23:09 segmasker
                        -rwxr-xr-x 1 3755 5333 46171672 27 Oct 23:08 tblastn
                        -rwxr-xr-x 1 3755 5333 46113260 27 Oct 23:08 tblastx
                        -rwxrwxr-x 1 3755 5333 12486 11 Sep 2014
                        -rwxr-xr-x 1 3755 5333 35312540 27 Oct 23:09 windowmasker

                        Check the dates. Do I actually have a legacy version installed?

                        The -help command you sent through didn't work (No such file or directory).

                        I ran the uninstaller before re-running the installer.


                        • #13
                          Actually, scratch that last.

                          All good.

                          Found the help file.

                          Thanks heaps!


                          • #14
                            Indeed the programs are installed! You have the latest version (that is when they were built at NCBI).

                            What I don't understand is why you did not get an output for -help command. If you copied and pasted the command from above then do not copy the leading $. Your file permissions look correct so you should get help for blastn printed to screen. Try again.


                            • #15
                              Yes, found it. Typographical error.

                              Thanks very much for all your help.


                              Latest Articles


                              • seqadmin
                                Advanced Tools Transforming the Field of Cytogenomics
                                by seqadmin

                                At the intersection of cytogenetics and genomics lies the exciting field of cytogenomics. It focuses on studying chromosomes at a molecular scale, involving techniques that analyze either the whole genome or particular DNA sequences to examine variations in structure and behavior at the chromosomal or subchromosomal level. By integrating cytogenetic techniques with genomic analysis, researchers can effectively investigate chromosomal abnormalities related to diseases, particularly...
                                09-26-2023, 06:26 AM
                              • seqadmin
                                How RNA-Seq is Transforming Cancer Studies
                                by seqadmin

                                Cancer research has been transformed through numerous molecular techniques, with RNA sequencing (RNA-seq) playing a crucial role in understanding the complexity of the disease. Maša Ivin, Ph.D., Scientific Writer at Lexogen, and Yvonne Goepel Ph.D., Product Manager at Lexogen, remarked that “The high-throughput nature of RNA-seq allows for rapid profiling and deep exploration of the transcriptome.” They emphasized its indispensable role in cancer research, aiding in biomarker...
                                09-07-2023, 11:15 PM
                              • seqadmin
                                Methods for Investigating the Transcriptome
                                by seqadmin

                                Ribonucleic acid (RNA) represents a range of diverse molecules that play a crucial role in many cellular processes. From serving as a protein template to regulating genes, the complex processes involving RNA make it a focal point of study for many scientists. This article will spotlight various methods scientists have developed to investigate different RNA subtypes and the broader transcriptome.

                                Whole Transcriptome RNA-seq
                                Whole transcriptome sequencing...
                                08-31-2023, 11:07 AM





                              Topics Statistics Last Post
                              Started by seqadmin, Yesterday, 06:57 AM
                              0 responses
                              Last Post seqadmin  
                              Started by seqadmin, 09-26-2023, 07:53 AM
                              0 responses
                              Last Post seqadmin  
                              Started by seqadmin, 09-25-2023, 07:42 AM
                              0 responses
                              Last Post seqadmin  
                              Started by seqadmin, 09-22-2023, 09:05 AM
                              0 responses
                              Last Post seqadmin