Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • compiling of cufflinks failed due to bamlib error

    Hi there,

    I know this issue has been addressed already in the instructions and also in some other forums. However, since I don't get it resolved after spending loads of time I hope someone can help me sorting out my problem:

    I am trying to compile the latest version of cufflinks (2.2.1) according to instructions given here http://cole-trapnell-lab.github.io/c...tting_started/ but I end up with the error

    checking for bamlib... configure: error: We could not detect the bam libraries (version or higher). If you have a staged bam library (still not installed) please specify $BAM_ROOT in your environment and do not give a PATH to --with-bam option. If you are sure you have bam installed, then check your version number looking in <bam/version.hpp>. See http://randspringer.de/bam for more documentation.

    From the instructions and having a look into the configure file I understand that in the first place the standard location /usr/local is searched for the samtools files which have to be organised as follows


    /usr/local/include/bam #has to contain the header files *.h
    /usr/local/lib #has to contain libbam.a

    and the samtools binary needs to go somewhere in $PATH .

    Since I only can do local installations I generated a folder in my home /home/group/user/:

    /home/group/user/bin/samtools

    and set up the structure described above:

    /home/group/user/bin/samtools
    /home/group/user/bin/samtools/lib containing the libbam.a file
    /home/group/user/bin/samtools/include/bam containing all the header files

    then added the directory to PATH by:

    export PATH=$PATH:/home/group/user/bin/samtools

    and executed configure using

    ./configure --prefix=/home/group/user/cufflinks/src/ --with-eigen=/home/group/user/Eigen/

    and get the following output:

    bash-4.2$ ./configure --prefix=/home/group/user/cufflinks/src/ --with-eigen=/home/group/user/Eigen/
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for gawk... (cached) gawk
    checking for g++... g++
    checking for C++ compiler default output file name... a.out
    checking whether the C++ compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C++ compiler... yes
    checking whether g++ accepts -g... yes
    checking for style of include used by make... GNU
    checking dependency style of g++... gcc3
    checking for gcc... gcc
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ANSI C... none needed
    checking dependency style of gcc... gcc3
    checking whether make sets $(MAKE)... (cached) yes
    checking for ranlib... ranlib
    checking for a BSD-compatible install... /usr/bin/install -c
    checking for a Python interpreter with version >= 2.4... python
    checking for python... /usr/bin/python
    checking for python version... 2.7
    checking for python platform... linux2
    checking for python script directory... ${prefix}/lib/python2.7/site-packages
    checking for python extension module directory... ${exec_prefix}/lib64/python2.7/site-packages
    checking for boostlib >= 1.47.0... yes
    checking for bamlib... configure: error: We could not detect the bam libraries (version or higher). If you have a staged bam library (still not installed) please specify $BAM_ROOT in your environment and do not give a PATH to --with-bam option. If you are sure you have bam installed, then check your version number looking in <bam/version.hpp>. See http://randspringer.de/bam for more documentation.

    I really tried everything suggested in the forums such setting the BAM_ROOT variable but I cannot work out what the problem is!

    Can you please help? I am sure there is something stupid I am missing and and blind for after countless times of trying...

    Many thanks!

    Kristian

  • #2
    I am having the same issues, installing at root, even after following instructions I found for dealing with the problem. I also tried installing with homebrew and got the same error:

    ==> ./configure --prefix=/usr/local/Cellar/cufflinks/2.2.1 --mandir=/usr/local/Cellar/cufflinks/2.2.
    checking for python platform... darwin
    checking for python script directory... ${prefix}/lib/python2.7/site-packages
    checking for python extension module directory... ${exec_prefix}/lib/python2.7/site-packages
    checking for boostlib >= 1.47.0... yes
    checking for bamlib... configure: error: We could not detect the bam libraries (version or higher). If you have a staged bam library (still not installed) please specify $BAM_ROOT in your environment and do not give a PATH to --with-bam option. If you are sure you have bam installed, then check your version number looking in <bam/version.hpp>. See http://randspringer.de/bam for more documentation.
    Any help would be hugely appreciated!

    Comment


    • #3
      Installing current samtools already results in a "correct" directory structure with 'include', 'lib' etc.

      1) put samtools in bin or install current samtools and export path to
      export /path/to/samtools/bin:$PATH
      2) configure, pointing to lib dir,
      export CPPFLAGS="-I/path/to/eigen/include/eigen3"

      ./configure --prefix=/path/to/cufflinks/2.2.1 --with-boost=/path/to/boost --with-bam=/path/to/samtools/lib --with-eigen=/path/to/eigen
      [...]
      checking for boostlib >= 1.47.0... yes
      checking for bamlib... yes
      checking for eigenlib... yes
      [...]
      This should at least make configure work ...

      best,
      Sven

      Comment


      • #4
        Additional procedure is necessary.

        Furthermore, you need an additional step.
        You need to copy version.h to version.hpp.

        $ cp /to/path/samtools/include/bam/version.h /to/path/samtools/include/bam/version.hpp

        My issue is sorted out by the above procedure.

        Comment

        Latest Articles

        Collapse

        • seqadmin
          Advanced Tools Transforming the Field of Cytogenomics
          by seqadmin


          At the intersection of cytogenetics and genomics lies the exciting field of cytogenomics. It focuses on studying chromosomes at a molecular scale, involving techniques that analyze either the whole genome or particular DNA sequences to examine variations in structure and behavior at the chromosomal or subchromosomal level. By integrating cytogenetic techniques with genomic analysis, researchers can effectively investigate chromosomal abnormalities related to diseases, particularly...
          09-26-2023, 06:26 AM
        • seqadmin
          How RNA-Seq is Transforming Cancer Studies
          by seqadmin



          Cancer research has been transformed through numerous molecular techniques, with RNA sequencing (RNA-seq) playing a crucial role in understanding the complexity of the disease. Maša Ivin, Ph.D., Scientific Writer at Lexogen, and Yvonne Goepel Ph.D., Product Manager at Lexogen, remarked that “The high-throughput nature of RNA-seq allows for rapid profiling and deep exploration of the transcriptome.” They emphasized its indispensable role in cancer research, aiding in biomarker...
          09-07-2023, 11:15 PM

        ad_right_rmr

        Collapse

        News

        Collapse

        Topics Statistics Last Post
        Started by seqadmin, 09-29-2023, 09:38 AM
        0 responses
        10 views
        0 likes
        Last Post seqadmin  
        Started by seqadmin, 09-27-2023, 06:57 AM
        0 responses
        13 views
        0 likes
        Last Post seqadmin  
        Started by seqadmin, 09-26-2023, 07:53 AM
        0 responses
        30 views
        0 likes
        Last Post seqadmin  
        Started by seqadmin, 09-25-2023, 07:42 AM
        0 responses
        18 views
        0 likes
        Last Post seqadmin  
        Working...
        X