Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cuffcompare Xlocus error

    Hi all -

    I've been struggling with a strange error in CuffCompare.

    I'm using the new cufflinks package (0.8.3) for 4 samples mapped using Tophat. After generating Cufflinks GTFs for each sample, I feed them into cuffcompare with a reference GTF:

    ./cuffcompare -r Reference.GTF sample1.gtf sample2.gtf sample3.gtf sample4.gtf

    Cuffcompare seems to be running smoothly, but before completing the run it crashes out with the following error:

    Error: no XLocus created for transcript CUFF.65771.1 (file sample4.gtf) [1, 0], on scaffold_1344+:43528-44023

    Has anyone seen this error before? I'm not sure why it would not generate and XLOC value.

    If I run cuffcompare on the 4 samples without a reference GTF, it works fine. However, if I run cuffcompare with the first 2 samples and the reference GTF, it also works fine.

    I am using an unassembled genome (X. tropicalis) that is split up into around 17,000 contig scaffolds. However, this didn't give me any problems in bowtie, tophat, or Cufflinks transcript assembly.

    I'd appreciate any help offered. Thanks!

  • #2
    Still really looking for some assistance on this - I'm totally stumped. Anyone have any ideas?

    Thanks.

    Comment


    • #3
      Cuffcompare Xlocus error

      Hi --

      Yes, I have encountered this exact same error as well. The error appeared sporadically for me, but always when I used a reference GTF (exactly as you mentioned).

      Geo Pertea was extremely helpful and worked through several possible bug sources with me to help identify whether it was a problem in the tool or a problem with the way I was running it. We went through several different hypotheses and found some subtle bugs along the way, but in the end I still got the error on rare occasions. I thought I was probably the only one so I stopped bothering Geo about it.

      Currently I am running Cuffcompare without a reference and then performing different comparisons to the reference using BEDTools/galaxy/bx-python intersections. This way I am able to classify the transcripts, albeit crudely.

      Best regards,

      Comment


      • #4
        Hi,

        I also got the same error msg, even without a reference.

        Did you find the explanation?

        Comment


        • #5
          the same problem here. :-(

          Comment


          • #6
            +1
            I also observed this in some cases, always with a reference, up to now. If I refer to the corresponding source code

            Code:
                  else {
                    //if (ft!=NULL) fprintf(ft,"noXLocus\t"); //should NEVER happen!
                    int fidx=(qtdata->eqdata & 0x0FFF);
                    GError("Error: no XLocus created for transcript %s (file %s) [%d, %d], on %s%c:%d-%d\n", qt.getID(),
                                       qryfiles[qtdata->locus->qfidx]->chars(), qtdata->locus->qfidx, fidx, qt.getGSeqName(), qt.strand, qt.start, qt.end);
                    }
            this is actually a bug, even if we did something wrong with the inputs. Has anyone contacted the authors about this problem ?

            Comment


            • #7
              pveber, do you know how to fix the bug? Thanks!

              Comment


              • #8
                Frankly not, sorry. Unfortunately I do not have time at the moment to investigate this any further. Sorry !

                Comment


                • #9
                  Thanks anyway, pveber! Hope Cole will fix it in the coming release.

                  Comment


                  • #10
                    Seeing this error in v0.9.3, no reference annotation

                    I'm seeing this error in v0.9.3 using a Cufflinks GTF file that was generated without a reference annotation:

                    --
                    Error: no XLocus created for transcript CUFF.240853.1 (file M_californicus.gtf) [1, 0], on gi|306738431|gb|AAPE02014593.1|+:16969-26889
                    --

                    Ideas anyone?

                    J.
                    Last edited by jgoecks; 01-28-2011, 11:57 AM. Reason: Include error message generated by Cuffcompare.

                    Comment


                    • #11
                      Same here. It seems like, it depends on the order of the samples. When I run

                      cuffcompare -o OUT -r hg19.ensembl-for-tophat.gtf -s /fasta/ 02/transcripts.gtf 04/transcripts.gtf 08/transcripts.gtf 10/transcripts.gtf 11/transcripts.gtf 12/transcripts.gtf 13/transcripts.gtf 15/transcripts.gtf 17/transcripts.gtf 20/transcripts.gtf 21/transcripts.gtf 22/transcripts.gtf 24/transcripts.gtf 29/transcripts.gtf
                      Cuffcompare reports this error

                      Error: no XLocus created for transcript CUFF.661691.1 (file 10/transcripts.gtf) [3, 0], on chr21-:46096860-46097549
                      When I leave out the erroneous sample 10, no error occurs. BUT, and this is very strange, I also get no error when sample 10 is the last sample:

                      cuffcompare -o OUT -r hg19.ensembl-for-tophat.gtf -s /fasta/ 02/transcripts.gtf 04/transcripts.gtf 08/transcripts.gtf 11/transcripts.gtf 12/transcripts.gtf 13/transcripts.gtf 15/transcripts.gtf 17/transcripts.gtf 20/transcripts.gtf 21/transcripts.gtf 22/transcripts.gtf 24/transcripts.gtf 29/transcripts.gtf 10/transcripts.gtf

                      Comment

                      Latest Articles

                      Collapse

                      • seqadmin
                        Exploring the Dynamics of the Tumor Microenvironment
                        by seqadmin




                        The complexity of cancer is clearly demonstrated in the diverse ecosystem of the tumor microenvironment (TME). The TME is made up of numerous cell types and its development begins with the changes that happen during oncogenesis. “Genomic mutations, copy number changes, epigenetic alterations, and alternative gene expression occur to varying degrees within the affected tumor cells,” explained Andrea O’Hara, Ph.D., Strategic Technical Specialist at Azenta. “As...
                        07-08-2024, 03:19 PM
                      • seqadmin
                        Exploring Human Diversity Through Large-Scale Omics
                        by seqadmin


                        In 2003, researchers from the Human Genome Project (HGP) announced the most comprehensive genome to date1. Although the genome wasn’t fully completed until nearly 20 years later2, numerous large-scale projects, such as the International HapMap Project and 1000 Genomes Project, continued the HGP's work, capturing extensive variation and genomic diversity within humans. Recently, newer initiatives have significantly increased in scale and expanded beyond genomics, offering a more detailed...
                        06-25-2024, 06:43 AM

                      ad_right_rmr

                      Collapse

                      News

                      Collapse

                      Topics Statistics Last Post
                      Started by seqadmin, 07-10-2024, 07:30 AM
                      0 responses
                      26 views
                      0 likes
                      Last Post seqadmin  
                      Started by seqadmin, 07-03-2024, 09:45 AM
                      0 responses
                      201 views
                      0 likes
                      Last Post seqadmin  
                      Started by seqadmin, 07-03-2024, 08:54 AM
                      0 responses
                      212 views
                      0 likes
                      Last Post seqadmin  
                      Started by seqadmin, 07-02-2024, 03:00 PM
                      0 responses
                      193 views
                      0 likes
                      Last Post seqadmin  
                      Working...
                      X