Announcement

Collapse
No announcement yet.

App installation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • App installation

    Hi all ~~

    I use Ubuntu as my operating system. I am new to it. I downloaded many Bioinformatics software; FastQC, Bowtie2,etc.

    I have read multiple manuals about installation. I did not download these applications from Software Center. As I went through manuals I found out for installation I have to write first: "./configure", then "make" and finally "make install".

    I follow these steps but I cannot install these applications. Would you please help me??

  • #2
    Post your errors and people might be able to help, right now, that's just not possible.

    Comment


    • #3
      I get this error for fastqc:

      "This is the source distribution of FastQC. You need to get the compiled version if you want to run the program"

      I do not know what I should do.

      Comment


      • #4
        If you look on the FastQC download page you have the following options:

        FastQC A quality control application for high throughput sequence data

        README
        Installation and setup instructions
        Release Notes Please read these before using the program.
        FastQC v0.11.3 (Win/Linux zip file)
        FastQC v0.11.3 (Mac DMG image)
        Source Code for FastQC v0.11.3 (zip file)

        The one in bold is the one you want.

        It's a Java application. You need to have Java installed to run it. There is more information in the installation guide:

        http://www.bioinformatics.babraham.a...qc/INSTALL.txt

        Comment


        • #5
          Hi all,

          I am having a similar problem. I work with Mac and my terminal give me back this error message "This is the source distribution of FastQC. You need to get the compiled version if you want to run the program". I have downloaded so many times the file for installing FastQC in my computer but it doesn't work. I have also tried to installed from the terminal following the instructions that the web page has but not success. Help please!!!

          Comment


          • #6
            Originally posted by luzlongoria View Post
            Hi all,

            I am having a similar problem. I work with Mac and my terminal give me back this error message "This is the source distribution of FastQC. You need to get the compiled version if you want to run the program". I have downloaded so many times the file for installing FastQC in my computer but it doesn't work. I have also tried to installed from the terminal following the instructions that the web page has but not success. Help please!!!
            Are you downloading the macOS .dmg version here?

            Comment


            • #7
              Yes. I have downloaded too many times at this website. I installed. It seems that it 's fine but I cannot open any file

              Comment


              • #8
                What do you mean by that? You can't open a fastq file or the program itself?

                Comment


                • #9
                  I have tried to work with FastQC through the terminal and it says the error abovementioned.
                  And with I open the program apparently it works but I can't open any file.

                  Comment


                  • #10
                    I assume you have the Java Development Kit installed in addition to the JRE. If not, install JDK and then the DMG version of fastqc should work.

                    Comment


                    • #11
                      Yes. I have installed the latest version of Java as the instruction says. So I don't know why it doens't work

                      Comment


                      • #12
                        Not only Java but also Java development kit (JDK). From here.

                        Comment


                        • #13
                          Yes. I have it. I don't know what is happening. The program even doesn't appear in the application list.

                          Comment


                          • #14
                            When you download the DMG version and unarchive it, copy the fastqc icon that you see (it is the full app) to desktop/applications folder. You should be able to run it then. What version of macOS are you using (I tested this on high sierra)?

                            Comment


                            • #15
                              Thanks for the explanation. In case of such problems, it will be very useful to me. I just recently found out that someone can remotely install a spy app on my phone. It worries me. I try to be extremely careful in messengers and on the phone. I took a look at a review of one of these apps, Ikemymonitor, at this resource realspyapps.com/review/ikeymonitor/ and noticed a lot of its advantages and benefits from using it. But there is no guarantee that these applications will not fall into the hands of intruders and contribute to the leakage of important data.
                              Last edited by Zion Griffin; 06-21-2022, 03:25 AM.

                              Comment

                              Working...
                              X