Announcement

Collapse
No announcement yet.

Facing error while trying to build SNP recalibration model using GATK

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Facing error while trying to build SNP recalibration model using GATK

    Hello everyone,

    Kindly help me in fixing following error while trying to build SNP recalibration model uing GATK,

    $ java -jar GenomeAnalysisTK.jar -T VariantRecalibrator -R Reference/hg19.fa -input raw_variants.vcf -resource:hapmap,known=false,training=true,truth=true,prior=15.0 /Reference/hapmap_3.3.hg19.vcf -resourcemni,known=false,training=true,truth=true,prior=12.0 /Reference/1000G_omni2.5.hg19.vcf -resource:1000G,known=false,training=true,truth=false,prior=10.0 /Reference/1000G_phase1.snps.high_confidence.hg19.vcf -resource:dbsnp,known=true,training=false,truth=false,prior=2.0 /Reference/dbsnp_138.hg19.vcf -an QD -an FS -an SOR -an MQ -an MQRankSum -an ReadPosRankSum -mode SNP -tranche 100.0 -tranche 99.9 -tranche 99.0 -tranche 90.0 -recalFile recalibrate_SNP.recal -tranchesFile recalibrate_SNP.tranches -rscriptFile recalibrate_SNP_plots.R

    ERROR ------------------------------------------------------------------------------------------

    ERROR A USER ERROR has occurred (version 3.5-0-g36282e4):

    ERROR

    ERROR This means that one or more arguments or inputs in your command are incorrect.

    ERROR The error message below tells you what is the problem.

    ERROR

    ERROR If the problem is an invalid argument, please check the online documentation guide

    ERROR (or rerun your command with --help) to view allowable command-line arguments for this tool.

    ERROR

    ERROR Visit our website and forum for extensive documentation and answers to

    ERROR commonly asked questions http://www.broadinstitute.org/gatk

    ERROR

    ERROR Please do NOT post this error to the GATK forum unless you have really tried to fix it yourself.

    ERROR

    ERROR MESSAGE: Invalid argument value '-resource:hapmap known=false training=true truth=true prior=15.0' at position 6.

    ERROR Invalid argument value '/Reference/hapmap_3.3.hg19.vcf' at position 7.

    ERROR Invalid argument value '-resourcemni known=false training=true truth=true prior=12.0' at position 8.

    ERROR Invalid argument value '/Reference/1000G_omni2.5.hg19.vcf' at position 9.

    ERROR Invalid argument value '-resource:1000G known=false training=true truth=false prior=10.0' at position 10.

    ERROR Invalid argument value '/Reference/1000G_phase1.snps.high_confidence.hg19.vcf' at position 11.

    ERROR Invalid argument value '-resource:dbsnp known=true training=false truth=false prior=2.0' at position 12.

    ERROR Invalid argument value '/Reference/dbsnp_138.hg19.vcf' at position 13.

    ERROR ------------------------------------------------------------------------------------------

    Thanks and Best Regards,
    Adnan

  • #2
    Your genome is at "Reference/hg19.fa", but you are referring to the other files at "/Reference/...".

    Simply remove the leading slashes "/" from the resources or provide a full path for everything.

    Comment

    Working...
    X