No announcement yet.

bowtie2-build causing system crash

  • Filter
  • Time
  • Show
Clear All
new posts

  • bowtie2-build causing system crash

    Hello everybody.
    I hope somebody can help me.
    I bought a new server a couple of days ago, a 6th generation i5 processor with 20Gb RAM.
    I installed Fedora 24 and it appears to be fully functioning and stable. I installed bowtie2 and tophat2.
    I downloaded the human genome hg38.
    When I try building the index via the following command,
    $ bowtie2-build hg38.fa hg38_index/hg38_index
    The program runs for a couple of minutes, then the screen goes blank, the server shuts down and reboots.
    Below is the output from bowtie2-build just before rebooting.
    Input files DNA, FASTA:
    Building a SMALL index
    Reading reference sizes
    I tried this 10 times and all 10 times it failed at the same spot.
    If somebody could give me insight as to the problem, please let me know.
    Any help would be appreciated.

  • #2
    Did you compile bowtie2 yourself or are you using the pre-compiled binaries? You may need to compile the binaries yourself in case the pre-compiled ones are not compatible with fedora (ubuntu is more common in bioinfo world).


    • #3
      Thank you for your quick reply.
      I downloaded the source code, unzipped it, and typed the "make" command without parameters to compile the source.
      When I tried bowtie2-build program, it failed just as it did before.
      I checked the hg38_index directory and there were two files
      hg38_index.3.bt2 size 0bytes
      hg38_index.4.bt2 size 44433408bytes

      I deleted these files and ran it again and it failed again at the same place.
      This is a little upsetting to me because it not only fails, it reboots my server.
      Any other suggestions would be helpful.
      Thanks in advance.


      • #4
        A new machine crashing like this under this sort of load suggests bad RAM. Go get MemTest86 and run it overnight.


        • #5
          Thanks for your help.
          I ran Memtest86 and just after a few seconds, the server rebooted. I took the server back to the electronics shop and they said the motherboard can't handle 20Gb of memory. WTF.
          I will try again later on another server.
          Thanks for the help.


          • #6
            "MB Can't Handle" part may actually just be a hardware mismatch/BIOS settings error.

            Did you put this machine together yourself or the shop did? While there is a chance that there is a bad hardware component involved, it may just be a case of trying to over-drive a hardware component due to using a bad BIOS setting (or mixing matching memory modules of different speeds, 20G sounds like an odd number, generally should be in multiples of 4, as 4GB modules are common).