Announcement

Collapse

Welcome to the New Seqanswers!

Welcome to the new Seqanswers! We'd love your feedback, please post any you have to this topic: New Seqanswers Feedback.
See more
See less

bcftools is printing <*> in the alt field

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bcftools is printing <*> in the alt field

    Hello everybody.
    I am running bcftools on an mpileup file generated by samtools via the following command (I removed the paths and shortened the filenames for clarity):
    Code:
    samtools mpileup -E -uf hg19.fa accepted_hits.bam > accepted_hits.mpileup
    I then ran bcftools to identify the variation between the sample and the reference genome:
    Code:
    bcftools view -o file.vcf file.mpileup
    The resulting output file contains many lines with a <*> in the ALT column. Below is a small piece of the output file:

    Code:
    1	10497	.	C	<*>	0	.	DP=6;I16=4,2,0,0,237,9429,0,0,300,15000,0,0,136,3166,0,0;QS=1,0;MQSB=1;MQ0F=0	PL	0,18,192
    1	10498	.	G	<*>	0	.	DP=6;I16=4,2,0,0,233,9117,0,0,300,15000,0,0,138,3240,0,0;QS=1,0;MQSB=1;MQ0F=0	PL	0,18,190
    1	10499	.	G	<*>	0	.	DP=6;I16=4,2,0,0,237,9429,0,0,300,15000,0,0,140,3318,0,0;QS=1,0;MQSB=1;MQ0F=0	PL	0,18,192
    1	10500	.	G	<*>	0	.	DP=6;I16=4,2,0,0,233,9117,0,0,300,15000,0,0,142,3400,0,0;QS=1,0;MQSB=1;MQ0F=0	PL	0,18,190
    1	10501	.	T	<*>	0	.	DP=6;I16=4,2,0,0,218,8232,0,0,300,15000,0,0,144,3486,0,0;QS=1,0;MQSB=1;MQ0F=0	PL	0,18,180
    1	10502	.	C	<*>	0	.	DP=6;I16=4,2,0,0,242,9774,0,0,300,15000,0,0,145,3525,0,0;QS=1,0;MQSB=1;MQ0F=0	PL	0,18,197
    1	10503	.	T	<*>	0	.	DP=6;I16=4,2,0,0,238,9462,0,0,300,15000,0,0,146,3566,0,0;QS=1,0;MQSB=1;MQ0F=0	PL	0,18,193
    1	10504	.	G	<*>	0	.	DP=6;I16=4,2,0,0,238,9462,0,0,300,15000,0,0,147,3609,0,0;QS=1,0;MQSB=1;MQ0F=0	PL	0,18,193
    1	10505	.	A	<*>	0	.	DP=6;I16=4,2,0,0,246,10086,0,0,300,15000,0,0,148,3654,0,0;QS=1,0;MQSB=1;MQ0F=0	PL	0,18,199
    1	10506	.	C	<*>	0	.	DP=6;I16=4,2,0,0,242,9774,0,0,300,15000,0,0,149,3701,0,0;QS=1,0;MQSB=1;MQ0F=0	PL	0,18,197
    I assume the <*> means there were no reads aligning to these positions of the genome.

    I tried various options such as "-U", "-m 2", "-c 1", but they either generated no output or did not do anything.

    What option do I use to prevent bcftools from printing the lines containing <*>?
Working...
X