Welcome to the New Seqanswers!

Welcome to the new Seqanswers! We'd love your feedback, please post any you have to this topic: New Seqanswers Feedback.
See more
See less

tophat 1.2 multi thread mode error

  • Filter
  • Time
  • Show
Clear All
new posts

  • tophat 1.2 multi thread mode error

    Hi all,
    running tophat 1.2 with 8 threads the following errors occur

    srun: error: q44: tasks 0-6: Exited with exit code 1
    And one thread continues running.

    Also it seems like there is a conflict between threads in creating outputdirectory:
    [Wed Jan 26 21:17:51 2011] Preparing output location tophat_04/
    Traceback (most recent call last):
    File "/soft/tophat-1.2.0/tophat", line 2347, in ?

    OSError: [Errno 17] File exists: '/tophat_04/'
    File "/soft/tophat-1.2.0/tophat", line 2230, in main

    Have anyone got the same problems?
    Last edited by altodor; 01-27-2011, 01:23 AM.

  • #2
    I've been using this version with 8 threads for a week now with no problems. did you build from source or download a binary? When in doubt build from source


    • #3
      Problem solved

      Hello, thank you!
      It really worked with 8 threads. First problem was, that I ran 16 treads of tophat on 8 cores and they tried to read to the same folder.
      Second problem, as appeared later, was the empty reference file. They say at tophat manual, that reference.fa will be built automatically with the first run of tophat. Nut I built in manually using bowtie-inspect. Now tophat produces junction database!