Announcement

Collapse

Welcome to the New Seqanswers!

Welcome to the new Seqanswers! We'd love your feedback, please post any you have to this topic: New Seqanswers Feedback.
See more
See less

BLAST database error - when changing to new BLAST+ local program

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BLAST database error - when changing to new BLAST+ local program

    Hi,
    I used local BLAST a while ago and have problem when changing to the new BLAST+.
    I put the .../ncbi-blast-2.2.24+/bin and .../ncbi-blast-2.2.24+/db into $PATH

    and execute the command
    /local/.../blastp -query input -out output.fa -db nr -evalue 0.001


    error returned:
    BLAST Database error: No alias or index file found for protein database [nr] in search path [/local/.../ncbi-blast-2.2.24+/bin::]

    ==========================
    What does this error mean?
    Has the query input query format changes in the new BLAST+?

  • #2
    It can't find your blast database (have you shortened the error message? The search path looks funny). There is an environment variable you can set, or just pass the full path rather than just nr.

    Comment


    • #3
      Thanks for your reply! I've tried putting the full path for nr db, but it seems BLAST still search within my current directory.

      But, I found a work-around that I put all my query in the folder of nr database, and now it can work fine.

      Although I checked the configuration guide again but cannot find ".ncbirc" file they mentioned on http://www.ncbi.nlm.nih.gov/staff/ta...nix_setup.html


      Originally posted by maubp View Post
      It can't find your blast database (have you shortened the error message? The search path looks funny). There is an environment variable you can set, or just pass the full path rather than just nr.

      Comment


      • #4
        try setting the environment variable BLASTDB to the location of your database, that should do the trick.

        Comment


        • #5
          There is no need of move your blast database. At least for the linux version of the blast+, setting up the appropriate file's owners and permitions will fix the problem.
          G'Luck,
          ferreirafm
          Last edited by ferreirafm; 06-15-2011, 05:26 AM.

          Comment

          Working...
          X