No announcement yet.

blast nr database not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • blast nr database not working

    So I am trying to download the latest nr database and use blast with it on Ubuntu 16.04. I compiled and installed the latest blast and then used to download nr, which worked fine. But when I try to run a blast query using nr I get this error:

    BLAST Database error: No alias or index file found for nucleotide database [/share/genomes/ncbi/nr/nr] in search path [/share/biocore/joshi/sandbox::]

    And I am definitely using the correct way of specifying nr. Here is my blastn command:

    blastn -query test.fa -db /share/genomes/ncbi/nr/nr -num_threads 30

    /share/genomes/ncbi/nr/ is a directory containing all of the nr files.

    So then I downloaded nt and ran the same command with nt and it worked just fine. It seems that whatever index file is needed by blastn is not included in any of the tar files for nr. Anybody have any ideas?

  • #2
    nr is a protein database. You are trying to use blastn with that. You will need to use blastx or a translated protein search.


    • #3
      There are both an nr nucleotide and nr protein databases. I'm using the nr nucleotide database.


      • #4
        If you downloaded `nr` as pre-formatted database from NCBI then it is a protein only database as noted in the blastftp file.
        Last edited by GenoMax; 11-29-2021, 04:44 PM.


        • #5
          So according to the blastftp file, nt is "Not non-redundant". Where would I download the nucleotide nr? Or are the nt.00.* files actually the nr nucleotide database? Because that is confusing.
          Last edited by najoshi; 11-29-2021, 03:20 PM.


          • #6
            So according to that blastftp file:

            nt.00.tar.gz first volume of the nucleotide nr database
            nt.01.tar.gz second volume of the nucleotide nr database

            nt is nucleotide nr! And nr is protein nr! ?!?!


            • #7
              I don't think there is a non-redundant nt database. You should consider using RefSeq/RefSeq genomes.

              Perhaps the only way to put this to rest is to email NCBI help desk and ask. There is some ambiguity for sure since the description of the `nt` FASTA file counterpart says

              nt.gz nucleotide database from GenBank excluding the
              batch division htgs, est, gss,sts, pat divisions,
              and wgs entries. Not non-redundant.