Header Leaderboard Ad


Install Newbler 2.9 in Ubuntu



No announcement yet.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Install Newbler 2.9 in Ubuntu

    Hey everyone,

    I am trying to install the Data_Analysis2.9 package in Ubuntu 13.04. I am very new to Ubuntu and Newbler, but am trying to get this to work.

    Here is what I have done so far:
    1. Download DataAnalysis_2.9_All_20130530_1559.tgz
    2. Extract the *.tgz file to a folder on my desktop called "DataAnalysis_2.9_All"
    3. Open terminal, and run
    sudo apt-get install ia32-libs
    4. From the bottom directory, type
    PHP Code:
    sudo ln -/bin/true /bin/rocks 
    (sudo ln -s /bin/true ~/bin/rocks didn't work.)
    5. Type
    sudo apt-get install alien
    6. Type
    PHP Code:
    ln -/bin/sh 
    PHP Code:
    lrwxrwxrwx 1 root root 4 Aug 12 18:29 /bin/sh -> bash 
    7. In /Desktop/DataAnalysis_2.9_All, type
    PHP Code:
    sudo ./setup.sh 
    Then I get this error in the log file:
    Installation started at 08/12/2013 06:45:41 PM
    User: uid=0(root) gid=0(root) groups=0(root)
    Hostname: bryan-ubuntu
    [06:45:41 PM] cd /home/bryan/Desktop/DataAnalysis_2.9_All; md5sum -c checksum_inst
    ./setup.sh: OK
    ./README: OK
    ./packages/gsNewbler-2.9-1.x86_64.rpm: OK
    ./packages/amplicons_CLI_2.9.i686.tgz: OK
    ./packages/jre-linux-i586-oracle-2.9-1.i386.rpm: OK
    ./packages/gsNewbler-2.9-1.i686.rpm: OK
    ./packages/gsAssembler-2.9-1.noarch.rpm: OK
    ./packages/gsSeqTools-2.9-1.x86_64.rpm: OK
    ./packages/gsAmplicons-2.9-1.noarch.rpm: OK
    ./packages/gsSeqTools-2.9-1.i686.rpm: OK
    ./packages/gsMapper-2.9-1.noarch.rpm: OK
    [06:45:42 PM] rpm -U   --force  /home/bryan/Desktop/DataAnalysis_2.9_All/packages/jre-linux-i586-oracle-2.9-1.i386.rpm
    rpm: RPM should not be used directly install RPM packages, use Alien instead!
    rpm: However assuming you know what you are doing...
    warning: /home/bryan/Desktop/DataAnalysis_2.9_All/packages/jre-linux-i586-oracle-2.9-1.i386.rpm: Header V3 DSA/SHA1 Signature, key ID e50b562c: NOKEY
    [06:45:44 PM] rpm -U   --force  /home/bryan/Desktop/DataAnalysis_2.9_All/packages/gsSeqTools-2.9-1.x86_64.rpm
    rpm: RPM should not be used directly install RPM packages, use Alien instead!
    rpm: However assuming you know what you are doing...
    warning: /home/bryan/Desktop/DataAnalysis_2.9_All/packages/gsSeqTools-2.9-1.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID e50b562c: NOKEY
    error: Failed dependencies:
    	/bin/sh is needed by gsSeqTools-1:2.9-1.x86_64
    This looks like the same error discussed at http://seqanswers.com/forums/showthread.php?t=20588, yet I can't get this to install. Thanks!

  • #2
    Did you try the code in post #5 from the thread that you have linked to? If you did then what do you see when you run the following?

    $ ls -l /bin/sh


    • #3
      I did the following commands:

      [email protected]:~$ sudo rm /bin/sh
      [sudo] password for bryan:
      [email protected]:~$ sudo ln -s bash /bin/sh
      [email protected]:~/Desktop/DataAnalysis_2.9_All$ ls -l /bin/sh
      lrwxrwxrwx 1 root root 4 Aug 12 19:35 /bin/sh -> bash

      I then tried to run setup.sh from Terminal and got the same error.


      • #4
        That looks right. I wonder if you have a problem with your $PATH variable (i.e. /bin is not in that path, it seems unlikely).

        What is the output of

        $ echo $PATH


        • #5
          Here is what appears:
          [email protected]:~$ echo $PATH
          [email protected]:~$


          • #6
            That again looks right. Not sure what to ask you to try next. In case no one from the west coast helps further tonight we can look at this tomorrow.


            • #7
              Hi brymerr,

              I am actually not sure but I think you have not to use
              HTML Code:
               sudo ./setup.sh
              . Try it without sudo, as my experience was that I could install 2.7 only locally and for this you don't need sudo.

              The link you created for bash did not work for root -- maybe.


              • #8


                • #9
                  I had the same issue. It's just because /bin/sh is not in the rpm database. To get round this I installed the STLinux "provides" RPM. This populates the database without installing anything and this happens to include /bin/sh:

                  Information: http://stlinux.com/install/ubuntu
                  Pick the latest version from here: http://download.stlinux.com/pub/stlinux/2.4/misc/

                  Simply do a:

                  rpm -ivh --force-debian stlinux24<version>.rpm
                  and then

                  sudo apt-get install ia32-libs
                  sudo ln -s /bin/true /bin/rocks
                  sudo ln -s /usr/bin/lspci /sbin/lspci
                  sudo dpkg-reconfigure dash   (select no)
                  sudo ./setup.sh
                  It should install without any problems.


                  • #10
                    Which one is the latest STLinux

                    I saw this list, but which one should I pick?
                    stlinux24-host-STLinux_deps-20100401-1.i386.rpm 01-Apr-2010 17:01  4.2K  
                    [   ] stlinux24-host-STLinux_deps-20100427-1.i386.rpm 28-Jun-2010 14:56  4.4K  
                    [   ] stlinux24-host-STLinux_deps-20110126-1.i386.rpm 26-Jan-2011 11:47  4.4K  
                    [   ] stlinux24-host-STLinux_deps-20110331-1.i386.rpm 31-Mar-2011 12:30  4.5K  
                    [   ] stlinux24-host-STLinux_deps-20110614-1.i386.rpm 14-Jun-2011 10:40  4.5K  
                    [   ] stlinux24-host-STLinux_deps-20111020-1.i386.rpm 20-Oct-2011 11:07  5.7K  
                    [   ] stlinux24-host-STLinux_deps-20120508-1.i386.rpm 08-May-2012 14:20  5.7K  
                    [   ] stlinux24-host-STLinux_deps-20120731-1.i386.rpm 01-Aug-2012 11:23  6.1K  
                    [   ] stlinux24-host-STLinux_deps-20121030-1.i386.rpm 30-Oct-2012 14:41  7.1K  
                    [   ] stlinux24-host-STLinux_deps-20130321-1.i386.rpm 21-Mar-2013 14:11  7.1K  
                    [   ] stlinux24-host-STLinux_deps-20131122-1.i386.rpm 22-Nov-2013 13:43  7.1K  
                    [   ] stlinux24-host-STLinux_deps-20140120-1.i386.rpm 23-Jan-2014 16:04  7.2K
                    I assumed the last one,
                    and installed it. The problem is still there. Any idea? Thanks!


                    • #11
                      I have a local installation of newbler but here the error message:

                      Warning: One or more of the following libraries was not found
                         zlib.i386, libXi.i386, libXtst.i386, libXaw.i386
                      Without these libraries, 454 Life Sciences software may not run correctly.  Consult the product documentation for more information.

                      could you help me?


                      • #12
                        What flavor of unix/linux are you running?

                        Here is a relevant thread that will help: http://ubuntuforums.org/showthread.php?t=1624351 See post #3.


                        • #13
                          i have Ubuntu 12.04LTS.
                          I installed the librairies ia32-libs.
                          but it's the same problème.


                          • #14
                            Maybe this thread helps?


                            Latest Articles


                            • seqadmin
                              A Brief Overview and Common Challenges in Single-cell Sequencing Analysis
                              by seqadmin

                              ​​​​​​The introduction of single-cell sequencing has advanced the ability to study cell-to-cell heterogeneity. Its use has improved our understanding of somatic mutations1, cell lineages2, cellular diversity and regulation3, and development in multicellular organisms4. Single-cell sequencing encompasses hundreds of techniques with different approaches to studying the genomes, transcriptomes, epigenomes, and other omics of individual cells. The analysis of single-cell sequencing data i...

                              01-24-2023, 01:19 PM
                            • seqadmin
                              Introduction to Single-Cell Sequencing
                              by seqadmin
                              Single-cell sequencing is a technique used to investigate the genome, transcriptome, epigenome, and other omics of individual cells using high-throughput sequencing. This technology has provided many scientific breakthroughs and continues to be applied across many fields, including microbiology, oncology, immunology, neurobiology, precision medicine, and stem cell research.

                              The advancement of single-cell sequencing began in 2009 when Tang et al. investigated the single-cell transcriptomes
                              01-09-2023, 03:10 PM