Header Leaderboard Ad

Collapse

mpileup: specified region truncated.

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mpileup: specified region truncated.

    Hello gentlepeople,

    I am using the samtools 'mpileup' program.
    I wish to generate a pileup file for a specific region.
    I have several separate .bam input files that I am generating the pileups for.
    Unfortunately, mpileup truncates the region and I only get data for the first part of the region.
    I have ran the same command on different .bam files and get different results.

    When I command:

    samtools mpileup -f 'hg19.fa' -r chr6:27114408-27115845 'experiment01.bam' > out_PILEUP2.pile
    [mpileup] 1 samples in 1 input files
    <mpileup> Set max per-file depth to 8000

    I get a file with 746 lines.
    I am expecting 1438 lines because that is the size of the interval I have specified with the '-r' flag
    If I use mpileup with the same region but with a different .bam file I get a different size file.

    samtools mpileup -f 'hg19.fa' -r chr6:27114408-27115845 'experiment02.bam' > out_PILEUP3.pile
    [mpileup] 1 samples in 1 input files
    <mpileup> Set max per-file depth to 8000

    I get a file with 623 lines.
    Again, I am expecting 1438 lines because that is the size of the interval I have specified with the '-r' flag.

    The first line in both files is for chr6:27114408, as expected.
    BUT, the files are truncated at different positions.
    With experiment01.bam the final line of the pileup file is chr6:27115577.
    With experiment02.bam the final line of the pileup file is chr6:27115344.

    This must have something to do with the .bam file.
    Can someone tell me which parameter needs to be adjusted?
    I have consulted the manual but I could not identify anything that sounded applicable.

    Thanks for you time,
    Lionel (Lee) Brooks 3rd
    Dartmouth Genetics Grad Student

  • #2
    The simplest answer is that you just don't have any reads across part of your region.

    Try getting the .sam file for the same region +- 500 bases, or try looking at the whole .bam in IGV. You can zoom in on your region.

    Comment


    • #3
      Yeah, mpileup doesn't generate lines for regions it has no reads on. If you need to work out whole-region coverage, then you should be looking at the column that gives the base number. For covered regions, this will increase by 1 per line (assuming no inserts), but will jump multiple bases when there are no reads.

      Comment


      • #4
        whoops, should have checked that...thanks!

        Comment

        Latest Articles

        Collapse

        • seqadmin
          A Brief Overview and Common Challenges in Single-cell Sequencing Analysis
          by seqadmin


          ​​​​​​The introduction of single-cell sequencing has advanced the ability to study cell-to-cell heterogeneity. Its use has improved our understanding of somatic mutations1, cell lineages2, cellular diversity and regulation3, and development in multicellular organisms4. Single-cell sequencing encompasses hundreds of techniques with different approaches to studying the genomes, transcriptomes, epigenomes, and other omics of individual cells. The analysis of single-cell sequencing data i...

          01-24-2023, 01:19 PM
        • seqadmin
          Introduction to Single-Cell Sequencing
          by seqadmin
          Single-cell sequencing is a technique used to investigate the genome, transcriptome, epigenome, and other omics of individual cells using high-throughput sequencing. This technology has provided many scientific breakthroughs and continues to be applied across many fields, including microbiology, oncology, immunology, neurobiology, precision medicine, and stem cell research.

          The advancement of single-cell sequencing began in 2009 when Tang et al. investigated the single-cell transcriptomes
          ...
          01-09-2023, 03:10 PM

        ad_right_rmr

        Collapse
        Working...
        X