Seqanswers Leaderboard Ad



No announcement yet.
  • Filter
  • Time
  • Show
Clear All
new posts

  • illumina bcl2fastq 1.8.3 Installation on Ubuntu 14.04 LTS

    Prepared by : Raju Yadav ([email protected])
    Date : 01-08-2014

    illumina bcl2fastq 1.8.3 Installation

    Introduction :This software can be used to convert zipped or non ‐ zipped bcl files, generated by Illumina HiSeq sequencers, to fastq files, and perform simultaneous demultiplexing of the data according to a sample sheet.

    Majority of illumina NGS softwares are developed and tested on CentOS , these softwares may or may not work with other Linux Distributions like Ubuntu , Redhat ,Fedora e.t.c

    Even different versions of same Distribution may not behave same . For instance softwares which compiled good on Ubuntu 12.04 may not compile in a same way on Ubuntu 14.04 version. So testing with different version is very much important.

    Installing bcl2fastq 1.8.3 on ubuntu 14.04 LTS Pre requesties :

    1.GNUmake(3.81 recommended)

    pre installed 3.81-8.2ubuntu3, nothing to do with this

    2.Perl >= 5.8

    pre installed 5.18.2-2ubuntu1

    3. libxslt-this library requires a recent version of libxml2(2.9.1+dfsg1-3ubuntu4.3,pre installed, upgrade in synaptic)

    Search in the synaptic, naming convention may change it produce result as libxslt1.1 it's one and the same install it through synaptic


    Search in the synaptic, naming convention may change it produce result as libxslt1-dev it's one and the same install it through synaptic

    5.libxml2(2.9.1+dfsg1-3ubuntu4.3,pre installed, upgrade in synaptic)


    Search in the synaptic, naming convention may change it produce result as libxml2-dev it's one and the same install it through synaptic

    7.gcc(4.0.0 or newer,except4.0.2),withc++

    gcc, pre installed version 4:4.8.2-1ubuntu6, c++;update with synaptic, search as g++( it will take some time to get installed ,be patient)


    pre installed version-1.0.6-5


    Search in the synaptic, naming convention may change it produce result as libbz2-dev it's one and the same install it through synaptic .


    Search in the synaptic, naming convention may change it produce result as zlib1g it's one and the same install it through synaptic .


    Search in the synaptic, naming convention may change it produce result as zlib1g-dev it's one and the same install it through synaptic

    Pre requesties installation done :

    After so manny trials and errors I personally experienced that neither illumina bcl2fastq or CASAVA cannot' be configured on ubuntu 14.04 LTS.

    In pratical bcl2fastq is apart of CASAVA,compilation will be same for both which cannot be done on ubuntu 14.04 LTS;There is only one option to install bcl2fastq 1.8.3 on ubuntu 14.04 LTS;

    Install a Bcl2fastq 1.8.3 RPM package

    Installation Steps :

    Step1 : Download the Bcl2fastq RPM package (

    Step2 : Copy the bcl2fastq-1.8.3-linux-x86_64.rpm file to any directory (Make sure that the download is completed with out any errors)

    Step3 : Check whether you system got alien and curl or not ,if not , open the terminal and install them using; sudo apt-get install alien,sudo apt-get install curl

    Step4 : Once alien got installed , change the directory in the terminal to the directory contains bcl2fastq-1.8.3-linux-x86_64.rpm file.

    Type the follwing command line one after one

    sudo alien -i bcl2fastq-1.8.4-Linux-x86_64.rpm
    sudo apt-get install build-essential
    curl -kL | bash
    echo >> ~/.bash_profile "source ~/perl5/perlbrew/etc/bashrc"
    perlbrew install perl-5.14.4
    perlbrew switch perl-5.14.4
    perlbrew install-cpanm
    cpanm XML/Simple.

    That's all, the installation complete!

    Instructions :
    Run as a non-root user.
    Installing (build) process took about 10min for my environment.
    You can also use "aptitude" instead of "apt-get".
    For perlbrew, you can use "use" instead of "switch" to set-up only for current shell. You may need to install other required modules using cpanm.

    Understanding the installantion :

    CASAVA and Bcl2fastq software compilation was not compatible with ubuntu 14.04LTS. So we are trying to install a RPM package; in other terms this RPM package contains a pre-compiled files which can directly can be directly installed on your machine. CASAVA is not avaiable in RPM package but Bcl2fastq do availabe. In practically Bcl2fastq is quite enough becuase many users uses other softwares like Tophat(Transcriptome) for alignment.

    To run a RPM package we need a small programme i.e alien which can install a RPM package with a single command (sudo alien -i package_file.rpm)
    The perl module which comes with ubuntu 14.04 LTS is very advanced and is more strict with syntax errors ,so this perl module can't be used ,But this module is very important for many other linux softwares ,So we should not remove it.

    As the perl module comes with ubuntu 14.04 LTS is not useful and should not be removed , here we plan something differnet like masking the existed perl module with older perl modules like perl-5.14.4 ,perl-5.12.5 etc which are not very strict to syntax errors.So we are downloading the old module ,installing it and making it as active perl by switching the old perl module to mask the existed one which cause no harm to your system.

    There is no gurantee exactly the above said commands will work smooth ; I encountered with some problems listed below

    sudo alien -i bcl2fastq-1.8.4-Linux-x86_64.rpm

    This command meant to install bcl2fastq-1.8.4-Linux-x86_64.rpm

    This command worked fine , so it's clear that Bcl2fastq installation was sucessfull ;check location /usr/local/bin ; you should find some executable files related to bcl2fastq.

    sudo apt-get install build-essential

    It will build the essentials if available or it will give us a message build essentials upto date

    This command worked fine

    curl -kL | bash

    This command is meant for installing perlbrew(an admin-free perl installation management tool)

    This command worked fine, so it's clear that perlbrew got installed.

    echo >> ~/.bash_profile "source ~/perl5/perlbrew/etc/bashrc"

    This commland line meant for doing temporary, short-term changes to environment)

    This command line worked fine

    perlbrew install perl-5.14.4

    This command is for installing old perl version; besides existed system perl version won't be altered

    This command really didn't worked for me, configuration was failed many times ,may be it's not compatible , so I changed my mind to install an older version prior to 5.14.4 , I just tried to install 5.12.5 , so changed command like; perlbrew install perl-5.12.5 and it worked (it will give perl 5.12.5 installed sucessfully)

    perlbrew switch perl-5.14.4

    This command is switiching the perl module you just installed , in this case 5.12.5 to active mode by masking the one existed with in your system; it will give a message like A sub-shell is launched with perl-5.12.5 as the activated perl. Run 'exit' to finish it. if the everything works proper with your new perl version

    perlbrew install-cpanm

    CPAN, the Comprehensive Perl Archive Network, is the primary source for publishing and fetching the latest modules and libraries for the Perl programming language.The default method for installing Perl modules, using the “CPAN Shell”.The CPAN Minus, or cpanm, client attempts to make the power of CPAN accessible to all users, particularly those who aren’t Perl developers with a great deal of experience with the CPAN shell.

    This command worked for me

    cpanm XML/Simple.

    XML::Simple is a Perl module that makes it really easy to read and write XML files.

    This command did't worked me , installation of XML was failing for many attempts

    Installing the dependencies failed: Module 'XML::Parser' is not installed
    ! Bailing out the installation for XML-SAX-Expat-0.51.
    ! Installing the dependencies failed: Module 'XML::SAX::Expat' is not installed
    ! Bailing out the installation for XML-Simple-2.20.

    Installation of XML:Simple has many dependencies, install XML::Parser and XML::SAX::Expat manually in another terminal and run the command again
    cpanm XML/Simple.

    Downlaod XML-Parser-2.41 tar.gz and expat-2.1.0 tar.gz, extract manually ( just right click the tar.gz and click ,extract here); the extracted folder now put in a directory and change the terminal to the same directory )

    Don't try to install XML-Parser first , it depends on expat ,so install expat just by ./configure, make,sudo make install commands)

    after suceesful installation of expat install XML-Parser manually with command

    If it get installed sucessfully you are ready to use Bcl2fastq ( Follow the Bcl2fsatq user guide for usage of Bcl2fastq)

    Here I am giving the command I used , Paths of input, output and sample sheet directories may change from system to system)

    /usr/local/bin/ --input-dir /media/vanessa/UUI/ngs/Data/Intensities/BaseCalls --output-dir Unaligned --sample-sheet /media/vanessa/UUI/ngs/Data/Intensities/BaseCalls/SampleSheet.csv

    If the command line is proper with directory path and without any space errors in the command line the Bcl2fastq will succesully configure the data , chances are the for an error beaucse of no xsltproc, if found error install xsltproc by command ;sudo apt-get install xsltproc and re run the previous command.

    Read the Bcl2fastq user guide for other options with Bcl2fastq usage.


  • #2
    Hi, Everyone,

    I have updated my RedHat and Perl modules, but I couldn't track which packages where updated.
    After the update the start to show warning messages in the process of make file generation :
    Use of uninitialized value $readNumber in hash element at /usr/local/lib/bcl2fastq-1.8.4/perl/Casava/ line 274.
    Use of uninitialized value $readNumber in numeric lt (<) at /usr/local/lib/bcl2fastq-1.8.4/perl/Casava/ line 276.
    Use of uninitialized value $adapterFileCount in foreach loop entry at /usr/local/lib/bcl2fastq-1.8.4/perl/Casava/ line 475.

    Could anyone help me ?
    Below are my modules and libraries versions:
    libxslt-devel (1.1.26)
    libxml2 (2.7.6)
    libxml2-devel (2.7.6)
    libxml2-python (2.7.6)
    ncurses-devel (5.7)
    libtiff-devel (3.9.4)
    zlib-devel (1.2.3)

    Perl modules:

    perl-XML-Dumper (0.81)
    perl-XML-Grove (0.46alpha)
    perl-XML-LibXML (2.0116)
    perl-XML-Parser (2.41)

    Thank You,



    • #3
      How does your command line look like? I doubt that these errors are caused by updating perl modules ..


      • #4
        This is the command line: --fastq-cluster-count 10000000 --use-bases-mask y150n,I6n,Y150n --input-dir /illumina/runs/140930_C00127_0035_AH9N32ADXX/Data/Intensities/BaseCalls --output-dir ./UnalignedTest --sample-sheet SampleSheet.csv


        • #5
          309 cycles . ok. What sequencer type? Have you tried to run the conversion on a run which has been converted successfully before? Just to exclude any issues with the current run.


          • #6
            @tyutakajr: Check the RunInfo.xml file (look for the section <Reads>) in /illumina/runs/140930_C00127_0035_AH9N32ADXX directory to verify that you have the correct number of cycles specified in your command.


            • #7
              Hi sklages and GenoMax,
              We have a HiSeq 1500 Sequencer, and our platform is working since the last year. The RunInfo.xml is Ok too.

              I solved the problem.

              I installed the older perl modules and made some tests but didn't work too, so I installed the newest versions again and now the warning messages has gone.

              Thank You All.


              Latest Articles


              • seqadmin
                The Impact of AI in Genomic Medicine
                by seqadmin

                Artificial intelligence (AI) has evolved from a futuristic vision to a mainstream technology, highlighted by the introduction of tools like OpenAI's ChatGPT and Google's Gemini. In recent years, AI has become increasingly integrated into the field of genomics. This integration has enabled new scientific discoveries while simultaneously raising important ethical questions1. Interviews with two researchers at the center of this intersection provide insightful perspectives into...
                02-26-2024, 02:07 PM
              • seqadmin
                Multiomics Techniques Advancing Disease Research
                by seqadmin

                New and advanced multiomics tools and technologies have opened new avenues of research and markedly enhanced various disciplines such as disease research and precision medicine1. The practice of merging diverse data from various ‘omes increasingly provides a more holistic understanding of biological systems. As Maddison Masaeli, Co-Founder and CEO at Deepcell, aptly noted, “You can't explain biology in its complex form with one modality.”

                A major leap in the field has
                02-08-2024, 06:33 AM





              Topics Statistics Last Post
              Started by seqadmin, 02-28-2024, 06:12 AM
              0 responses
              Last Post seqadmin  
              Started by seqadmin, 02-23-2024, 04:11 PM
              0 responses
              Last Post seqadmin  
              Started by seqadmin, 02-21-2024, 08:52 AM
              0 responses
              Last Post seqadmin  
              Started by seqadmin, 02-20-2024, 08:57 AM
              0 responses
              Last Post seqadmin