Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Could not locate a Bowtie index corresponding to basename

    Hi,

    I am using cnvCapSeq-0.1.2 software which has bowtie 2 integrated into a pipline. When I am trying to launch it I am getting an error:

    Code:
    Realigning using Bowtie2...
    Could not locate a Bowtie index corresponding to basename "/home/laba/Desktop/bowtie2-2.2.4/chr1_index/chr1.fa"
    Overall time: 00:00:00
    Error: Encountered internal Bowtie 2 exception (#1)
    Command: /home/laba/Desktop/bowtie2-2.2.4/bowtie2-align-s --wrapper basic-0 -t -x /home/laba/Desktop/bowtie2-2.2.4/chr1_index/chr1.fa --rg-id NA06984.mapped.ILLUMINA.bwa.CEU.low_coverage.20101123_sorted.bam --rg LB:LB_NA06984.mapped.ILLUMINA.bwa.CEU.low_coverage.20101123_sorted.bam --rg SM:SM_NA06984.mapped.ILLUMINA.bwa.CEU.low_coverage.20101123 --rg PL:illumina --rg PU:PU_NA06984.mapped.ILLUMINA.bwa.CEU.low_coverage.20101123 --rg DS:DS_NA06984.mapped.ILLUMINA.bwa.CEU.low_coverage.20101123 --rg CN:CN_NA06984.mapped.ILLUMINA.bwa.CEU.low_coverage.20101123 -a --very-sensitive --maxins 300000 -p 4 -1 ./pre_processing_results/RP_results/realign/reads/NA06984.mapped.ILLUMINA.bwa.CEU.low_coverage.20101123.abnormal._1.fq -2 ./pre_processing_results/RP_results/realign/reads/NA06984.mapped.ILLUMINA.bwa.CEU.low_coverage.20101123.abnormal._2.fq
    First I palced the reference in fasta format for chr1 into folder within bowtie2 directory. It did not work. Then I tried to create bowtie index for the reference it did not help either. I have also tried to download refernce using pipeline provided in scripts folder which did not help as well (i modified it to only download chr1). I have 257 gb free for my tmp folder. At the moment index files are in the same folder as reference fasta file. Where should I place them?

    What can case the issue?
    Last edited by YKY; 12-29-2014, 05:30 AM.

  • #2
    Can you post a listing of the files in "/home/laba/Desktop/bowtie2-2.2.4/chr1_index/"?

    Comment


    • #3
      I have tried two provide two different directories.

      /home/laba/Desktop/bowtie2-2.2.4/aux contains:
      chr1.1.bt2 chr1.2.bt2 chr1.3.bt2 chr1.4.bt2 chr1.fa chr1.fai chr1.rev.1.bt2 chr1.rev.2.bt2
      For this directory I downloaded the refernce for build 37 substted chr1 and indexed it with bowtie 2

      another directory I tried to provide to bowtie2
      /home/laba/Desktop/bowtie2-2.2.4/chr1_index/ contains:
      chr1.1.bt2 chr1.2.bt2 chr1.3.bt2 chr1.4.bt2 chr1.fa chr1_random.fa chr1.rev.1.bt2 chr1.rev.2.bt2
      I downloaded the reference using pipeline for human genome in bowtie2/scripts folder. Apart from fasta files other files were name hg18* after it did not work I renamed them to chr1*, which did not work either.

      Comment


      • #4
        If the index files were originally named hg18* then you can't rename them to chr1*. The thing to do is either restore the names back to the original or download a new copy and use hg18 as "basename" for the index.

        As for the chr1 subset you should use "chr1" as the basename.
        Last edited by GenoMax; 12-29-2014, 05:49 AM.

        Comment


        • #5
          I've tried what you suggesting and replaced bowtie parameter form /home/laba/Desktop/bowtie2-2.2.4 to /chr1_index/chr1.fa to .../hg18 but it did not help.

          As I mentioned I've indexed chr1 reference separately before. And all filenames matched and were in the same directory, but it did not help.

          Comment


          • #6
            Assuming I am looking at the same cnvCapSeq program here is what the Readme file says about the index files. Are you closely following these directions?

            The read pair pipeline requires the FASTA sequence file against
            which the the multi-mapped reads will be re-aligned. This file should
            be placed in the /aux folder and renamed to chr*.fasta, where * is
            the chromosome name. The fasta files also need to be indexed using
            Bowtie2.

            Comment


            • #7
              Yes. Thats what I did intitially. You can see contents of the aux folder in my second post. When it did not work I've started trying to provide another directory to bowtie.

              EDIT
              Also I dont have readme file for RP_pipeline. Only pipline itself. Maybe you are on different version? Mine is 0.1.2
              EDIT2
              And for aux folder I indexed chr1.fa reference file separately. Using bowtie2
              Last edited by YKY; 12-29-2014, 06:49 AM.

              Comment


              • #8
                Here is the link for the software (assuming it is the same one as what you are using): http://ftp.jaist.ac.jp/pub/sourcefor...vCapSeq/0.1.2/ You can find the readme file there.

                Just trying to see if I can help. I don't use this software.

                Comment


                • #9
                  Thanks. Yea I found it now. I've tried to put aux folder into cnvCapSeq directory, changing aux variable in pipeline back to what it was "./aux", still no luck.
                  EDIT
                  Before that I was placing it into bowtie2 directory

                  Comment

                  Latest Articles

                  Collapse

                  • seqadmin
                    The Impact of AI in Genomic Medicine
                    by seqadmin



                    Artificial intelligence (AI) has evolved from a futuristic vision to a mainstream technology, highlighted by the introduction of tools like OpenAI's ChatGPT and Google's Gemini. In recent years, AI has become increasingly integrated into the field of genomics. This integration has enabled new scientific discoveries while simultaneously raising important ethical questions1. Interviews with two researchers at the center of this intersection provide insightful perspectives into...
                    Yesterday, 02:07 PM
                  • seqadmin
                    Multiomics Techniques Advancing Disease Research
                    by seqadmin


                    New and advanced multiomics tools and technologies have opened new avenues of research and markedly enhanced various disciplines such as disease research and precision medicine1. The practice of merging diverse data from various ‘omes increasingly provides a more holistic understanding of biological systems. As Maddison Masaeli, Co-Founder and CEO at Deepcell, aptly noted, “You can't explain biology in its complex form with one modality.”

                    A major leap in the field has
                    ...
                    02-08-2024, 06:33 AM

                  ad_right_rmr

                  Collapse

                  News

                  Collapse

                  Topics Statistics Last Post
                  Started by seqadmin, 02-23-2024, 04:11 PM
                  0 responses
                  45 views
                  0 likes
                  Last Post seqadmin  
                  Started by seqadmin, 02-21-2024, 08:52 AM
                  0 responses
                  61 views
                  0 likes
                  Last Post seqadmin  
                  Started by seqadmin, 02-20-2024, 08:57 AM
                  0 responses
                  51 views
                  0 likes
                  Last Post seqadmin  
                  Started by seqadmin, 02-14-2024, 09:19 AM
                  0 responses
                  65 views
                  0 likes
                  Last Post seqadmin  
                  Working...
                  X