Announcement

Collapse
No announcement yet.

Repost: tophat-fusion outputs empty result

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Repost: tophat-fusion outputs empty result

    Hi all,
    Today I run tophat-fusion-post and got empty result. Then I searched the forum and noticed that this question has been posted:
    http://seqanswers.com/forums/showthread.php?t=13096

    I wonder if anyone has solved this issue. Based on my test, I think tophat-fusion-post does not read the files in tophat_MCF7 under top_dir (assume our sample is MCF7): I prepared all other required files (ensGenes.txt, mcl, refSeq_sorted.txt, blast_human/) under top_dir but did not provide the tophat_MCF7 folder. Then I run tophat-fusion-post, it returned no error message and gave 0 fusions finally.

    My another question is: what is the point of "Making a list of known fusions (fusion_info.txt)" before running tophat-fusion-post? Could anybody answer this?

    Thank you all.

  • #2
    Thanks to Daehwan Kim, one of the Tophatfusion contributors, In my case, the PATH for Tophat aligner was not set properly: it points to the Tophat in the Tophatfusion folder. After I correct that, Tophat-fusion goes well for most of my samples.

    Comment


    • #3
      Could you tell me how did you correct it?
      In my case, I have put the path for TopHat-Fusion in my shell's PATH but still get the empty files. I really appreciate you help!

      Comment


      • #4
        You can run 'which tophat' in your shell to see if the original Tophat's 'tophat' script is the default one or Tophat-fusion's 'tophat' script is. If it still points to the Tophat-fusion installation folder, then you need to modify the PATH in your .bashrc or .bash_profile to put Tophat's folder before Tophat-fusion's.

        Hope it helps.

        Comment


        • #5
          Thanks for your reply. I have tried it but still got empty results. In addition, a note from http://tophat-fusion.sourceforge.net/index.html said that "If you have both TopHat and TopHat-Fusion installed on the same machine, you may need to put the path for TopHat-Fusion in your shell's PATH so that the sub-programs included in the TopHat-Fusion's package are used. ". I wondered when you run the first step of tophat-fusion, which
          'tophat' command you used, from Tophat's folder or Tophat-fusion's folder?

          Comment


          • #6
            I do not remember it. My suggestion is that you first set up the PATH correctly and then run the pipeline from the very beginning. If the problem occurs again, it might be wrong with something else. Another case is that in your samples, there are no fusion events at all--it is not necessary that we could observe fusions in each sample.

            Good luck!

            Comment


            • #7
              I am still curious why should we put the path for Tophat before TopHat-Fusion in the shell's PATH. In my previous run, I have added both TopHat-Fusion and tophat directories to PATH and got some problems. Some sub-programs such as "prep_reads" can be found in both Tophat and TopHat-Fusion directories. In this case, TopHat-Fusion calls these sub-program from some other place, but not from where it is supposed to be (e.g. from Tophat, not from TopHat-Fusion's package). As a result, it causes the problem.

              Thanks and have a good weekend!

              Comment


              • #8
                It seems your can run it smoothly.
                I guess there is some difference between Tophat-fusion's scripts with those of Tophat's, though they have the same file names.

                Actually we do not need to go to these details. I believe that their team will improve it and eliminate the confusion.

                Have a good weekend.

                Comment


                • #9
                  tophat-fusion-post empty results

                  hello Xia687 & Mrfox,

                  I have the same problem, and have been puzzled for a while ...

                  I can run tophat-fusion without any problems. But when I tried tophat-fusion-post, I always got empty results. I have been using MCF7 data that tophat-fusion-post uses as demo so I should be able to repeat their results but I couldn't.

                  I tried changing the PATH as Mrfox suggested but didn't see anything difference. It looked to me tophat-fusion-post is not using balst and blast_human directory because I renamed that folder and removed blastn and blastall, it did not complain, and the log file always looks like
                  "
                  /site/app/x86_64/tophatfusion/v0.1.0/tophat-fusion-post:16: DeprecationWarning: the sets module is deprecated
                  from sets import Set
                  [Mon Feb 6 09:46:21 2012] Beginning TopHat-Fusion post-processing run (v0.1.0 (Beta))
                  -----------------------------------------------
                  [Mon Feb 6 09:46:21 2012] Extracting 23-mer around fusions and mapping them using Bowtie
                  [Mon Feb 6 09:46:21 2012] Filtering fusions
                  0 fusions are output in ./tophatfusion_out/potential_fusion.txt
                  [Mon Feb 6 09:46:25 2012] Blasting 50-mers around fusions
                  [Mon Feb 6 09:46:25 2012] Generating read distributions around fusions
                  [Mon Feb 6 09:46:25 2012] Reporting final fusion candidates in html format
                  num of fusions: 0
                  -----------------------------------------------
                  Run complete [00:00:04 elapsed]
                  ESC[HESC[JESC[HESC[JESC[1;31m... Bye-byeESC[0m

                  "

                  Any idea? Appreciate your help!

                  Comment


                  • #10
                    Hi wzhang1001,

                    Did you create the directory structure strictly as instructed in the Tophat-fusion webpage?

                    Comment


                    • #11
                      Yes. I followed the instructions posted on tophat-fusion, and created top_dir and copied ensGene.txt,ensGtp.txt,mcl,refGene_sorted.txt under top_dir, and also created a blast_human directory that conatins human_genomic*(unzipped) and nt* (unzipped) from NCBI.

                      But looked like tophat-fusion-post didn't look for those blast files which it is supposed to.

                      Thanks for your quick reply.

                      Comment


                      • #12
                        what is the "mcl" for? where to get it?

                        Comment


                        • #13
                          what is the "mcl" ??

                          Comment


                          • #14
                            mcl (known gene fusions) can be obtained from previous tophatfusion version (in annotation directory), http://tophat-fusion.sourceforge.net...n-0.1.0.tar.gz

                            Comment


                            • #15
                              an observation

                              not sure if you've all got this to work, but my version of tophat-fusion-post (from tophat2) points to:

                              blast/

                              for the blast database, not blast_human/ as listed in the tutorial webpage.

                              you can change the code, or just put the blast db's into top_dir/blast

                              good luck,

                              sf

                              Comment

                              Working...
                              X