Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems transferring annotations with RATT

    Im fairly new to bioinformatics, and I've been having significant trouble using RATT as part of the PAGIT set of tools, and was hoping to find some help here, as I could not find any links to support options provided by the developers on the RATT page: http://ratt.sourceforge.net/index.html

    At this point I would be happy just to find such a support option

    What I have is the reference yeast mitochondrial genome, along with its features, and the mitochondrial genome for another strain assembled from PacBio reads. My goal is to transfer the annotations from the reference onto the newly assembled genome. Doing a few alignments of just the primary exons (there are very few) of the reference confirmed for me that these sequences are present and in good synteny between the two.

    RATT documentation:


    Yeast mitochondrial translation table: http://www.ncbi.nlm.nih.gov/Taxonomy...cgi?mode=c#SG3

    Checking the RATT documentation, I set up a config file that looks like this:
    #START
    ATA
    ATG
    #STOP
    TAA
    TAG
    #SPLICE
    GT..AG
    #CORRECTSPLICE
    1

    I am unaware if RATT is accounting for other codon differences, but these were the only parameters I saw specified for the config in the documentation, and am uncertain if I should have specified additional parameters to account for those differences



    Next I set the RATT_HOME and RATT_CONFIG variables as described in the documentation, and then tried to execute start.ratt.sh.

    I've uploaded the embl file here: http://pastebin.com/bm6wS69u The reference sequence was correctly named with the fasta header being the same as the name of the embl file.

    This is what I ran, and the results:
    jwolter1@bravo:~/PAGIT/PAGIT/RATT$ RATT_HOME=/home/jwolter1/PAGIT/PAGIT/RATT; export RATT_HOME
    jwolter1@bravo:~/PAGIT/PAGIT/RATT$ RATT_CONFIG=/home/jwolter1/PAGIT/PAGIT/RATT/ratt_yeastMT.config; export RATT_CONFIG

    jwolter1@bravo:~/PAGIT/PAGIT/RATT/TESTING$ $RATT_HOME/start.ratt.sh /home/jwolter1/PAGIT/PAGIT/RATT/embl /home/jwolter1/PA GIT/PAGIT/RATT/ContigConsensus.fasta TESTING Strain /home/jwolter1/PAGIT/PAGIT/RATT/embl/reference.fasta
    I am using the reference /home/jwolter1/PAGIT/PAGIT/RATT/embl/reference.fasta. Please make sure that the description line of each fasta entry is the same than in the embl file name!
    >Refeatures
    should be the same name as the embl file in embl
    Refeatures.embl reference.fasta


    ERROR: Could not parse delta file, nucmer.TESTING.delta
    error no: 400
    ERROR: Could not parse delta file, nucmer.TESTING.filter.delta
    error no: 402
    ERROR: Could not parse delta file, nucmer.TESTING.delta
    error no: 400
    ERROR: Could not parse delta file, nucmer.TESTING.filter.delta
    error no: 402
    Use of uninitialized value $stats in print at /home/jwolter1/PAGIT/PAGIT/RATT/main.ratt.pl line 94.
    ERROR: Could not parse delta file, nucmer.TESTING.delta
    error no: 400
    ERROR: Could not parse delta file, nucmer.TESTING.filter.delta
    error no: 402
    ERROR: Could not parse delta file, nucmer.TESTING.delta
    error no: 400
    ERROR: Could not parse delta file, nucmer.TESTING.filter.delta
    error no: 402
    working on Refeatures
    Use of uninitialized value in split at /home/jwolter1/PAGIT/PAGIT/RATT/main.ratt.pl line 1172.
    Overview of transfere of annotation elements:
    86 elements found.
    0 Elements were transfered.
    0 Elements could be transfered partially.
    0 Elements split.
    117 Parts of elements (i.e.exons tRNA) not transferred.
    86 Elements couldn't be transferred.

    CDS:
    28 Gene models to transfer.
    0 Gene models transferred correctly.
    0 Gene models partially transferred.
    0 Exons not transferred from partial CDS matches.
    28 Gene models not transferred.

    1 Sequences where generated
    Done.
    Couldn't open file to Seqparate ..//home/jwolter1/PAGIT/PAGIT/RATT/embl/reference.fasta No such file or directory
    If you want to start artemis on this replicon:
    art TESTING.TestRun1_rep_c155.final.embl + TESTING.TestRun1_rep_c155.Report.gff + Query/TESTING.TestRun1_rep_c155.Mutatio ns.gff
    rm: cannot remove `TESTING.*embl.tmp.BBA.embl': No such file or directory
    jwolter1@bravo:~/PAGIT/PAGIT/RATT/TESTING$

    My principle problem here is that I cannot seem to find the actual delta file to examine if anything went wrong with the alignment. Without this I don't really know how I can determine why the transfer is failing when I know that there should be good alignments.

    The resulting files look like this:
    -rw-r--r-- 1 jwolter1 jwolter1 0 Jan 15 16:33 nucmer.TESTING.coords
    -rw-r--r-- 1 jwolter1 jwolter1 0 Jan 15 16:33 nucmer.TESTING.filter.coords
    -rw-r--r-- 1 jwolter1 jwolter1 0 Jan 15 16:33 nucmer.TESTING.filter.delta
    -rw-r--r-- 1 jwolter1 jwolter1 0 Jan 15 16:33 nucmer.TESTING.snp
    drwxr-xr-x 2 jwolter1 jwolter1 10 Jan 15 16:33 Query
    -rw-r--r-- 1 jwolter1 jwolter1 79323 Jan 15 16:33 query.21703
    -rw-r--r-- 1 jwolter1 jwolter1 79587 Jan 15 16:33 query.21703.mutated
    drwxr-xr-x 2 jwolter1 jwolter1 10 Jan 15 16:33 Reference
    drwxr-xr-x 2 jwolter1 jwolter1 10 Jan 15 16:33 ReferenceSequences
    drwxr-xr-x 2 jwolter1 jwolter1 38 Jan 15 16:33 Sequences
    -rw-r--r-- 1 jwolter1 jwolter1 26747 Jan 15 16:33 TESTING.Refeatures.NOTTransfered.embl
    -rw-r--r-- 1 jwolter1 jwolter1 109932 Jan 15 16:33 TESTING.TestRun1_rep_c155.final.embl

    All of the nucmer related files are empty. It seems like the alignment failed and this is why transfer failed.

    Any help on this would be vastly appreciated!

  • #2
    Hi, I got the same error saying "ERROR: Could not parse delta file, nucmer.data.delta error no: 400".
    Did you find the solution? If yes, could you tell me? Thanks!

    Comment


    • #3
      Hi all,

      sorry for never replying to this thread, as I have not seen it. Normally people contact me directly.

      This reported error is due to the fact that nucmer cannot generate a comparison file. Following reasons:
      1. The fasta header of the target sequence has special symbols that mumer does not like
      2. The reference in the embl directory is not in proper embl format.
      3. Mumer has problemes to run, maybe too big genomes (the current version in the PAGIT version is working on large genomes > 1gb, but give it > 120GB of ram)

      Looking at the first post, a bug could be, that the directory is given as absolute path, but I need to check.

      I hope this helps...

      Comment

      Latest Articles

      Collapse

      • seqadmin
        Current Approaches to Protein Sequencing
        by seqadmin


        Proteins are often described as the workhorses of the cell, and identifying their sequences is key to understanding their role in biological processes and disease. Currently, the most common technique used to determine protein sequences is mass spectrometry. While still a valuable tool, mass spectrometry faces several limitations and requires a highly experienced scientist familiar with the equipment to operate it. Additionally, other proteomic methods, like affinity assays, are constrained...
        04-04-2024, 04:25 PM
      • seqadmin
        Strategies for Sequencing Challenging Samples
        by seqadmin


        Despite advancements in sequencing platforms and related sample preparation technologies, certain sample types continue to present significant challenges that can compromise sequencing results. Pedro Echave, Senior Manager of the Global Business Segment at Revvity, explained that the success of a sequencing experiment ultimately depends on the amount and integrity of the nucleic acid template (RNA or DNA) obtained from a sample. “The better the quality of the nucleic acid isolated...
        03-22-2024, 06:39 AM

      ad_right_rmr

      Collapse

      News

      Collapse

      Topics Statistics Last Post
      Started by seqadmin, 04-11-2024, 12:08 PM
      0 responses
      34 views
      0 likes
      Last Post seqadmin  
      Started by seqadmin, 04-10-2024, 10:19 PM
      0 responses
      37 views
      0 likes
      Last Post seqadmin  
      Started by seqadmin, 04-10-2024, 09:21 AM
      0 responses
      31 views
      0 likes
      Last Post seqadmin  
      Started by seqadmin, 04-04-2024, 09:00 AM
      0 responses
      53 views
      0 likes
      Last Post seqadmin  
      Working...
      X