Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMOS installation on 64-bit Linux

    I keep banging my head against the keyboard trying to install the AMOS package on my 64-bit Linux system (Ubuntu 9.10). I think I have qt3 installed correctly, but I could be wrong.

    If anyone has successfully installed the AMOS package (e.g. to use hawkeye) for a 64-bit system, can you help me walk through the installation?

    Any help would be much appreciated!

    ariel

  • #2
    I guess what you need is:

    some modified .cc files from Ariadna Rodriguez Chamorro (ariadna dot rodriguez at unil dot ch).

    when you drop your E-mail I can send these replacements

    What I learned the short read version is not working, you should use amos v 2.0.8, worked for me on 64 bit Fedora 11

    v.

    Comment


    • #3
      Thanks for the reply, v_kisand. I've sent an email to Ariadna. I have been trying to install amos 2.0.8, not the short tools.

      Looking forward to finally getting this resolved.

      Comment


      • #4
        Thanks for the reply and thanks Arianda for the files. However, there was no change. I type $ ./configure, then "make", and still get the same errors:

        IDMap_AMOS.cc: In member function ‘void AMOS::IDMap_t::read(const std::string&)’:
        IDMap_AMOS.cc:504: error: ‘fopen’ was not declared in this scope
        IDMap_AMOS.cc:509: error: ‘fscanf’ was not declared in this scope
        IDMap_AMOS.cc:515: error: ‘fscanf’ was not declared in this scope
        IDMap_AMOS.cc:517: error: ‘getc’ was not declared in this scope
        IDMap_AMOS.cc:529: error: ‘EOF’ was not declared in this scope
        IDMap_AMOS.cc:540: error: ‘EOF’ was not declared in this scope
        IDMap_AMOS.cc:557: error: ‘fclose’ was not declared in this scope
        make[3]: *** [libAMOS_a-IDMap_AMOS.o] Error 1
        make[3]: Leaving directory `/home/bioinformatics/programs/amos-2.0.8/src/AMOS'
        make[2]: *** [all-recursive] Error 1
        make[2]: Leaving directory `/home/bioinformatics/programs/amos-2.0.8/src'
        make[1]: *** [all-recursive] Error 1
        make[1]: Leaving directory `/home/bioinformatics/programs/amos-2.0.8'
        make: *** [all] Error 2

        qt3 is installed and operational, as judging by "qmake" working.

        I think this is a common error, but not sure how to fix it.

        ariel

        Comment


        • #5
          hmm, looks like C++ problem...

          othrewise I run
          ./configure --with-Qt-dir= ...

          Qt is used for GUIs even when qt3.3 is missing or not directed, the compilation runs fine, non-GUI part will be built

          make
          make install

          v.

          Comment


          • #6
            The interesting information that you can post in situations like these is: what version of which compiler you are using, and the error messages that are produced.

            Judging from the error messages you have now posted, you're using GCC 4.4.x or thereabouts.

            Add "#include <cstdio>" to the top of src/AMOS/IDMap_AMOS.cc, right after the similar <cstring> line. This file will then compile successfully; you might need to do similar things to other source files.

            Comment


            • #7
              jmarshall, thanks for your reply. It was helpful - I added the #include <cstdio> in the files that were giving me problems, and this got me through some errors. I indeed have the GCC compiler 4.4.4.1.

              My current situation is this:

              $ ./configure --prefix=/home/bioinformatics/amos-2.0.8/bin --with-Qt-dir=/usr/lib/qt3 --with-Qt-lib-dir=/usr/lib64/qt3

              then

              $ make

              Quite a few things ran, then it stopped with:

              FileSystem.cc: In static member function ‘static bool FileSystem::isCreatableFile(const char*)’:
              FileSystem.cc:59: error: invalid conversion from ‘const char*’ to ‘char*’
              FileSystem.cc: In static member function ‘static char* FileSystem::getAbsolutePath()’:
              FileSystem.cc:138: warning: ignoring return value of ‘char* getcwd(char*, size_t)’, declared with attribute warn_unused_result
              make[3]: *** [FileSystem.o] Error 1
              make[3]: Leaving directory `/home/bioinformatics/programs/amos-2.0.8/src/Foundation'
              make[2]: *** [all-recursive] Error 1
              make[2]: Leaving directory `/home/bioinformatics/programs/amos-2.0.8/src'
              make[1]: *** [all-recursive] Error 1
              make[1]: Leaving directory `/home/bioinformatics/programs/amos-2.0.8'
              make: *** [all] Error 2


              I added the #include line in FileSystem.cc, but that doesn't solve the problem. I also added #include <string.h> to Foundation/ConfigFile.cc as suggested by Mike Schatz in the AMOS forum, but that didn't help.

              Comment


              • #8
                It turns out that there are two classes of problem compiling AMOS with GCC 4.4.x, and all instances of both are in fact fixed in AMOS's CVS repository. Hopefully the AMOS people will release a 2.0.9 sometime soon that compiles with current GCC.

                In the meantime:

                1. As you've found, you need to add "#include <cstdio>" to four source files. This fixes the existing "<blah> was not declared" errors.

                2. To fix these "invalid conversion" errors in three files, you need to change "char * p" to "const char * p" in the vicinity of each error, like this:

                The world's largest development and download repository of Open Source code and applications

                The world's largest development and download repository of Open Source code and applications

                and similarly in src/Align/align_poly.cc.

                -- John

                Comment


                • #9
                  John, (jmarshall) - you are my saviour! I finally got it to install, after weeks of banging my head against the wall! The combination of adding the #include <cstdio> to four or five files and changing "char * p" to "const char * p" in three or four others finally did it. AMOS is now installed and fully functional!

                  John, if you are ever in Berkeley, I want to take you out for a beer!

                  ariel

                  Comment


                  • #10
                    Ariel and John,
                    Thank you very much. It also solved my problem. Fora nyone with the same problem, here is how my problem is solved. I hope in the ext AMOS it will be fixed


                    First
                    add "#include <stdio.h>" to these files:

                    $AMOS$/src/AMOS/IDMap_AMOS.cc
                    $AMOS$/src/AMOS/Message_AMOS.cc
                    $AMOS$/src/Common/amp.cc
                    $AMOS$/src/Foundation/Options.cc

                    edit AMOS > src > Foundation > FileSystem.cc
                    const char * end_of_path = strrchr(filename, PATH_DELIMINATOR);

                    Edit line 250, 288 and 360 of AMOS > src > Align > align.cc
                    char * p; const char * p;

                    add
                    #include <iomanip> to AMOS > src > Align > overlap-align.cc
                    and edit line 274/5
                    cout << setw(3) << trace[k].score << endl;

                    then make and make instell
                    That was it, It should work
                    Regards
                    Eskeatnaf

                    Comment


                    • #11
                      AMOS Input Files

                      Anyone has tried running sequence data in AMOS. I am unable to find the way to start after installing AMOS since the documentation is so unorganized. I have paried end data from illumina 75bp. Can anybody help how to convert fastq reads to amos format?
                      ~Adnan~

                      Comment


                      • #12
                        i think you can try soapdenovo

                        Comment


                        • #13
                          Thanks for reply Bio-x but i have been assigned to do comparative assembly not denovo but i can try after it. But first i want to look at AMOS since it took 6 banging days to install it and now i want to use it.
                          ~Adnan~

                          Comment


                          • #14
                            For me, there is just 2 days of banging my head on the keyboard. I'm also on a Linux-64 with a GCC4.
                            I tried to apply the modification you mentioned but I'm still under errors, perhaps have I made a mistake somewhere.

                            Is it possible to send me the modified version of the files, I will later put this files on a server for the other users of AMOS (I think we are not alone to "try" using AMOS on a 64b Linux)!

                            Comment


                            • #15
                              My mail address is dfog22 (at) hotmail.com

                              Comment

                              Latest Articles

                              Collapse

                              • seqadmin
                                Current Approaches to Protein Sequencing
                                by seqadmin


                                Proteins are often described as the workhorses of the cell, and identifying their sequences is key to understanding their role in biological processes and disease. Currently, the most common technique used to determine protein sequences is mass spectrometry. While still a valuable tool, mass spectrometry faces several limitations and requires a highly experienced scientist familiar with the equipment to operate it. Additionally, other proteomic methods, like affinity assays, are constrained...
                                04-04-2024, 04:25 PM
                              • seqadmin
                                Strategies for Sequencing Challenging Samples
                                by seqadmin


                                Despite advancements in sequencing platforms and related sample preparation technologies, certain sample types continue to present significant challenges that can compromise sequencing results. Pedro Echave, Senior Manager of the Global Business Segment at Revvity, explained that the success of a sequencing experiment ultimately depends on the amount and integrity of the nucleic acid template (RNA or DNA) obtained from a sample. “The better the quality of the nucleic acid isolated...
                                03-22-2024, 06:39 AM

                              ad_right_rmr

                              Collapse

                              News

                              Collapse

                              Topics Statistics Last Post
                              Started by seqadmin, 04-11-2024, 12:08 PM
                              0 responses
                              15 views
                              0 likes
                              Last Post seqadmin  
                              Started by seqadmin, 04-10-2024, 10:19 PM
                              0 responses
                              21 views
                              0 likes
                              Last Post seqadmin  
                              Started by seqadmin, 04-10-2024, 09:21 AM
                              0 responses
                              16 views
                              0 likes
                              Last Post seqadmin  
                              Started by seqadmin, 04-04-2024, 09:00 AM
                              0 responses
                              44 views
                              0 likes
                              Last Post seqadmin  
                              Working...
                              X