Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • arkanion
    replied
    htseq-count bug

    I have tried the above suggestion changing the limit to 30G but still get the same error.

    Any fix yet?
    Last edited by arkanion; 08-19-2016, 10:16 PM. Reason: improved info

    Leave a comment:


  • fanli
    replied
    It's a really easy fix. Editing my file (yours may be in a different location):
    Code:
    sudo vim +625 /usr/lib64/python2.7/site-packages/HTSeq-0.6.1p1-py2.7-linux-x86_64.egg/HTSeq/__init__.py
    in vim, replace the max_buffer_size default setting (my new setting is bolded):
    Code:
    def pair_SAM_alignments_with_buffer( alignments, max_buffer_size=[B]30000000[/B] ):

    Leave a comment:


  • pengchy
    replied
    Maybe we just need a more work to sort the bam file according to read name "samtools sort -n"

    Leave a comment:


  • SrCardgage
    replied
    disheartening

    It's rather disheartening that this has been a known issue for more than a year and there is still no fix.

    I just switched to DESeq from Cufflinks and am learning my THIRD method of generating the counts matrix to feed into DESeq.

    I'm beginning to wonder if any published bioinfo tools are actually usable in the real world.

    Leave a comment:


  • catbus
    replied
    P.S. subread only takes about 10 minutes to install. It doesn't have any complicated dependencies. Once again: http://subread.sourceforge.net/

    Leave a comment:


  • catbus
    replied
    Two options:

    You can either re-sort your files lexographically/alphabetically and run htseq-counts with the lexigraphic order (in other words, NOT --order=pos)

    or

    You can switch to the much faster and generally more user friendly (easier options, easier output file format) program "featureCounts". Part of the "subread" package. http://subread.sourceforge.net/

    I would switch to subread. htseq-counts is incredibly slow and very poor at handling large files without crashing.


    [QUOTE=dc3000;161213]Is there a way to increase the buffer size?

    I got this error with a pos-sorted.bam file (3.2GB) created with tophat2

    [CODE]
    [xxx@dev-intel14-phi 20131017mRNA_gfCC]$ htseq-count --format=bam --stranded=no --order=pos \

    Leave a comment:


  • dc3000
    replied
    Is there a way to increase the buffer size?

    I got this error with a pos-sorted.bam file (3.2GB) created with tophat2

    Code:
    [xxx@dev-intel14-phi 20131017mRNA_gfCC]$ htseq-count --format=bam --stranded=no --order=pos \
    > ~/RTSF/hiseq/20131017mRNA_gfCC/ms12cc2/accepted_hits.bam \
    > ~/RTSF/hiseq/20131017mRNA_gfCC/genes.gtf \
    > > ~/RTSF/hiseq/20131017mRNA_gfCC/htseq/ms12cc2.txt
    100000 GFF lines processed.
    ...
    16100000 SAM alignment record pairs processed.
    16200000 SAM alignment record pairs processed.
    Error occured when processing SAM input (record #35593187 in file /mnt/home/xxx/RTSF/hiseq/20131017mRNA_gfCC/ms12cc2/accepted_hits.bam):
      Maximum alignment buffer size exceeded while pairing SAM alignments.
      [Exception type: ValueError, raised in __init__.py:671]
    [xxx@dev-intel14-phi 20131017mRNA_gfCC]$ Write failed: Broken pipe

    Leave a comment:


  • golharam
    replied
    I get this problem as well using tophat2 aligned BAM files, position sorted. I will revert to name sorting.

    Leave a comment:


  • catbus
    replied
    It appears that this problem is not addressed in 0.6.1p2 either.

    It would be extremely nice if there were a way to use htseq-count on positionally-sorted data (which is the default Tophat output). Maybe there could be an option that htseq-count could use to just increase the buffer size? I have 48 GB of RAM on this machine, so it is not possible that htseq-count could actually consume it all on one file.

    Leave a comment:


  • dakl
    replied
    I get the same with reads aligned with star, and position sorted using samtools.

    Code:
    tools/samtools view /home/daniel.klevebring/cust001/tests/fullRNA/L8760/rnaseq/L8760T/L8760T.star.50.stranded.PE.bam 
    | htseq-count  --stranded=reverse --mode=intersection-nonempty  --order=pos - /mnt/hds/proj/cust001/autoseq_genome/genes/genes_fixed.gtf > /home/daniel.kleveb
    ring/cust001/tests/fullRNA/L8760/rnaseq/L8760T/L8760T.star.50.stranded.PE.htseq-count.txt
    
    ...
    18900000 SAM alignment record pairs processed.
    Error occured when processing SAM input (line 40808946):
      Maximum alignment buffer size exceeded while pairing SAM alignments.
      [Exception type: ValueError, raised in __init__.py:671] 
    
    $ htseq-count |grep version
    Public License v3. Part of the 'HTSeq' framework, version 0.6.1p1.
    I don't always get it, and it runs with larger files without a problem. What's the best fix for this? Is there one?

    Leave a comment:


  • sidderb
    replied
    As Simon reads these I just wanted to flag up that I have run into the same issue with a position sorted alignment from STAR as well.

    I was so excited to see this feature in 0.6 as the position to name based ordering is an annoyingly long step in my workflow! Fingers crossed for a fix soon...

    Leave a comment:


  • mehaffeymg
    replied
    Working now

    Originally posted by Simon Anders View Post
    When you used the name-sorted file, have you remembered to omit the "-r pos"?
    Excellent catch. I reran without that flag and it worked just fine.

    Thank you!

    Leave a comment:


  • Simon Anders
    replied
    When you used the name-sorted file, have you remembered to omit the "-r pos"?

    Leave a comment:


  • mehaffeymg
    replied
    I get the same "Maximum alignment buffer size exceeded" whether running my bam file as position or name sorted. It gets farther with the name sorted file than the position sorted file (output size of 1 Gb vs. 600+ Mb respectively) but still fails. My input bam is 11Gb of around 142 million reads.

    Leave a comment:


  • Bukowski
    replied
    Have hit the same problem with STAR aligner, and positional ordering.

    12200000 SAM alignment record pairs processed.
    Error occured when processing SAM input (record #27408270 in file alignments/S6.bam):
    Maximum alignment buffer size exceeded while pairing SAM alignments.
    [Exception type: ValueError, raised in __init__.py:671]
    Last edited by Bukowski; 03-19-2014, 08:51 AM.

    Leave a comment:

Latest Articles

Collapse

  • seqadmin
    The Impact of AI in Genomic Medicine
    by seqadmin



    Artificial intelligence (AI) has evolved from a futuristic vision to a mainstream technology, highlighted by the introduction of tools like OpenAI's ChatGPT and Google's Gemini. In recent years, AI has become increasingly integrated into the field of genomics. This integration has enabled new scientific discoveries while simultaneously raising important ethical questions1. Interviews with two researchers at the center of this intersection provide insightful perspectives into...
    02-26-2024, 02:07 PM
  • seqadmin
    Multiomics Techniques Advancing Disease Research
    by seqadmin


    New and advanced multiomics tools and technologies have opened new avenues of research and markedly enhanced various disciplines such as disease research and precision medicine1. The practice of merging diverse data from various ‘omes increasingly provides a more holistic understanding of biological systems. As Maddison Masaeli, Co-Founder and CEO at Deepcell, aptly noted, “You can't explain biology in its complex form with one modality.”

    A major leap in the field has
    ...
    02-08-2024, 06:33 AM

ad_right_rmr

Collapse

News

Collapse

Topics Statistics Last Post
Started by seqadmin, 02-28-2024, 06:12 AM
0 responses
27 views
0 likes
Last Post seqadmin  
Started by seqadmin, 02-23-2024, 04:11 PM
0 responses
74 views
0 likes
Last Post seqadmin  
Started by seqadmin, 02-21-2024, 08:52 AM
0 responses
82 views
0 likes
Last Post seqadmin  
Started by seqadmin, 02-20-2024, 08:57 AM
0 responses
69 views
0 likes
Last Post seqadmin  
Working...
X