Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • laoding of large data on tablet_viewer???

    Hi,

    i have my ace file of 9.42 GB containing 28 million reads of 75 bp length (for solexa/illumina data). i am unable to load it on tablet.

    Is there any way to load it on tablet?

    OR can we split ace file into two parts? Is there any way?

    Thanks

  • #2
    A couple of suggestions:

    - Convert it to BAM if you can.

    - Run Tablet with more memory (http://bioinf.scri.ac.uk/tablet/help/memory.shtml), on a 64bit machine if you can.

    - If the ACE file has multiple contigs in it, see if you can pre-process the file to save out the contigs, one per file.

    Iain
    Our software: Tablet | Flapjack | Strudel | CurlyWhirly | TOPALi

    Comment


    • #3
      reply to imilne for tablet

      thanks for ur suggestions

      yes i tried it already, by increasing the memory of tablet on 64 bit. but after completion of all 28 million reads upto 100% it gives the error of memory.

      and my ace file has a single contig as it is for mapping assembly.

      Comment


      • #4
        How much memory do you have? A 9GB ace file will probably contain a lot of additional data that Tablet will throw away anyway (because it doesn't use it), so I would expect it to load with just a few GB of memory.

        If it's not, then maybe something more serious is wrong...

        Iain
        Our software: Tablet | Flapjack | Strudel | CurlyWhirly | TOPALi

        Comment


        • #5
          my RAM is 4 GB. but i also tried it on 20 GB system after increasig the default memory of tablet.

          but tablet loads when i use filtered data but by that way my information is being lost, so i have to use unfiltered data.

          Comment


          • #6
            Originally posted by saima View Post
            my RAM is 4 GB. but i also tried it on 20 GB system after increasig the default memory of tablet.

            but tablet loads when i use filtered data but by that way my information is being lost, so i have to use unfiltered data.
            What OS? Is this 32bit or 64bit?

            Comment


            • #7
              Originally posted by saima View Post
              my RAM is 4 GB. but i also tried it on 20 GB system after increasig the default memory of tablet.

              but tablet loads when i use filtered data but by that way my information is being lost, so i have to use unfiltered data.
              Hmm, something's not right. 4GB might be tight, but I would expect it to manage. With 20GB it should be laughing. Can you check how much memory Tablet thinks it's getting by looking at the About box? Make sure it is what you changed the vmoptions file to.

              Tablet only stores a "skeleton" of the layout of the reads in memory. All the actual data is kept on disk, even with ACE files. It's basically a position, length, and ID per read (roughly 12 bytes + class overhead). The consensus sequence isn't kept on disk, so unless it's gigabases long, you shouldn't be having a problem.

              Iain
              Our software: Tablet | Flapjack | Strudel | CurlyWhirly | TOPALi

              Comment


              • #8
                the default memory that tablet takes is 1 GB. my consensus sequence is in MBs so i think i should rebuild ace file, may be some problem at the initial steps.

                but i also could not load it on eagle view

                thanks for ur help

                Comment


                • #9
                  Originally posted by saima View Post
                  the default memory that tablet takes is 1 GB
                  Yes, that's the default, but if you've increased it (by changing the value in the tablet.vmoptions file) then the About box should say so.

                  Look for the line stating "Memory available to JVM" and check that it's close to what you asked for. eg, if you put "-Xmx3000m" in the file (roughly 3GB) then Tablet's About box should be reporting a number close to 3000. If it's not, and it still shows a value around 1000, then Tablet isn't using more memory.

                  Iain
                  Our software: Tablet | Flapjack | Strudel | CurlyWhirly | TOPALi

                  Comment


                  • #10
                    Another thought... turn off the protein translations if you have them on. They use up memory too.

                    Iain
                    Our software: Tablet | Flapjack | Strudel | CurlyWhirly | TOPALi

                    Comment


                    • #11
                      how to turn it off, i dont know where to check for protein translation?

                      Comment


                      • #12
                        Originally posted by saima View Post
                        how to turn it off, i dont know where to check for protein translation?
                        "Options" panel on the control bar. Top row, middle button of the 2nd group.

                        Iain
                        Our software: Tablet | Flapjack | Strudel | CurlyWhirly | TOPALi

                        Comment


                        • #13
                          HI,

                          at last my ace file of 28 million reads loaded successfully.

                          let me tell, what was the problem (it is little stupid :-)). actually i changed the memory of tablet in VMoptions many times but didnt close the 'info.plist' file (so the changes couldn't be saved). when i closed it, the saving message appeared so i saved it.

                          Comment


                          • #14
                            ANYONE WHO WANT TO CHANGE DEFAULT MEMORY OF TABLET on mac system:

                            i have mac system
                            i goto my applications folder -> then right cliked tablet icon -> then cliked 'show pakage contents' -> opened Contents folder -> opened 'Info-plist'

                            then under java i changed VMoptions, as below;

                            '-Xmx10244m -XX:+UseCompressedOops'
                            change '1024' to how much memory u want. e.g 2048

                            BUT DONT FORGET TO CLOSE THE FILE TO GET IT SAVED :-)
                            Last edited by saima; 03-25-2010, 01:36 AM.

                            Comment


                            • #15
                              Gap5 can also read ace files natively, although it's not really the preferred format. (In theory this allows conversion to sam too as you can then export again, but I'm sure there are more direct routes.)

                              Comment

                              Latest Articles

                              Collapse

                              • seqadmin
                                Best Practices for Single-Cell Sequencing Analysis
                                by seqadmin



                                While isolating and preparing single cells for sequencing was historically the bottleneck, recent technological advancements have shifted the challenge to data analysis. This highlights the rapidly evolving nature of single-cell sequencing. The inherent complexity of single-cell analysis has intensified with the surge in data volume and the incorporation of diverse and more complex datasets. This article explores the challenges in analysis, examines common pitfalls, offers...
                                06-06-2024, 07:15 AM
                              • seqadmin
                                Latest Developments in Precision Medicine
                                by seqadmin



                                Technological advances have led to drastic improvements in the field of precision medicine, enabling more personalized approaches to treatment. This article explores four leading groups that are overcoming many of the challenges of genomic profiling and precision medicine through their innovative platforms and technologies.

                                Somatic Genomics
                                “We have such a tremendous amount of genetic diversity that exists within each of us, and not just between us as individuals,”...
                                05-24-2024, 01:16 PM

                              ad_right_rmr

                              Collapse

                              News

                              Collapse

                              Topics Statistics Last Post
                              Started by seqadmin, 06-07-2024, 06:58 AM
                              0 responses
                              179 views
                              0 likes
                              Last Post seqadmin  
                              Started by seqadmin, 06-06-2024, 08:18 AM
                              0 responses
                              227 views
                              0 likes
                              Last Post seqadmin  
                              Started by seqadmin, 06-06-2024, 08:04 AM
                              0 responses
                              184 views
                              0 likes
                              Last Post seqadmin  
                              Started by seqadmin, 06-03-2024, 06:55 AM
                              0 responses
                              18 views
                              0 likes
                              Last Post seqadmin  
                              Working...
                              X