Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SAMTool install error about curses

    Hi all,
    When I install SAMTool 0.1.8 on linux, I got error: cannot find -lcurses
    collect2: ld returned 1 exit status
    But I have libncurses.so installed under /usr/lib.
    After run rpm -qa | grep ncurses, I got:
    ncurses-devel-5.5-18.11
    ncurses-5.5-18.11
    yast2-ncurses-2.13.68-0.3
    ncurses-devel-32bit-5.5-18.11
    ncurses-32bit-5.5-18.11
    It seemed I've installed dependencies.
    Did I miss something? Thanks.

  • #2
    Originally posted by xinwu View Post
    Hi all,
    When I install SAMTool 0.1.8 on linux, I got error: cannot find -lcurses
    collect2: ld returned 1 exit status
    But I have libncurses.so installed under /usr/lib.
    After run rpm -qa | grep ncurses, I got:
    ncurses-devel-5.5-18.11
    ncurses-5.5-18.11
    yast2-ncurses-2.13.68-0.3
    ncurses-devel-32bit-5.5-18.11
    ncurses-32bit-5.5-18.11
    It seemed I've installed dependencies.
    Did I miss something? Thanks.
    Did you get this problem fixed?

    Comment


    • #3
      Problem Solved

      I ran into this problem as well. To get around it, change the makefile from
      Code:
      LIBCURSES= -lcurses
      to

      Code:
      LIBCURSES= -lncurses
      That should fix the problem.

      Comment


      • #4
        Thanks RCJ, just found your post and had been struggling with that!

        Comment


        • #5
          thank you, RockChalkJayhawk. I had a same problem and your answer solved the problem.

          Open SUSE 11.3
          samtools 0.1.18
          =======================================
          $ pwd
          /opt/utillities/samtools/samtools-0.1.18
          $ vi Makefile
          - change a line in "Makefile" as follows
          -------------------------------------------------
          original: LIBCURSES= -lcurses # -lXCurses
          changed: LIBCURSES= -lncurses # -lXCurses
          --------------------------------------------------
          $ make
          - compile worked well
          ========================================

          Comment


          • #6
            I had to install ncurses-devel to make this work. I also changed the Makefile as suggested above.

            cheers
            Daniel

            Comment


            • #7
              I am getting following error while installing samtools
              The update version of zlib and ncurses are installed.
              I tried to look posts but cold not find answer to "bgzf error"

              *********************************************************************************
              make[1]: Entering directory `/root/samtools-0.1.18'
              make[2]: Entering directory `/root/samtools-0.1.18'
              gcc -c -g -Wall -O2 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_USE_KNETFILE -D_CURSES_LIB=1 -I. bgzf.c -o bgzf.o
              In file included from bgzf.c:36:
              bgzf.h:29:18: error: zlib.h: No such file or directory
              bgzf.c: In function ‘open_write’:
              bgzf.c:186: error: ‘Z_DEFAULT_COMPRESSION’ undeclared (first use in this function)
              bgzf.c:186: error: (Each undeclared identifier is reported only once
              bgzf.c:186: error: for each function it appears in.)
              bgzf.c: In function ‘deflate_block’:
              bgzf.c:297: error: ‘z_stream’ undeclared (first use in this function)
              bgzf.c:297: error: expected ‘;’ before ‘zs’
              bgzf.c:298: error: ‘zs’ undeclared (first use in this function)
              bgzf.c:305: warning: implicit declaration of function ‘deflateInit2’
              bgzf.c:305: error: ‘Z_DEFLATED’ undeclared (first use in this function)
              bgzf.c:306: error: ‘Z_DEFAULT_STRATEGY’ undeclared (first use in this function)
              bgzf.c:307: error: ‘Z_OK’ undeclared (first use in this function)
              bgzf.c:311: warning: implicit declaration of function ‘deflate’
              bgzf.c:311: error: ‘Z_FINISH’ undeclared (first use in this function)
              bgzf.c:312: error: ‘Z_STREAM_END’ undeclared (first use in this function)
              bgzf.c:313: warning: implicit declaration of function ‘deflateEnd’
              bgzf.c:345: warning: implicit declaration of function ‘crc32’
              bgzf.c: In function ‘inflate_block’:
              bgzf.c:371: error: ‘z_stream’ undeclared (first use in this function)
              bgzf.c:371: error: expected ‘;’ before ‘zs’
              bgzf.c:373: error: ‘zs’ undeclared (first use in this function)
              bgzf.c:380: warning: implicit declaration of function ‘inflateInit2’
              bgzf.c:381: error: ‘Z_OK’ undeclared (first use in this function)
              bgzf.c:385: warning: implicit declaration of function ‘inflate’
              bgzf.c:385: error: ‘Z_FINISH’ undeclared (first use in this function)
              bgzf.c:386: error: ‘Z_STREAM_END’ undeclared (first use in this function)
              bgzf.c:387: warning: implicit declaration of function ‘inflateEnd’
              bgzf.c: In function ‘check_header’:
              bgzf.c:405: error: ‘Z_DEFLATED’ undeclared (first use in this function)
              make[2]: *** [bgzf.o] Error 1
              make[2]: Leaving directory `/root/samtools-0.1.18'
              make[1]: *** [lib-recur] Error 1
              make[1]: Leaving directory `/root/samtools-0.1.18'
              make: *** [all-recur] Error 1
              *****************************************************************************

              Please help
              -Nikhil

              Comment


              • #8
                Not sure this is the appropriate thread for this problem.

                Anyhow, it looks like you're missing zlib. Did you try installing zlib-devel. If you're on RedHat/Fedora/CentOS, try

                sudo yum install zlib-devel

                //D

                Comment


                • #9
                  do yum install ncurses-devel , i hpe it will solve th issue

                  recommended for Centos , RHEL

                  Same problem faced and solved
                  Kausik Bhattacharyya
                  Delhi University

                  Comment


                  • #10
                    On an Ubuntu box all you will need is:

                    Code:
                    sudo apt-get install libncurses5 libncurses5-dev
                    to solve the missing curses.h file not found error
                    SysAdmin & ICT consultant
                    http://about.me/nicola.losito

                    Comment

                    Latest Articles

                    Collapse

                    • seqadmin
                      Recent Advances in Sequencing Analysis Tools
                      by seqadmin


                      The sequencing world is rapidly changing due to declining costs, enhanced accuracies, and the advent of newer, cutting-edge instruments. Equally important to these developments are improvements in sequencing analysis, a process that converts vast amounts of raw data into a comprehensible and meaningful form. This complex task requires expertise and the right analysis tools. In this article, we highlight the progress and innovation in sequencing analysis by reviewing several of the...
                      05-06-2024, 07:48 AM
                    • seqadmin
                      Essential Discoveries and Tools in Epitranscriptomics
                      by seqadmin




                      The field of epigenetics has traditionally concentrated more on DNA and how changes like methylation and phosphorylation of histones impact gene expression and regulation. However, our increased understanding of RNA modifications and their importance in cellular processes has led to a rise in epitranscriptomics research. “Epitranscriptomics brings together the concepts of epigenetics and gene expression,” explained Adrien Leger, PhD, Principal Research Scientist...
                      04-22-2024, 07:01 AM

                    ad_right_rmr

                    Collapse

                    News

                    Collapse

                    Topics Statistics Last Post
                    Started by seqadmin, 05-14-2024, 07:03 AM
                    0 responses
                    26 views
                    0 likes
                    Last Post seqadmin  
                    Started by seqadmin, 05-10-2024, 06:35 AM
                    0 responses
                    46 views
                    0 likes
                    Last Post seqadmin  
                    Started by seqadmin, 05-09-2024, 02:46 PM
                    0 responses
                    59 views
                    0 likes
                    Last Post seqadmin  
                    Started by seqadmin, 05-07-2024, 06:57 AM
                    0 responses
                    47 views
                    0 likes
                    Last Post seqadmin  
                    Working...
                    X