Seqanswers Leaderboard Ad



No announcement yet.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting Trans-ABySS running

    We're interested in testing out Trans-ABySS and comparing it with our other methods for RNA-Seq analysis. It seems to have a lot of potential for metatranscriptomics, since we may not always have a metagenome.

    I've finally gotten ABySS compiled (our environment was more locked down in compiler and MPI versions than I would have liked, and made it more difficult) and I am running a test right now. I think I have all the scripts and support tools for trans-ABySS installed, but there's a chance I missed one.

    Trans-ABySS expects a directory structure with results from ABySS runs with different sizes of k. Is there a script packaged with ABySS or Trans-ABySS that generates all those runs? That will make my life a lot easier than running ABySS manually, and I didn't see that in the documentation. I've got ABySS 1.2.4 and trans-ABySS 1.0, FWIW.

    I'll post my continued experience with these programs here, in case anyone else looks into going down this road.

  • #2
    What about a simple bash script?

    for i in {25..30}
    mkdir k$i;
    cd k$i;
    ABYSS -k$i -o output input.fa

    Maybe this is too basic and I didn't get the appropriate question but if it helps...


    • #3
      That bash script should work... I was way over-thinking this problem.



      • #4

        Did you able to run abyss 1.2.4?

        I could not make it work. Whenever I run, I get the following error. I tried to run on different servers. I get the same error.

        abyss-pe k=29 n=2 c=10 e=0 np=14 in='../s_3_1_sequence_fat.txt ../
        s_3_2_sequence_fat.txt' name=run82_test

        ABYSS-P: NetworkSequenceCollection.cpp:472: void
        NetworkSequenceCollection::runControl(): Assertion `opt::erode > 0'
        [test2:19382] *** Process received signal ***
        [test2:19382] Signal: Aborted (6)
        [test2:19382] Signal code: (-6)
        [test2:19382] [ 0] /lib64/ [0x3aa58302d0]
        [test2:19382] [ 1] /lib64/ [0x3aa5830265]
        [test2:19382] [ 2] /lib64/ [0x3aa5831d10]
        [test2:19382] [ 3] /lib64/ [0x3aa58296e6]
        [test2:19382] [ 4] ABYSS-P [0x40caab]
        [test2:19382] [ 5] ABYSS-P [0x4059e7]
        [test2:19382] [ 6] /lib64/
        [test2:19382] [ 7] ABYSS-P(__gxx_personality_v0+0x169) [0x404c99]
        [test2:19382] *** End of error message ***



        • #5
          I did get 1.2.4 running. So far we haven't run any pair-end or mate-pair experiments, so I wouldn't be able to replicate your problem.
          It looks like you've got an assert that failed, which is odd.

          It looks like your problem comes from the e=0 parameter. Somewhere the function NetworkSequenceCollection::SetState is being called with NAS_ERODE when the opt::erode variable is set to 0 (opt::erode gets set to 0 by e=0).

          I can see a few different places that could happen, so you may want to put in some debugging couts and figure out which one is being called right before the assert fails.


          • #6

            Thank you for your input. I am using transcriptome data. It looks like abyss does not like setting e to 0 for RNA-seq data. After I ran abyss removing c and e from my command, it completed the job without any error. Abyss could guess the correct values for c and e.

            Thank you,


            • #7
              Well, I figured out a little bug I had with ABySS and now trans-ABySS is running ( in -1 mode) so we'll see how it turns out. My first impressions are:

              This is not production-ready code.

              ABySS seems to be pretty picky about compiler and MPI versions. Trans-ABySS doesn't just have one configuration file, it has 5 general config files and 2 run-specific config files. Also, some of the general config files have some parameters that seem to be run-specific, which is a bit annoying.

              I'm not dissuaded by difficult software, so I'll keep plugging along. So far trans-ABySS has been neither easy to use nor fast to run. I'm hoping I can get it working.


              • #8
                Well, I finally got all the ABySS output ready for trans-ABySS only to find that it dies because I don't have paired-end data. Does anyone know if there is a way around this, or does trans-ABySS not handle single end data?


                • #9
                  Originally posted by mrawlins View Post
                  Well, I finally got all the ABySS output ready for trans-ABySS only to find that it dies because I don't have paired-end data. Does anyone know if there is a way around this, or does trans-ABySS not handle single end data?
                  You will get proper answer if you post your question on their discussion group:


                  • #10
                    agree its intimidating and not production ready. I am just looking at the trans-abyss manual and quite lost.

                    From this it seems I first need abyss separately and that would not be part of any trans-abyss tool set / wrappers.. pheww .. but definitely worth it seeing what the tool offers!


                    • #11
                      So, I haven't posted much lately on this as it's taken a while to get things up and running.

                      Trans-ABySS doesn't yet officially support colorspace. I was able to (using an inelegant hack) get it to run fairly well with my colorspace single-end reads, and we're encouraged. The details of that are on the Trans-ABySS Google group.

                      To those getting started, I would recommend getting ABySS working first. In general I've needed as much RAM as about three times the size of my input fasta in order for ABySS to run. If you don't have that kind of RAM you may need to run on a cluster, which requires the MPI version.

                      There are examples in the Trans-ABySS folders of the commands/parameters used to run ABySS. Basically, use abyss-pe (regardless of whether you're using single or pair end) and if you want it to use MPI give it the np=<# procs> argument.

                      The latest version of Trans-ABySS should be helpful in getting at least the 1st stage up and running. The Google group is very responsive despite its being small, so it's probably not a bad idea to post there if you're having trouble.

                      Now that it's working, it's looking much more promising. We have a few kinks to work out, but that's at least partly because the dataset we tested on was poorly suited to this kind of analysis.


                      • #12
                        I posted this on the google discussion, but might have a different audience here:

                        In preparation for trans-abyss, going through the steps in the manual,
                        I get an error when creating indexes:
                        $ python ../../annotations/hg18/ensGene.txt -i ../../
                        Traceback (most recent call last):
                        File "", line 1, in <module>
                        from analysis import transcript
                        ImportError: No module named analysis

                        Also, I am confused about the projects.cfg file. Is there a greater
                        detail or more notes on setting projects.cfg up?

                        I am looking to use a paired-end lane of Illumina to run through trans-
                        abyss. I have figured out abyss and completed analyzing that using
                        different k values.



                        Latest Articles


                        • seqadmin
                          Current Approaches to Protein Sequencing
                          by seqadmin

                          Proteins are often described as the workhorses of the cell, and identifying their sequences is key to understanding their role in biological processes and disease. Currently, the most common technique used to determine protein sequences is mass spectrometry. While still a valuable tool, mass spectrometry faces several limitations and requires a highly experienced scientist familiar with the equipment to operate it. Additionally, other proteomic methods, like affinity assays, are constrained...
                          04-04-2024, 04:25 PM
                        • seqadmin
                          Strategies for Sequencing Challenging Samples
                          by seqadmin

                          Despite advancements in sequencing platforms and related sample preparation technologies, certain sample types continue to present significant challenges that can compromise sequencing results. Pedro Echave, Senior Manager of the Global Business Segment at Revvity, explained that the success of a sequencing experiment ultimately depends on the amount and integrity of the nucleic acid template (RNA or DNA) obtained from a sample. “The better the quality of the nucleic acid isolated...
                          03-22-2024, 06:39 AM





                        Topics Statistics Last Post
                        Started by seqadmin, 04-11-2024, 12:08 PM
                        0 responses
                        Last Post seqadmin  
                        Started by seqadmin, 04-10-2024, 10:19 PM
                        0 responses
                        Last Post seqadmin  
                        Started by seqadmin, 04-10-2024, 09:21 AM
                        0 responses
                        Last Post seqadmin  
                        Started by seqadmin, 04-04-2024, 09:00 AM
                        0 responses
                        Last Post seqadmin