Announcement

Collapse

Welcome to the New Seqanswers!

Welcome to the new Seqanswers! We'd love your feedback, please post any you have to this topic: New Seqanswers Feedback.
See more
See less

Scaffolding Translational mapping (STM) - velvet assembly summary?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Scaffolding Translational mapping (STM) - velvet assembly summary?

    Hello,

    Has anyone used STM [http://genome.cshlp.org/content/early/2010/08/30/gr.103846.109.abstract[/URL] for velvet assembly summaries?

    I am trying to use it and have issues (St9bad_alloc) with multiple-k method - cd-est. Has anyone seen this before?

    Thanks!

  • #2
    Hi Canadian.

    We have tried this method and have had good results with the multiple-K (still not able to get the actual STM part to work, may be a problem with biopython?). For cd-hit-est, you have to install it separately. If you google "cd-hit-v4.3-2010-10-25.tgz" it should pull up the address for the tarball download. One thing that we also did was to run Velvet-Oases prior to the multiple K. I think the Oases step is better to include if you're doing a transcriptome (I'm assuming this if you're interested in the STM method). Are you going to also try the STM method?

    Cheers!

    Comment


    • #3
      Hi there,

      Thanks for your reply. You are right, I am trying to use STM for transcriptome assembly. I have assemblies from Velvet/oases and I am trying to use that to run the cd-hit-est and multiple-k method. My files are like this :
      /home/deepthi/All_kmers_fasta --> has contigs_25.fa contigs_29.fa contigs_31.fa Lane5_velvet_assembled_27.fa Lane678_velvet_seq_27.fa #contigs obtained from different k mers from velvet/oases#
      My command-line is:
      /home/deepthi/cd-hit-est -i /home/deepthi/All_kmers_fasta -o /home/deepthi/All_kmers_fasta_clus -c 0.9 -n 5 -M 800

      Error looks like this :
      \"Apprixmated maximum memory consumption: 593M
      writing new database

      Fatal Error:
      file opening failed
      Program halted !!

      Traceback (most recent call last):
      File \"/usr/local/software/STM/multiple-K.py\", line 84, in
      <module>
      os.remove(\'%s.bak.clstr\'%outfile)
      OSError: [Errno 2] No such file or directory:
      \'/home/deepthi/All_kmers_fasta.bak.clstr\'


      Multiple-k method with this line doesn't seem to work either : sudo /usr/local/software/STM/multiple-K.py -d /home/deepthi/All_kmers_fasta -o /home/deepthi/All_kmers_fasta -v

      The first part using the reference genome worked -- was that your question?

      Comment

      Working...
      X