Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when running TopHat

    Hi,
    this is the first time I run Tophat, and I cannot get it to work.
    I have two test fastq files, each one containing 10 reads. They align well to hg19 with bowtie:
    bowtie --phred64-quals indexes/h_sapiens_37_asm -1 test_1.fastq -2 test_2.fastq

    # reads processed: 10
    # reads with at least one reported alignment: 5 (50.00%)
    # reads that failed to align: 5 (50.00%)
    Reported 5 paired-end alignments to 1 output stream(s)

    However, tophat complains:

    tophat --keep-tmp -r 15 -o test --phred64-quals indexes/h_sapiens_37_asm test_1.fastq test_2.fastq
    I get the following output, again and again with different settings:
    [Tue Jul 12 15:06:45 2011] Beginning TopHat run (v1.3.0)
    -----------------------------------------------
    [Tue Jul 12 15:06:45 2011] Preparing output location test/
    [Tue Jul 12 15:06:45 2011] Checking for Bowtie index files
    [Tue Jul 12 15:06:45 2011] Checking for reference FASTA file
    [Tue Jul 12 15:06:45 2011] Checking for Bowtie
    Bowtie version: 0.12.7.0
    [Tue Jul 12 15:06:45 2011] Checking for Samtools
    Samtools Version: 0.1.15
    [Tue Jul 12 15:06:45 2011] Generating SAM header for indexes/h_sapiens_37_asm
    [Tue Jul 12 15:06:48 2011] Preparing reads
    format: fastq
    quality scale: phred64 (reads generated with GA pipeline version >= 1.3)
    Left reads: min. length=53, count=10
    Right reads: min. length=53, count=10
    [Tue Jul 12 15:06:48 2011] Mapping left_kept_reads against h_sapiens_37_asm with Bowtie
    [FAILED]
    Error at mkfifo(test/tmp/31660.bwt_unmapped.z.fifo). [Errno 5] Input/output error
    If anyone knows what is going on, I would be so thankful...

  • #2
    mkfifo errors in TopHat v1.3.1

    I am also unable to get the mkfifo portions of the code that were introduced in Tophat v1.3.0 and v1.3.1 to work on my system. I thought I had circumvented this problem by using the --no-unmapped-fifo option, but then it failed much later in the merge_sort.fifo portion of the code.

    As a temporary solution, I have continued to use v1.2.0, though I would like to try out the new features in 1.3.1, so it would be great to understand what may be causing these errors.

    I am certainly not an expert in the nuances of Linux, so I am not sure what the problem is. I don't have root permissions where bowtie is installed on my system - would that make a difference?

    I look forward to a resolution to this problem.

    Thanks!

    Comment


    • #3
      Hi,
      well, I finally got the answer to my problem. I'll paste it here, since it may be useful for others...
      Here is what the developers of Tophat told me by email:

      This seems to be an error related to the underlying file system -- some file systems do not support the mkfifo() call that Tophat currently uses. For example, if the underlying partition/volume that is hosting the tophat output directory is a Windows (NTFS) volume, mkfifo() will fail. We will address this problem in the next release (removing the mkfifo() call), but until then the only solution to this is to redirect's tophat output (using -o/--output-dir) to (or run tophat in) a directory which resides on a different volume/partition which uses a file system that supports mkfifo(). Using a local directory with a native file system usually works for this. Of course you must also make sure that you have enough space on this output volume, as the output and temporary files are quite large (about twice the size of the original data).
      That was indeed my case (NTFS volume). I changed to another volume, and it worked.
      Hope that helps!

      Comment


      • #4
        This problem seems to have been resolved in the latest version of TopHat (according to release notes) 1.3.2 beta.

        Comment

        Latest Articles

        Collapse

        • seqadmin
          The Impact of AI in Genomic Medicine
          by seqadmin



          Artificial intelligence (AI) has evolved from a futuristic vision to a mainstream technology, highlighted by the introduction of tools like OpenAI's ChatGPT and Google's Gemini. In recent years, AI has become increasingly integrated into the field of genomics. This integration has enabled new scientific discoveries while simultaneously raising important ethical questions1. Interviews with two researchers at the center of this intersection provide insightful perspectives into...
          02-26-2024, 02:07 PM
        • seqadmin
          Multiomics Techniques Advancing Disease Research
          by seqadmin


          New and advanced multiomics tools and technologies have opened new avenues of research and markedly enhanced various disciplines such as disease research and precision medicine1. The practice of merging diverse data from various ‘omes increasingly provides a more holistic understanding of biological systems. As Maddison Masaeli, Co-Founder and CEO at Deepcell, aptly noted, “You can't explain biology in its complex form with one modality.”

          A major leap in the field has
          ...
          02-08-2024, 06:33 AM

        ad_right_rmr

        Collapse

        News

        Collapse

        Topics Statistics Last Post
        Started by seqadmin, Yesterday, 06:12 AM
        0 responses
        17 views
        0 likes
        Last Post seqadmin  
        Started by seqadmin, 02-23-2024, 04:11 PM
        0 responses
        67 views
        0 likes
        Last Post seqadmin  
        Started by seqadmin, 02-21-2024, 08:52 AM
        0 responses
        73 views
        0 likes
        Last Post seqadmin  
        Started by seqadmin, 02-20-2024, 08:57 AM
        0 responses
        62 views
        0 likes
        Last Post seqadmin  
        Working...
        X