Announcement

Collapse
No announcement yet.

tophat-fusion-post result empty

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • tophat-fusion-post result empty

    Hello,

    Does anyone use tophat-fusion-post? After I run it, the output is empty. I put the tophat-fusion outputs, blast database and annotation files in the same directory. command line I used is:
    tophat-fusion-post -p 8 --num-fusion-reads 1 --num-fusion-pairs 2 --num-fusion-both 5 hg18

    I don't know what's wrong with the process. I really appreciate someone's help.

    Thanks,

  • #2
    I'm having the same issue. After I ran the tophat-fusion, i generated the folder structure shown on the website with blast binaries and sequences. When I run tophat-fusion-post; it starts by extracting 23mers around fusions and maps them using bowtie. I have fusion_seq.bwtout, fusion_seq.fa and fusion.seq.map files generated. After tophat-fusion-post filters the fusions, it puts 0 fusions into potential_fusion.txt. Anyone with any ideas why this may be? My filtering criteria is min fusion reads is to be 1 and I know there are fusions with more than 1 reads in the fusions.out file from tophat-fusion. I tried to follow the python code but got lost after a while since i'm new in this. any help is greatly appreciated. thanks.

    Comment


    • #3
      I've got the same problem. It extracts and maps the 23-mers without a problem but no potential fusions are identified. If you follow their "awk filtering" suggestion on the fusion.out file the first line is a known IgH translocation is this sample with over 100 reads spanning the break, 100 pairs flanking, etc... I think I'll try and simulate a BCR-ABL translocation and see if that gets mapped and survives filtering. It would be nice if there was a small test dataset to validate each install like they have for bowtie and tophat.

      Comment


      • #4
        I actually wanted to use the fusion-post for the way it presents the results. like giving you gene names along with chr coordinates and showing the reads around the fusion point. when i do the filtering with 10 reads being my filter, i get about 20 fusions and going around trying to figure the genes out manually seems a bit mundane given i have a lab meeting for next week. oh well.

        Comment


        • #5
          This weekend I download and ran the MCF7 dataset on the tophat-fusion website using the settings described in the manual. No luck the potential_fusion.txt file is empty still. I've put in a question to the tophat-cufflinks email so I'll post if I get any answers.

          Comment


          • #6
            i hope you hear from them jon. do post here if you do.

            Comment


            • #7
              No response yet but I have a feeling there is some odd compiling issue between systems. I've tried three things"
              1) compiled from source on linux = tophat-fusion fails (never tried tophat-fusion-post)
              2) tried pre-compiled linux binary = tophat-fusion works, tophat-fusion-post fails to identify any fusion even in MCF7 data from developer site
              3) tried pre-compiled mac binary = tophat-fusion works, tophat-fusion-post identifies fusions but I get a blast error (looks to be memory limitation of my laptop).

              Comment


              • #8
                when i complied from the source, tophat-fusion had failed to compile all together for a reason i failed to understand. then used the precompiled version for mac and got the error i listed above. wonder if we'll hear from them.

                Comment


                • #9
                  I did forget to mention that I've tried compiling from source on a mac and get the same error more or less that you saw

                  Code:
                  -- tophat 1.2.0 Configuration Results --
                    C compiler:          gcc -Wall -arch x86_64 -O3  -DNDEBUG
                    C++ compiler:        g++ -Wall -arch x86_64 -O3  -DNDEBUG -I/Users/jkeats/local/include
                    GCC version:         i686-apple-darwin10-gcc-4.2.1 (GCC) 4.2.1 (Apple Inc. build 5664)
                    Host System type:    i386-apple-darwin10.8.0
                    Install prefix:      /Users/jkeats/local2
                    Install eprefix:     ${prefix}
                  
                    See config.h for further configuration information.
                    Email <[email protected]> with questions and bug reports.
                  
                  jkeats-ML:tophatfusion-0.1.0 jkeats$ make
                  make  all-recursive
                  Making all in src
                  g++ -Wall -arch x86_64 -O3  -DNDEBUG -I/Users/jkeats/local/include -I./SeqAn-1.2 -Wall -arch x86_64 -O3  -DNDEBUG -I/Users/jkeats/local/include  -L/usr/lib -o prep_reads -L/Users/jkeats/local/lib prep_reads.o ../src/libtophat.a -lbam -lz -lz 
                  Undefined symbols:
                    "_solToPhred", referenced from:
                        charToPhred33(char, bool, bool)in prep_reads.o
                  ld: symbol(s) not found
                  collect2: ld returned 1 exit status
                  make[2]: *** [prep_reads] Error 1
                  make[1]: *** [all-recursive] Error 1
                  make: *** [all] Error 2
                  Did you align to hg18 or hg19? The annotation files provided in the package are for hg19. In my case for comparison, I'm running the mac binary on a snow leopard machine, aligning to hg19 provided on the bowtie site. At least when I tested the MCF7 dataset using the settings on the website it works less the blast error and generated reports with annotated breaks with gene names, positions, exon number, etc..

                  Comment


                  • #10
                    I've got the same problem.
                    I contacted the authors, but not have received a response.
                    Has anyone solved this yet?

                    Comment


                    • #11
                      No. I checked the code, but could not figure out how it can be empty. I run on Python 2.6.5, an 2.7.1, none of them worked.

                      A bit frustrating, because I already finished tophat-fusion step for12 samples with a big effort.

                      Plus, I could not use existing genes.gtf at the tophat-fusion step. It worked if I did not provide an existing genes.gtf.

                      Comment


                      • #12
                        Same problems here. Tried on Mac and Ubuntu (with python 2.7.1). The tophat-fusion-post did not work. Contacted the author but no response.

                        Comment


                        • #13
                          I just tried tophat-fusion-post - freshly downloaded mac binaries - and it actually worked. the only problem is the html file doesn't show my fusions and i think blast is working probably because of the way i unzipped the database. anyone care commenting whether i have the right configuration for the database?

                          Comment


                          • #14
                            tophat-fusion-post example

                            Hi Ahametz,

                            I'm still struggling to get the tophat-fusion-post example to work -- I also get no fusions even though all the fusions.out files in their MCF7 example certainly contain fusion candidates. In other words, I don't even get to the blast stage.

                            I'm using tophat 2.0.4 and tophat-fusion ran without issues.

                            Any help would be really appreciated.

                            thanks,
                            t

                            Comment


                            • #15
                              I used as well MCF7 to test TopHat-Fusion but it worked for me.
                              I am using symlinks for the blast and indexes directories (it works as well if the tophat_MCF7_1 files are symlinks).

                              The structure I am using to run tophat-fusion-post is the following:

                              TopHatFusion_MCF7
                              ----blast
                              ----blast_human # symbolic link to the blast directory
                              ----indexes # hg19 indexes / bowtie1
                              ----mcl
                              ----refGene.txt
                              ----ensGene.txt
                              ----tophat_MCF7_1
                              --------accepted_hits.bam
                              --------deletions.bed
                              --------fusions.out
                              --------insertions.bed
                              --------junctions.bed
                              --------logs
                              --------prep_reads.info
                              --------unmapped.bam
                              ----tophatfusion_out

                              The blast directory looks like:

                              blast
                              ----human_genomic.00.nhd
                              ----human_genomic.00.nhi
                              [...]
                              ----nt.00.nhd
                              ----nt.00.nhi
                              [...]
                              ----other_genomic.00.nhd
                              ----other_genomic.00.nhi
                              [...]

                              The command I am using:
                              tophat-fusion-post -p 1 --num-fusion-reads 1 --num-fusion-pairs 2 --num-fusion-both 5 indexes/hg19

                              I am using bowtie/0.12.7, samtools/0.1.18 and blast+/2.2.26
                              This works with both tophat-2.0.3 (tophat-2.0.3.Linux_x86_64.tar.gz) and tophat-2.0.4 (tophat-2.0.4.Linux_x86_64.tar.gz)

                              Hope this helps

                              Emilie

                              Comment

                              Working...
                              X