Announcement

Collapse
No announcement yet.

Tophat cannot evoke bowtie from under qsub

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tophat cannot evoke bowtie from under qsub

    Hi

    I come across a strange problem. I have all the latest tophat, bowtie, samtools installed locally. All the tree programs are also in my $PATH.

    When I run tophat on the test sequences it does not report any problems and produces the output files as expected.

    however, when I run the same command but submitting it via qsub to the cluster, then tophat (which is evoked with the full path) starts up correctly but when it checks for bowtie it reports:
    [Wed Sep 7 12:28:38 2011] Checking for Bowtie
    Error locating program: bowtie
    Any idea what could be wrong with the setup/configuration?
    Thanks
    K

  • #2
    If you qsub a script that does "echo $PATH", does it include the path to bowtie? It's possible that your dotfiles (eg, .bashrc) set the PATH differently for an interactive session.

    Comment


    • #3
      Thanks but it does not unfortunately; I run

      qsub -b y -e /mnt/fastfs/KW_Temp/installs -o /mnt/fastfs/KW_Temp/installs/ "echo $PATH > bow"

      I have put PATH to both .bashrc and .profile files but it still does not help.

      Comment


      • #4
        You have at least two options:

        1) figure out what dotfiles are being used when your job is executed and modify those. I'd save this for the next time you're bored.

        2) set PATH in your job. You could do this by
        a) writing a script that sets PATH and then invokes tophat
        b) qsub "PATH=${PATH}:/path/to/bowtie tophat ....."

        Note that the behavior of (b) depends on whether you use single or double quotes. Double will use PATH from the shell where you call qsub. Single will use PATH from inside the job.

        Comment


        • #5
          Also, and it depends on your version of qsub (mine is PBSpro and does not have your '-b' parameter) try the '-V' parameter. My version says:

          -V Declares that all environment variables in the user's login environment where
          qsub is run are to be exported to the job. The job's Variable_List attribute
          is appended with all of these environment variables and their values.

          Comment


          • #6
            I somehow made it:
            I made a bash script which first export the PATH with directories to tophat,bowtie, and samtools; and then runs the tophat.

            I am running this script from within qsub with single quotes

            THanks fall al suggestions
            K

            Comment

            Working...
            X