Header Leaderboard Ad


New version of MOSAIK available



No announcement yet.
  • Filter
  • Time
  • Show
Clear All
new posts

  • New version of MOSAIK available

    Hi guys,

    Just wanted to mention that a new version of MOSAIK is now available:


    Additionally, MOSAIK has finally been released under the GPL license! Feel free to grab the source here:



    // Michael

  • #2
    can not align now

    I cannot use the new versions 1.0

    The old version worked fine. When I change to use the new version. The step “mosaikaligner” tells“segmentation fault” although I have rebuilt the reference and reads.


    • #3
      Interesting. This certainly is not happening for most people.

      Could you go to the bug reporting site and describe the error there:


      Please include any program output and command-line parameters as well.

      The best chance for me to fix the bug you are experiencing is if I can reproduce the error in question.

      Thanks for testing the software!

      // Michael


      • #4
        Firstly, thanks for making Mosaik available.

        I have been trying the OS X build under OS X 10.4 ("Tiger") I too experienced segmentation faults (and bus errors) when running all Mosaik components. I managed to get them to run by compiling from source with the following modified macosx.inc

        # define our processor specific flags
        export PLATFORM_FLAGS = -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -Dstat64=stat -Dfstat64=fstat
        export LDFLAGS = -Wl
        I haven't tested the output of the recompiled binaries extensively and I'm not a programmer so I don't know if the above changes will affect the results obtained with Mosaik.


        • #5

          It seems the name of my contigs is not proper which cause the problem "segmentation fault". the name of the last hundreds of contigs have "+" and "-", as I deleted these, they work fine. thank you!


          • #6
            @Nick: Thanks for the updated Mac OS X compilation options. These will be used when the MOSAIK update is pushed out this weekend.

            @csffq: I'll take a look at why MOSAIK didn't like the '+' and '-' characters in the reference sequence names. Theoretically, it shouldn't matter, but I'll look into it either way.

            Thanks again for the feedback,

            // Michael


            • #7
              How can make gigaBayes a little fast?

              Currently I am using mosaic package to align my solexa reads to reference of transcriptome. It works well as producing snp and coverage information.

              Here I write to ask for help as some problems happen to me. When I used mosaikassemble to produce assemble files, it produce more than ten thousands files because the reference is more than 20000 contigs. When I tried to use gigabayes to get snp information from those .gig files produced by mosaikassemble, I have to run the command one by one, it really costs a lot of time.

              Is there any way to get only one resulting file from mosaikassemble command, so that I could run gigabayes only once to get all the snp information from transcriptome?

              Or is there some way to ran gigabayes with those more than ten thousand files just faster?


              • #8
                cssffq, how about joining your contigs into a single 'reference'? You will know the contig boundaries, and can 'separate' them after. Could add some N's in between each contig to to make it easier to identify the boundaries.


                • #9
                  Re: about gigaBayes

                  I have merged the 20000 contigs into one whole sequence as you have said. with MosaikAssemble it produce only one .gig file. When using gigaBayes it still runs slowly, probably need 4-5 whole days to finish the task.
                  Fortunately I can just wait for the computer to finish the job, and then with perl scirpt to extract the useful information, thank you a lot!


                  • #10
                    Hi all I want to use Mosaik for assembling a bacterial genome but the problem is that I can't access the API because when I go c++ or perl directory and write make it's gives error so any one can guide me about this, thanks in advance.