No announcement yet.
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    maq getting started


    sorry but I usually don't work with Macs so I can't really help you. However I have some thoughts about your last error message:

    It seems that you are trying to compile a 64bit version of maq by linking a 32bit library which can't work. You could try two things:

    make clean
    set the environment variable CC to "gcc -m32" (I assume gcc is your compiler)

    make clean
    edit the file Makefile.generic and look for CFLAGS; change -m64 into -m32
    make -f Makefile.generic

    Hmm, I don't know if that really helps you. You could also ask the author of maq for a compiled binary for your Mac.

    Maybe one of the other mac users in this forum can help you out ...

    Wish you luck ,



    • #17
      To Andreas,

      actually you did help me, so thank you, thank you.

      you are quite correct that I was trying to compile a 64bit version of maq by linking a 32bit library.

      Editing the Makefile.generic at CFLAGS did solve the problem.

      I now just have to find some example data to trial the program with while I wait for our sequence to come.

      thanks very much again



      • #18
        easy run failed

        hi while running maq-0.6.8 in easy run command i am getting this error msg.
        fail to run command '(cd easyrun; /usr/local/bin/maq map -n 2 -e 70 -u [email protected] [email protected] ref.bfa [email protected] 2> [email protected])' at ../maq-0.6.8/scripts/ line 842
        can any one tell me the possible reason for this failed msg?


        • #19
          Same error here...

          -- 0 potential soa-indels pass the filter.
          -- 2 potential pe-indels pass the filter.
          -- CMD: (cd easyrun; ln -s cns.filter.snp)
          ln: creating symbolic link `cns.filter.snp': File exists
          ** fail to run command '(cd easyrun; ln -s cns.filter.snp)' at /usr/local/bin/ line 842.
          ** fail to run command '(cd maqdemo; /usr/local/bin/ easyrun -p -d easyrun ref.bfa r1.fq r2.fq)' at /usr/local/bin/ line 842.

          I am new to MAQ... as well as to this forum, so kindly forgive me if i go wrong somewhere...
          and kindly help in solving the above error..


          • #20
            --> ln: creating symbolic link `cns.filter.snp': File exists <--

            The script tries to create a link cns.filter.snp to the file However this is not possible if the link already exists. A linux thing ...

            Simply remove all files that were created by an previous run and try again ...



            • #21
              running maq on linux ubuntu 32 bit

              Thanks for the reply andpet, yes what you mentioned is true and in the above case the problem was because of that only.
              I had tried running after clearing the existing output files. I would like to first mention here that i am now able to successfully execute the MAQ demo. I would also like to share another piece of experience here:
              I am working on a 32 bit core 2 duo, Linux machine.
              Though I was able to run the maq v0.6.8 executables, directly downloaded from the sourceforge download page, i was unable to run this version compiled from source code on my machine.
              Invariably I was getting stuck at the following error during execution:

              *** buffer overflow detected ***: /home/.../maq-0.7.1/scripts/maq terminated


              ** fail to run command '(cd maqdemo; /home/.../maq-0.7.1/scripts/maq simustat easyrun/ > eval.simustat)' at ./ line 842.

              Later I discovered that it was coming because of a compile time optimization parameter in the Makefile.generic:

              CFLAGS= -g -Wall -O2 -m64 # comment out `-m64' for 32-bit compilation

              removed the '-O2' from the above flag and changed -m64 to -m32 (as mentioned in other posts) and compiled the source code. This solved the purpose and ran the executable to completion.
              Last edited by kunalfab; 11-04-2009, 10:44 PM.


              Latest Articles


              • seqadmin
                Advanced Tools Transforming the Field of Cytogenomics
                by seqadmin

                At the intersection of cytogenetics and genomics lies the exciting field of cytogenomics. It focuses on studying chromosomes at a molecular scale, involving techniques that analyze either the whole genome or particular DNA sequences to examine variations in structure and behavior at the chromosomal or subchromosomal level. By integrating cytogenetic techniques with genomic analysis, researchers can effectively investigate chromosomal abnormalities related to diseases, particularly...
                09-26-2023, 06:26 AM
              • seqadmin
                How RNA-Seq is Transforming Cancer Studies
                by seqadmin

                Cancer research has been transformed through numerous molecular techniques, with RNA sequencing (RNA-seq) playing a crucial role in understanding the complexity of the disease. Maša Ivin, Ph.D., Scientific Writer at Lexogen, and Yvonne Goepel Ph.D., Product Manager at Lexogen, remarked that “The high-throughput nature of RNA-seq allows for rapid profiling and deep exploration of the transcriptome.” They emphasized its indispensable role in cancer research, aiding in biomarker...
                09-07-2023, 11:15 PM





              Topics Statistics Last Post
              Started by seqadmin, Yesterday, 09:38 AM
              0 responses
              Last Post seqadmin  
              Started by seqadmin, 09-27-2023, 06:57 AM
              0 responses
              Last Post seqadmin  
              Started by seqadmin, 09-26-2023, 07:53 AM
              1 response
              Last Post seed_phrase_metal_storage  
              Started by seqadmin, 09-25-2023, 07:42 AM
              0 responses
              Last Post seqadmin