Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cufflinks 'std::bad_alloc'

    Hello all,

    Can anyone suggest a reason for, or potential fix to, Cufflinks quitting with the following error?

    terminate called after throwing an instance of 'std::bad_alloc'

    I am running Cufflinks 0.9.3 on an Amazon instance of Fedora linux with 7GB of memory (and 500Gb storage). I am analyzing large (Illumina PE 101bp HiSeq) .bam files (>5Gb).

    As I am using the Amazon EC2, I can activate another instance with more 'RAM' (up to 32GB), and see if this helps. I will post for others' reference to see if this fixes my problem. If anyone has suggestions though, please post for my reference!

    Any other comments are much appreciated.

    Thanks,
    Dan

    Update: After trying a few different things and talking briefly with Adam Roberts (Developer on Cufflinks), it seems like the problem is with the specific binary that I downloaded (linux x86_64) and the specific version of linux I was running (fedora). I was able to fix the problem by running this locally on my mac using the Mac OSX binary. Alternatively, it was suggested to build Cufflinks from source rather than grabbing a binary. Had some trouble installing boost libraries, so for now will just stick with OSX. Note: the same library that is throwing the error before now takes >24 hours on a similar machine as what I was running on Linux.
    Last edited by DanWebster; 02-06-2011, 09:32 PM. Reason: Update

  • #2
    Having the same the problem, with no solutions. However our BAM file is 31GB in size. We are running this on a system with 12 cpus and 32GB of RAM.

    Any advice would be greatly appreciated.

    Comment


    • #3
      I got the same error message with a BAM file of about 500 MB on a 4-CPU machines with 12 GB RAM. It is a 64 bits Linux distribution (kernel 2.6.18); I will try to launch the same cufflink job on my Mac to see if it makes a difference.

      Aurelien

      Comment


      • #4
        I compiled cuffdiff from source and still get this error:

        terminate called after throwing an instance of 'std::bad_alloc'
        what(): std::bad_alloc

        I am using cufflinks 1.0.3 on Ubuntu 10.10, kernel 2.6.35-30-generic.

        Pascal

        Comment


        • #5
          Hi all,

          I'm having the same problem running cufflinks v1.0.3 on a 64 bit Centos OS, 16Gb of RAM

          has anyone solved this?


          thanks in advance


          M.

          Comment


          • #6
            For me it turned out, that this error message probably occurred due to insufficient memory. I ran the same job on a cluster without any problems. Cuffdiff used over 32GB of ram + some swap.

            Comment


            • #7
              Hi,

              I just finished a project with cufflinks last week (Redhat 64bit with latest Tophat and Cufflinks, 24 cores and 32G memory) without any problem. One way to trouble-shoot is to reduce the read counts and/or split the reference sequences. Usually if memory is the bottleneck, these measures will solve the problem, or at least confirm the root cause.

              Thank you,
              Douglas

              Comment


              • #8
                sudden std bad alloc

                I've been running bedtools on a virtual machine and have used genomeCoverageBed to make bedgraph files for months now. I didn't change anything, and all of a sudden the script throws std bad alloc. How was there enough memory yesterday but not today? Any ideas on how I can troubleshoot? I'm completely at a loss.

                Comment


                • #9
                  Hi Everyone

                  I have the same error, but i haven't access to a cluster.
                  My pc is using UBUNTU 12.04, Newbler 2.3.
                  It is 4 gb RAM
                  ...i have the error:
                  "...terminate called after throwing an instance of 'std::bad_alloc'
                  what(): St9bad_alloc

                  Error: An internal error (exit status 134) has occurred in the computation.
                  Please report this error to your customer support representative."

                  Any solution?

                  Comment


                  • #10
                    You are most likely running out of memory. 4GB is unfortunately just not enough for many things now.

                    Comment


                    • #11
                      Originally posted by GenoMax View Post
                      You are most likely running out of memory. 4GB is unfortunately just not enough for many things now.
                      Do you know if there is some public server to run the assembly?

                      Comment


                      • #12
                        check here: https://usegalaxy.org/

                        Thank you,
                        Douglas

                        Comment

                        Latest Articles

                        Collapse

                        • seqadmin
                          Exploring the Dynamics of the Tumor Microenvironment
                          by seqadmin




                          The complexity of cancer is clearly demonstrated in the diverse ecosystem of the tumor microenvironment (TME). The TME is made up of numerous cell types and its development begins with the changes that happen during oncogenesis. “Genomic mutations, copy number changes, epigenetic alterations, and alternative gene expression occur to varying degrees within the affected tumor cells,” explained Andrea O’Hara, Ph.D., Strategic Technical Specialist at Azenta. “As...
                          07-08-2024, 03:19 PM
                        • seqadmin
                          Exploring Human Diversity Through Large-Scale Omics
                          by seqadmin


                          In 2003, researchers from the Human Genome Project (HGP) announced the most comprehensive genome to date1. Although the genome wasn’t fully completed until nearly 20 years later2, numerous large-scale projects, such as the International HapMap Project and 1000 Genomes Project, continued the HGP's work, capturing extensive variation and genomic diversity within humans. Recently, newer initiatives have significantly increased in scale and expanded beyond genomics, offering a more detailed...
                          06-25-2024, 06:43 AM

                        ad_right_rmr

                        Collapse

                        News

                        Collapse

                        Topics Statistics Last Post
                        Started by seqadmin, 07-10-2024, 07:30 AM
                        0 responses
                        18 views
                        0 likes
                        Last Post seqadmin  
                        Started by seqadmin, 07-03-2024, 09:45 AM
                        0 responses
                        197 views
                        0 likes
                        Last Post seqadmin  
                        Started by seqadmin, 07-03-2024, 08:54 AM
                        0 responses
                        206 views
                        0 likes
                        Last Post seqadmin  
                        Started by seqadmin, 07-02-2024, 03:00 PM
                        0 responses
                        190 views
                        0 likes
                        Last Post seqadmin  
                        Working...
                        X