Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • tahamasoodi
    replied
    Hi,

    I'm getting the same error message. How it can be sorted out?

    samtools: bam_plcmd.c:612: group_smpl: Assertion `id >= 0 && id < m->n' failed

    Leave a comment:


  • rubi
    replied
    Hi vinodhsri,

    Did you manage to solve the [bcf_sync] incorrect number of fields (0 != 5) problem?

    I'm facing the same problem myself.

    Thanks,
    rubi

    Leave a comment:


  • vinodhsri
    replied
    [bcf_sync] incorrect number of fields Error:

    Has anyone encountered this error ('[bcf_sync] incorrect number of fields (0 != 5)') and found a solution already:


    vcfutils.pl splitchr -l 50000000 ucsc.hg19.fasta.fai | xargs -i echo samtools mpileup -I -C50 -m3 -F0.0002 -DSuf ucsc.hg19.fasta -r {} -b bam.list | bcftools view -bcvg - /> part-{}.bcf

    [bcf_sync] incorrect number of fields (0 != 5) at 0:0
    [afs] 0:0.000
    xargs: echo: terminated by signal 13

    Appreciate your advice.

    vsri

    Leave a comment:


  • aatu18
    replied
    Hi,

    How did you solve this error, samtools: bam_plcmd.c:596: group_smpl: Assertion `id >= 0 && id < m->n' failed ? I am repeatedly getting this error! I have a merged and sorted bam file, which I am using to call SNPs using bcftools. i merged multiple sorted bam files using a "rg.txt" file I created..

    Where should I look first ?

    Thanks for any help!

    aarti

    Leave a comment:


  • jamminbeh
    replied
    How can I implement the -I option? I've tried:

    /u/local/apps/samtools/0.1.11/samtools mpileup -I -uf hg19.fa accepted_hits.bam

    and

    /u/local/apps/samtools/0.1.11/samtools mpileup -ufI hg19.fa accepted_hits.bam

    and I still get the same error:

    [bcf_sync] incorrect number of fields (8 != 5). Corrupted file?

    Leave a comment:


  • Hkins552
    replied
    Is there anyway to avoid using the -I option? I would still like to call the INDELs on my file. My error is:

    [bcf_sync] incorrect number of fields (6 != 5) at 0:33736084
    [afs] 0:27544.812 1:16105.314 2:36880.874

    Leave a comment:


  • Haiqing
    replied
    I think I just removed these @RG header from SAM file(I do not use the read groups in my case).

    Leave a comment:


  • oudacontrol
    replied
    How did you fix the read group issue? I am getting the same error: "bam_plcmd.c:596: group_smpl: Assertion `id >= 0 && id < m->n' failed" ...

    Leave a comment:


  • Haiqing
    replied
    Thanks! It works now!

    BTW, I also tried the old "pileup" for SNP/INDEL call with my deep sequencing data (50000+). Somehow, the pileup out only count 8000 read depth (column eight of the pileup output) for the first reference base. And then add one more read for every next base(like 8001 for second reference base, 8002 for third reference base, and so on). Any suggestions(I already give the -d60000 option to increase the max read depth. It works for mpileup, but not for pileup)? Thanks.
    Last edited by Haiqing; 03-21-2011, 03:40 PM.

    Leave a comment:


  • lh3
    replied
    You have read groups undefined in the header

    Leave a comment:


  • Haiqing
    replied
    Another error message when do the first step for SNP call using samtools:
    samtools mpileup -uf reference.fna sample.sort.bam |bcftools view -bvcg - > var.raw.bcf
    [mpileup] 1 samples in 1 input files
    samtools: bam_plcmd.c:596: group_smpl: Assertion `id >= 0 && id < m->n' failed.
    Aborted
    :-(

    Any suggestions?

    Leave a comment:


  • Haiqing
    replied
    Hi! lh3,

    I got similar error:
    [bcf_sync] incorrect number of fields (0 != 5). Corrupted file?
    [afs] 0:0.000

    What does this mean?

    Thanks

    Leave a comment:


  • gaffa
    replied
    I am also getting this error. I wonder if it would be possible to somehow sort out positions with excessively many indels before running mpileup.

    Leave a comment:


  • bair
    replied
    Originally posted by lh3 View Post
    No, your results are truncated.
    Yes, you are right. I get more variants with -I option on chr:MT.

    Leave a comment:


  • lh3
    replied
    No, your results are truncated.

    Leave a comment:

Latest Articles

Collapse

  • seqadmin
    Exploring the Dynamics of the Tumor Microenvironment
    by seqadmin




    The complexity of cancer is clearly demonstrated in the diverse ecosystem of the tumor microenvironment (TME). The TME is made up of numerous cell types and its development begins with the changes that happen during oncogenesis. “Genomic mutations, copy number changes, epigenetic alterations, and alternative gene expression occur to varying degrees within the affected tumor cells,” explained Andrea O’Hara, Ph.D., Strategic Technical Specialist at Azenta. “As...
    07-08-2024, 03:19 PM
  • seqadmin
    Exploring Human Diversity Through Large-Scale Omics
    by seqadmin


    In 2003, researchers from the Human Genome Project (HGP) announced the most comprehensive genome to date1. Although the genome wasn’t fully completed until nearly 20 years later2, numerous large-scale projects, such as the International HapMap Project and 1000 Genomes Project, continued the HGP's work, capturing extensive variation and genomic diversity within humans. Recently, newer initiatives have significantly increased in scale and expanded beyond genomics, offering a more detailed...
    06-25-2024, 06:43 AM

ad_right_rmr

Collapse

News

Collapse

Topics Statistics Last Post
Started by seqadmin, 07-10-2024, 07:30 AM
0 responses
26 views
0 likes
Last Post seqadmin  
Started by seqadmin, 07-03-2024, 09:45 AM
0 responses
201 views
0 likes
Last Post seqadmin  
Started by seqadmin, 07-03-2024, 08:54 AM
0 responses
212 views
0 likes
Last Post seqadmin  
Started by seqadmin, 07-02-2024, 03:00 PM
0 responses
193 views
0 likes
Last Post seqadmin  
Working...
X