Header Leaderboard Ad


SMRT Tools ipdSummary Error



No announcement yet.
  • Filter
  • Time
  • Show
Clear All
new posts

  • SMRT Tools ipdSummary Error

    Hello everyone,

    I downloaded the latest version of the SMRT Link software ( and I am trying to run the ipdSummary tool of the SMRT Tools. We obtained PacBio Sequel II sequencing data of a sample and control without the modifications in question.

    I aligned both sequencing sets to the reference genome using pbmm2. Then, I tried to run the following command:

    ipdSummary --reference reference_Genome.fasta --outfile mod_test --control control.alignmentset.xml sample.alignmentset.xml
    Unfortunately I receive this error and I have been unable to fix it myself:

    Process KineticsWriter-2:
    Traceback (most recent call last):
      File "/work/project/ladsie_002/smrtlink/install/smrtlink-release_8.0.0.80529/bundles/smrttools/install/smrttools-release_8.0.0.80502/private/thirdparty/python/python_2.7.16/lib/python2.7/multiprocessing/process.py", line 267, in _bootstrap
      File "/work/project/ladsie_002/smrtlink/install/smrtlink-release_8.0.0.80529/bundles/smrttools/install/smrttools-release_8.0.0.80502/private/thirdparty/python/python_2.7.16/site-packages/kineticsTools/ResultWriter.py", line 116, in run
      File "/work/project/ladsie_002/smrtlink/install/smrtlink-release_8.0.0.80529/bundles/smrttools/install/smrttools-release_8.0.0.80502/private/thirdparty/python/python_2.7.16/site-packages/kineticsTools/ResultWriter.py", line 101, in _run
      File "/work/project/ladsie_002/smrtlink/install/smrtlink-release_8.0.0.80529/bundles/smrttools/install/smrttools-release_8.0.0.80502/private/thirdparty/python/python_2.7.16/site-packages/kineticsTools/ResultWriter.py", line 952, in onResult
      File "/work/project/ladsie_002/smrtlink/install/smrtlink-release_8.0.0.80529/bundles/smrttools/install/smrttools-release_8.0.0.80502/private/thirdparty/python/python_2.7.16/site-packages/kineticsTools/ResultWriter.py", line 583, in alt_hdf5CsvConsumer
        tMean[idx] += float(x['tMean'])
    KeyError: 'tMean'
    When I run the command without specifying a custom control with --control, I do not receive this error. However, we are looking for modifications that are not in the in silico database, hence we sequenced both a sample and a control. I would be grateful for any support.

Latest Articles


  • seqadmin
    A Brief Overview and Common Challenges in Single-cell Sequencing Analysis
    by seqadmin

    ​​​​​​The introduction of single-cell sequencing has advanced the ability to study cell-to-cell heterogeneity. Its use has improved our understanding of somatic mutations1, cell lineages2, cellular diversity and regulation3, and development in multicellular organisms4. Single-cell sequencing encompasses hundreds of techniques with different approaches to studying the genomes, transcriptomes, epigenomes, and other omics of individual cells. The analysis of single-cell sequencing data i...

    01-24-2023, 01:19 PM
  • seqadmin
    Introduction to Single-Cell Sequencing
    by seqadmin
    Single-cell sequencing is a technique used to investigate the genome, transcriptome, epigenome, and other omics of individual cells using high-throughput sequencing. This technology has provided many scientific breakthroughs and continues to be applied across many fields, including microbiology, oncology, immunology, neurobiology, precision medicine, and stem cell research.

    The advancement of single-cell sequencing began in 2009 when Tang et al. investigated the single-cell transcriptomes
    01-09-2023, 03:10 PM