Header Leaderboard Ad

Collapse

BFast+BWA Only using one Core

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BFast+BWA Only using one Core

    I am using BFAST+BWA for SOLiD alignment. When I run the following command:

    PHP Code:
    bfast bwaaln -t 16 --f results/solid0131_20100330_2_bc_WTA_Tumor_Lib2_F3.bmf ref/hg19.fa reads/solid0131_20100330_2_bc_WTA_Tumor_Lib2_F3.fastq 

    I am only getting one CPU running on my Dual Quad Core Server (which appears as 16 CPU cores). I have run the simple bwa and am getting multiple core usage - so I am pretty sure its not my server and Ubuntu installation.

    Does anyone have any suggestions on how to debug?

  • #2
    The multithreaded mode does not quick in immediately. It only happens when bwa is computing the alignments.

    Run your bwa instance in one console. In the other one, dump the vmstat command output to a file.

    Once the execution is completed... look at the first columns of the vmstat output across time.. you should see 16 at some point.

    BTW, you said it is a dual quad core, that should be a 8 core machine (perhaps is hyperthreaded?)
    -drd

    Comment


    • #3
      Is running bwa_aln_core...

      drio, Thanks for the reply. Yes its hyperthreading. So, with my machine I can run 16 threads.

      The algorithm is in [bwa_aln_core] and still not spawing more than one thread. I was just checking to see if anyone had similar issues with bfast Version: 0.6.4e while running bwaaln.

      Do you have any other suggestions?

      Michael

      Comment


      • #4
        Solved BFAST bwaaln only running One core

        I figured it out.

        The autogen config.h file contains a define called HAVE_LIBPTHREAD that is required by bwaaln.c in order for threading to be compiled in.

        The solution I found was to add the following code to the bfast/BLibDefinitions.h file.

        #include "../config.h"

        bwaaln.c picks up the HAVE_LIBPTHREAD and everything works like a champ.

        Michael

        Comment


        • #5
          Originally posted by michaelkre View Post
          I figured it out.

          The autogen config.h file contains a define called HAVE_LIBPTHREAD that is required by bwaaln.c in order for threading to be compiled in.

          The solution I found was to add the following code to the bfast/BLibDefinitions.h file.

          #include "../config.h"

          bwaaln.c picks up the HAVE_LIBPTHREAD and everything works like a champ.

          Michael
          Patch applied. Thank-you kindly for figuring it out. I good place to send help is [email protected] (for help) or [email protected] (for developer questions).

          Comment


          • #6
            I am trying to run bfast bwaaln -A 1 "ref.fa" "reads.fastq"
            but I am getting an error invalid option -A
            then How can mention for color reads bcoz my index file with color reads is not recognized without -A option.

            Please help me out

            Comment

            Working...
            X