Welcome to the New Seqanswers!

Welcome to the new Seqanswers! We'd love your feedback, please post any you have to this topic: New Seqanswers Feedback.
See more
See less

Could not locate a bowtie index corresponding to basename -- tried posted solutions

  • Filter
  • Time
  • Show
Clear All
new posts

  • Could not locate a bowtie index corresponding to basename -- tried posted solutions


    I am running on Ubuntu 16 and am trying to analyze my data with Bowtie2. I have managed to get this exact script to work on a windows machine running cygwin, but can't figure out this problem that arose on Linux.

    I am getting the classic "Could not located Bowtie index corresponding to basename "directory", yet I have listed a path directing to the base file name 'mm10', not the folder as many people here have posted about before.

    Things that I have tried:

    Changing to directory the index is located and running bowtie2.

    Adding the directory the index is located in to PATH.

    Placed the index in a folder in the bowtie2 directory, in my downloads directory, and the desktop. All with the same result.

    I have tried building an index from scratch or downloading a prebuilt one from bowtie2.

    I am running the code within a script to align multiple reads, but I have also tried manually calling bowtie to individual fastq files.
    bowtie2 index:
    call to bowtie2: 
    bowtie2 --local --very-sensitive-local --no-unal -q --phred33 --threads 12 -x /user/home/Downloads/mm10/mm10 -U BS_P384R_S_S30_L002_R1_001.fastq > BS_P384R_S
    Could not locate a Bowtie index corresponding to basename "/user/home/Downloads/mm10/mm10"
    Error: Encountered internal Bowtie 2 exception (#1)
    Command: /home/user/anaconda3/bin/bowtie2-align-s --wrapper basic-0 --local --very-sensitive-local -q --phred33 --threads 12 -x /user/home/Downloads/mm10/mm10 --passthrough -U BS_P384R_S_S30_L002_R1_001.fastq 
    (ERR): bowtie2-align exited with value 1
    Traceback (most recent call last):
      File "/home/user/phd/", line 92, in <module>
        py_bowtie_single_end('/home/user/phd/NGYHF03', list_output_sam = outputs, bowtie2_index = mm10)
      File "/home/user/phd/", line 87, in py_bowtie_single_end
        check_output(temp_str, shell=True)
      File "/home/user/anaconda3/lib/python3.6/", line 336, in check_output
      File "/home/user/anaconda3/lib/python3.6/", line 418, in run
        output=stdout, stderr=stderr)
    subprocess.CalledProcessError: Command 'bowtie2 --local --very-sensitive-local --no-unal -q --phred33 --threads 12 -x /user/home/Downloads/mm10/mm10 -U BS_P384R_S_S30_L002_R1_001.fastq > BS_P384R_S' returned non-zero exit status 1

    Any suggestions on something to try?