Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • GenoMax
    replied
    Originally posted by Dave-bo_Baggins View Post
    GenoMax

    When I entered the the bjam command I got these warnings:
    warning: mismatched versions of Boost.Build engine and core
    warning: Boost.Build engine (bjam) is 03.1.19
    warning: Boost.Build core (at /home/mrmary/ngs/applications/boost_1_53_0/tools/build/v2) is 2011.12-svn
    and an error statement
    error: Invalid property '<address_model>32': unknown feature 'address_model'.
    Dave,

    There is a typo in the bjam build command that is included on the cufflinks "getting started" page. The address model directive needs a "-" (hyphen) and not an "_".

    Can you try (32 or 64 depending on if you are using 32-bit OS or 64-bit)?

    Code:
    address-model=32 [B]or [/B]address-model=64
    Last edited by GenoMax; 05-14-2013, 03:33 AM.

    Leave a comment:


  • Dave-bo_Baggins
    replied
    Originally posted by GenoMax View Post
    Dave,

    Do you see the two directories "include" and "lib" under "/usr/local/boost_1_53_0/ " (or /home/mrmary/ngs/applications/boost_1_53_0/) ? If you don't then that means your boost libraries did not build properly. Can you please verify?

    If the directories (and their contents) are there then the only --with-boost directive you should need is the one I posted in post 64.
    Originally posted by GenoMax View Post
    "include --> boost" will have all the "*.hpp" files (I see 214 files) and "lib" will have all "libboost*" files.
    GenoMax

    When I entered the the bjam command I got these warnings:
    warning: mismatched versions of Boost.Build engine and core
    warning: Boost.Build engine (bjam) is 03.1.19
    warning: Boost.Build core (at /home/mrmary/ngs/applications/boost_1_53_0/tools/build/v2) is 2011.12-svn
    and an error statement
    error: Invalid property '<address_model>32': unknown feature 'address_model'.

    Im checking around to see what does actually it actually mean. Im figuring this was the reason why the include and the lib directories were not created
    before

    Leave a comment:


  • GenoMax
    replied
    "include --> boost" will have all the "*.hpp" files (I see 214 files) and "lib" will have all "libboost*" files.

    Leave a comment:


  • Dave-bo_Baggins
    replied
    Originally posted by GenoMax View Post
    Dave,

    Do you see the two directories "include" and "lib" under "/usr/local/boost_1_53_0/ " (or /home/mrmary/ngs/applications/boost_1_53_0/) ? If you don't then that means your boost libraries did not build properly. Can you please verify?

    If the directories (and their contents) are there then the only --with-boost directive you should need is the one I posted in post 64.
    GenoMax

    I checked paths and there are no "include" or "lib" directories.(there is a libs directory) I will reinstall and rebuild the boost, and keep an eye out for an errors that may come up during building and report back.

    Thanks again
    Dave

    Leave a comment:


  • GenoMax
    replied
    Dave,

    Do you see the two directories "include" and "lib" under "/usr/local/boost_1_53_0/ " (or /home/mrmary/ngs/applications/boost_1_53_0/) ? If you don't then that means your boost libraries did not build properly. Can you please verify?

    If the directories (and their contents) are there then the only --with-boost directive you should need is the one I posted in post 64.

    Leave a comment:


  • Dave-bo_Baggins
    replied
    Originally posted by GenoMax View Post
    Dave,

    "--with-boost=" should point to the top level directory where the "include" and "lib" directories for boost are. In your case if "/usr/local/boost_1_53_0" is that directory then your directive will be
    Code:
    --with-boost=/usr/local/boost_1_53_0
    Hello Again GenoMax

    I decided to go over my configure statement again, in particularly the boost related commands:
    --with-boost=/usr/local/boost_1_53_0/
    --with-boost-thread=/usr/lib64/boost141/libboost_thread-mt.so
    --with-boost-libdir=/usr/local/boost_1_53_0/boost/
    --with-boost-system=/usr/local/boost_1_53_0/stage/lib/

    I changed the line: --with-boost-thread=/usr/lib64/boost141/libboost_thread-mt.so to --with-boost-thread=/usr/lib/libboost_thread-mt.so

    other than that I don't think the issue is with my statement, at least I dont see one. I am going to try appending the LD_PATH. Will get back to you. I cannot think of what I'm missing at the moment.

    Thanks for the replies and your time
    Dave

    Leave a comment:


  • GenoMax
    replied
    Originally posted by Dave-bo_Baggins View Post
    Hello GenoMax

    Thanks so much for your feedback. Let me answer your question:


    I have Boost installed in the home directory: $HOME/ngs/applications
    mrmary@mrmary-Dimension-4600i:~/ngs/applications$ ls -l
    drwxrwxr-x 10 mrmary mrmary 4096 May 12 05:58 boost_1_53_0

    I also copied my boost installation to /usr/local as well
    mrmary@mrmary-Dimension-4600i:/usr/local$ ls -l
    drwxr-xr-x 10 root root 4096 May 12 08:20 boost_1_53_0

    I will look at the threads you have listed and get back to you tomorrow. The locate libboost command looks very promising avenue to start with tomorrow.

    Thanks again for your time, I was at wit's end with this
    Dave
    Dave,

    "--with-boost=" should point to the top level directory where the "include" and "lib" directories for boost are. In your case if "/usr/local/boost_1_53_0" is that directory then your directive will be
    Code:
    --with-boost=/usr/local/boost_1_53_0

    Leave a comment:


  • Dave-bo_Baggins
    replied
    Originally posted by pengchy View Post
    the "--with-boost-libdir=" specify the directory like /path/to/lib/boost_1_47_0/include/
    here, the "include" directory contain one directory "boost", and many files suffix *hpp locate at "boost" directory. So the files will like "include/boost/*hpp". If you have installed boost, you will find this directory at /prefix/include/boost/*hpp
    Hello pengchy

    Thanks for the reply that cleared up things a lil bit. I have .hpp files at the following locations:

    /usr/local/boost_1_53_0/boost
    /ngs/applications/boost_1_53_0/boost

    when I hit the ls -l command I can see the .hpp files. I have understood correctlythe corrected statement should be:

    --with-boost-libdir=/usr/local/boost_1_53_0/boost/

    I added that to my configure statement but it didnt work. I went back too at the cufflinks config.log and I found these statements:"

    configure:3870: checking for boostlib >= 1.47.0
    configure:3929: g++ -c -I/home/mrmary/ngs/applications/boost_1_53_0//include conftest.cc >&5
    conftest.cc:25:5: error: #error Boost version is too old
    configure:3935: $? = 1
    configure: failed program was:
    | /* confdefs.h. */

    configure:3870: checking for boostlib >= 1.47.0
    configure:3929: g++ -c -I/home/mrmary/ngs/applications/boost_1_53_0//include

    configure:4059: g++ -c -I/home/mrmary/ngs/applications/boost_1_53_0//include -I/home/mrmary/ngs/applications/boost_1_53_0//include conftest.cc >&5
    conftest.cc:25:6: error: #error Boost version is too old
    I think this may have to do with the lines I got back when I built boost:
    The Boost C++ Libraries were successfully built!
    The following directory should be added to compiler include paths:
    /home/mrmary/ngs/applications/boost_1_53_0
    The following directory should be added to linker library paths:
    /home/mrmary/ngs/applications/boost_1_53_0/stage/lib

    Im gonna sleep on this and get back to it in a few hours
    Dave

    Leave a comment:


  • Dave-bo_Baggins
    replied
    Originally posted by GenoMax View Post
    Dave: Where exactly did you install boost libraries? Are they in "/usr/local" or in your home directory?

    You may have already seen the instructions here: http://cufflinks.cbcb.umd.edu/tutorial.html#inst Depending on where you installed the boost libraries add that path using " --with-boost=/path/to/boost"

    Here are a couple of threads for reference: http://seqanswers.com/forums/showthread.php?t=19805 and http://seqanswers.com/forums/showthread.php?t=14224
    Hello GenoMax

    Thanks so much for your feedback. Let me answer your question:
    Where exactly did you install boost libraries? Are they in "/usr/local" or in your home directory?
    I have Boost installed in the home directory: $HOME/ngs/applications
    mrmary@mrmary-Dimension-4600i:~/ngs/applications$ ls -l
    drwxrwxr-x 10 mrmary mrmary 4096 May 12 05:58 boost_1_53_0

    I also copied my boost installation to /usr/local as well
    mrmary@mrmary-Dimension-4600i:/usr/local$ ls -l
    drwxr-xr-x 10 root root 4096 May 12 08:20 boost_1_53_0

    I will look at the threads you have listed and get back to you tomorrow. The locate libboost command looks very promising avenue to start with tomorrow.

    Thanks again for your time, I was at wit's end with this
    Dave

    Leave a comment:


  • pengchy
    replied
    the "--with-boost-libdir=" specify the directory like /path/to/lib/boost_1_47_0/include/
    here, the "include" directory contain one directory "boost", and many files suffix *hpp locate at "boost" directory. So the files will like "include/boost/*hpp". If you have installed boost, you will find this directory at /prefix/include/boost/*hpp

    Leave a comment:


  • GenoMax
    replied
    Dave: Where exactly did you install boost libraries? Are they in "/usr/local" or in your home directory?

    You may have already seen the instructions here: http://cufflinks.cbcb.umd.edu/tutorial.html#inst Depending on where you installed the boost libraries add that path using " --with-boost=/path/to/boost"

    Here are a couple of threads for reference: http://seqanswers.com/forums/showthread.php?t=19805 and http://seqanswers.com/forums/showthread.php?t=14224

    Leave a comment:


  • Dave-bo_Baggins
    replied
    Thanks Pengchy for answering I really appreciate it

    This is what I tried again:

    ./configure
    --prefix=/home/mrmary/ngs/applications/cufflinks-2.1.1/
    --with-boost-libdir=/home/mrmary/ngs/applications/boost_1_53_0/
    --with-boost-thread=/usr/lib64/boost141/libboost_thread-mt.so
    --with-bam=/usr/local/include/bam/
    --with-eigen=/usr/local/include/Eigen/

    Im a little confused when I ran the ./b2 command to build boost I got the following recommendations:

    The following directory should be added to compiler include paths:
    /home/mrmary/ngs/applications/boost_1_53_0
    The following directory should be added to linker library paths:
    /home/mrmary/ngs/applications/boost_1_53_0/stage/lib

    Im not sure where I should add the include paths and what path --with-boost-libdir is asking for

    Thanks anyone and everyone who reads this

    Dave

    Leave a comment:


  • pengchy
    replied
    try specify:
    --with-boost-libdir=/path/to/lib/boost_1_47_0/include/

    Leave a comment:


  • Dave-bo_Baggins
    replied
    I have been working on trying to build cufflinks for the past few days and so far I keep getting stuck with the same error
    checking for boostlib >= 1.47.0... configure: error: We could not detect the boost libraries (version 1.47 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option. If you are sure you have boost installed, then check your version number looking in <boost/version.hpp>. See http://randspringer.de/boost for more documentation.

    I have installed
    1. boost_1_53_0
    2. samtools(samtools-0.1.19)
    3. eigen (eigen-eigen-2249f9c22fe8)
    4. install cufflinks (cufflinks-2.1.1)


    for boost I did the following:
    ./bootstrap.sh
    ./b2
    The Boost C++ Libraries were successfully built!
    The following directory should be added to compiler include paths:
    /home/mrmary/ngs/applications/boost_1_53_0
    The following directory should be added to linker library paths:
    /home/mrmary/ngs/applications/boost_1_53_0/stage/lib

    I continued forward with this command.
    ./bjam --prefix=/home/mrmary/ngs/applications/boost_1_53_0
    --toolset=gcc link=static runtime-link=static stage install

    then i went cd'ed into my cufflinks directory and entered the following
    ./configure --prefix=/home/mrmary/ngs/applications/cufflinks-2.1.1 --with-boost=/home/mrmary/ngs/applications/boost_1_53_0 --with-boost-thread=/usr/lib64/boost141/libboost_thread-mt.so --with-bam=/usr/local/include/bam --with-eigen=/usr/local/include/Eigen

    when that didn't work I modified the command a little and tried again

    ./configure --prefix=/home/mrmary/ngs/applications/cufflinks-2.1.1 --with-boost=/home/mrmary/ngs/applications/boost_1_53_0/stage/lib --with-boost-thread=/usr/lib64/boost141/libboost_thread-mt.so --with-bam=/usr/local/include/bam --with-eigen=/usr/local/include/Eigen


    any help would be god send at this point. Much thanks and regards

    Dave

    Leave a comment:


  • pengchy
    replied
    Hi all,

    I have installed successfully from source code, here is the step:
    1. install boost (boost_1_47_0)
    2. install samtools
    3. install eigen
    4. install cufflinks (cufflinks-2.1.1)
    ./configure --with-boost=/path/to/lib/boost_1_47_0/ --prefix=/path/to/cufflinks-2.1.1/ --with-bam=/path/to/bam/ --with-eigen=/path/to/Eigen/ --with-boost-libdir=/path/to/lib/boost_1_47_0/include/ --with-boost-thread=/path/to/lib/boost_1_47_0/lib/libboost_thread.so

    NOTE: /path/to/bam/ directory contain the following directories:
    include/bam
    include/Eigen #the subdirectory of eigen after uncompressed eigen package
    lib/libbam.a

    Explaination of the error message:
    The thread package in the include//boost/thread directory cann't be compiled successfully by cufflinks, so we can use the compiled library when we install boost.
    Last edited by pengchy; 04-17-2013, 05:34 PM. Reason: add version information

    Leave a comment:

Latest Articles

Collapse

  • seqadmin
    Best Practices for Single-Cell Sequencing Analysis
    by seqadmin



    While isolating and preparing single cells for sequencing was historically the bottleneck, recent technological advancements have shifted the challenge to data analysis. This highlights the rapidly evolving nature of single-cell sequencing. The inherent complexity of single-cell analysis has intensified with the surge in data volume and the incorporation of diverse and more complex datasets. This article explores the challenges in analysis, examines common pitfalls, offers...
    06-06-2024, 07:15 AM
  • seqadmin
    Latest Developments in Precision Medicine
    by seqadmin



    Technological advances have led to drastic improvements in the field of precision medicine, enabling more personalized approaches to treatment. This article explores four leading groups that are overcoming many of the challenges of genomic profiling and precision medicine through their innovative platforms and technologies.

    Somatic Genomics
    “We have such a tremendous amount of genetic diversity that exists within each of us, and not just between us as individuals,”...
    05-24-2024, 01:16 PM

ad_right_rmr

Collapse

News

Collapse

Topics Statistics Last Post
Started by seqadmin, Yesterday, 06:54 AM
0 responses
10 views
0 likes
Last Post seqadmin  
Started by seqadmin, 06-14-2024, 07:24 AM
0 responses
17 views
0 likes
Last Post seqadmin  
Started by seqadmin, 06-13-2024, 08:58 AM
0 responses
16 views
0 likes
Last Post seqadmin  
Started by seqadmin, 06-12-2024, 02:20 PM
0 responses
17 views
0 likes
Last Post seqadmin  
Working...
X