Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • chenyao
    replied
    Originally posted by Tiger123 View Post
    Glad you got it. I installed boost in the /usr/local and exported the path.

    make and make install went fine. I was able to run the test_data.sam given in the cufflinks webpage. But, there was one warning. Pasted below is the output.


    tiger123@ubuntu:~/data$ cufflinks ./test_data.sam
    You are using Cufflinks v1.0.3, which is the most recent release.
    [bam_header_read] EOF marker is absent. The input is probably truncated.
    [bam_header_read] invalid BAM binary header (this is not a BAM file).
    File ./test_data.sam doesn't appear to be a valid BAM file, trying SAM...
    [16:48:28] Inspecting reads and determining fragment length distribution.
    > Processed 1 loci. [*************************] 100%
    Warning: Using default Gaussian distribution due to insufficient paired-end reads in open ranges. It is recommended that correct paramaters (--frag-len-mean and --frag-len-std-dev) be provided.
    > Map Properties:
    > Total Map Mass: 102.50
    > Read Type: 75bp x 75bp
    > Fragment Length Distribution: Truncated Gaussian (default)
    > Default Mean: 200
    > Default Std Dev: 80
    [16:48:28] Assembling transcripts and estimating abundances.
    > Processed 1 loci.

    I am not sure whether this will create problems when running the actual data.
    Strange. I also run test_data.sam. That's what I got:

    Processed 1 loci. [*************************] 100%
    Warning: Using default Gaussian distribution due to insufficient paired-end reads in open ranges. It is recommended that correct paramaters (--frag-len-mean and --frag-len-std-dev) be provided.
    > Map Properties:
    > Total Map Mass: 102.50
    > Read Type: 75bp x 75bp
    > Fragment Length Distribution: Truncated Gaussian (default)
    > Default Mean: 200
    > Default Std Dev: 80
    [11:34:41] Assembling transcripts and estimating abundances.
    > Processing Locus test_chromosome:52-550 [************************ ] 99%段错误

    Leave a comment:


  • Tiger123
    replied
    Glad you got it. I installed boost in the /usr/local and exported the path.

    make and make install went fine. I was able to run the test_data.sam given in the cufflinks webpage. But, there was one warning. Pasted below is the output.


    tiger123@ubuntu:~/data$ cufflinks ./test_data.sam
    You are using Cufflinks v1.0.3, which is the most recent release.
    [bam_header_read] EOF marker is absent. The input is probably truncated.
    [bam_header_read] invalid BAM binary header (this is not a BAM file).
    File ./test_data.sam doesn't appear to be a valid BAM file, trying SAM...
    [16:48:28] Inspecting reads and determining fragment length distribution.
    > Processed 1 loci. [*************************] 100%
    Warning: Using default Gaussian distribution due to insufficient paired-end reads in open ranges. It is recommended that correct paramaters (--frag-len-mean and --frag-len-std-dev) be provided.
    > Map Properties:
    > Total Map Mass: 102.50
    > Read Type: 75bp x 75bp
    > Fragment Length Distribution: Truncated Gaussian (default)
    > Default Mean: 200
    > Default Std Dev: 80
    [16:48:28] Assembling transcripts and estimating abundances.
    > Processed 1 loci.

    I am not sure whether this will create problems when running the actual data.

    Leave a comment:


  • chenyao
    replied
    OK , I fix it. It seems the boost is not installed in "/usr/local/boost"

    Leave a comment:


  • chenyao
    replied
    Originally posted by Tiger123 View Post
    Hi, solved the problem with the error message (checking for boostlib >= 1.38.0... configure: error: ....) while cufflinks configuration.
    Today I installed libboost using;
    sudo apt-get install libboost-all-dev.

    Then I configured successfully.

    ./configure --prefix=/usr/local/cufflinks/install --with-boost=/usr/local/boost

    The output is below:

    -------------------------------------
    -----------------------------------

    checking for boostlib >= 1.38.0... yes
    checking for bamlib... yes
    checking build system type... x86_64-unknown-linux-gnu
    checking whether the Boost::Thread library is available... yes
    checking how to run the C preprocessor... gcc -E
    checking for egrep... grep -E
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking if zlib is wanted... yes
    checking for inflateEnd in -lz... yes
    ------------------------------------------
    ---------------------------------------

    -- cufflinks 1.0.3 Configuration Results --
    C++ compiler: g++ -Wall -Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized -m64 -O3 -DNDEBUG -pthread -I/usr/local/boost/include -I/usr/local/include
    GCC version: gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
    Host System type: x86_64-unknown-linux-gnu
    Install prefix: /usr/local/cufflinks/install
    Install eprefix: ${prefix}

    See config.h for further configuration information.
    Email <[email protected]> with questions and bug reports.

    Dear Tiger, using your command, I got the same message. It seems cufflinks has found "boost". But after that, I cannot get the "make" successful, which always showed the error. Did you "make" it?

    Leave a comment:


  • Tiger123
    replied
    Hi, solved the problem with the error message (checking for boostlib >= 1.38.0... configure: error: ....) while cufflinks configuration.
    Today I installed libboost using;
    sudo apt-get install libboost-all-dev.

    Then I configured successfully.

    ./configure --prefix=/usr/local/cufflinks/install --with-boost=/usr/local/boost

    The output is below:

    -------------------------------------
    -----------------------------------

    checking for boostlib >= 1.38.0... yes
    checking for bamlib... yes
    checking build system type... x86_64-unknown-linux-gnu
    checking whether the Boost::Thread library is available... yes
    checking how to run the C preprocessor... gcc -E
    checking for egrep... grep -E
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking if zlib is wanted... yes
    checking for inflateEnd in -lz... yes
    ------------------------------------------
    ---------------------------------------

    -- cufflinks 1.0.3 Configuration Results --
    C++ compiler: g++ -Wall -Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized -m64 -O3 -DNDEBUG -pthread -I/usr/local/boost/include -I/usr/local/include
    GCC version: gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
    Host System type: x86_64-unknown-linux-gnu
    Install prefix: /usr/local/cufflinks/install
    Install eprefix: ${prefix}

    See config.h for further configuration information.
    Email <[email protected]> with questions and bug reports.

    Leave a comment:


  • chenyao
    replied
    Originally posted by Tiger123 View Post
    Some additional information about the results got when I build the boost using:

    bjam --prefix=\usr\local --toolset=gcc architecture=x86 address_model=32 link=static runtime-link=static stage install

    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build/property.jam:328: in validate1 from module property
    error: Invalid property '<address_model>32': unknown feature 'address_model'.
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build/property.jam:337: in property.validate from module property
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build/build-request.jam:216: in convert-command-line-element from module build-request
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build/build-request.jam:153: in build-request.from-command-line from module build-request
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build-system.jam:612: in load from module build-system
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/kernel/modules.jam:283: in import from module modules
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/kernel/bootstrap.jam:142: in boost-build from module
    /home/tiger123/boost/boost_1_47_0/boost-build.jam:17: in module scope from module


    Any thoughts?

    Same problem ,wait for the answer

    Leave a comment:


  • Tiger123
    replied
    Some additional information about the results got when I build the boost using:

    bjam --prefix=\usr\local --toolset=gcc architecture=x86 address_model=32 link=static runtime-link=static stage install

    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build/property.jam:328: in validate1 from module property
    error: Invalid property '<address_model>32': unknown feature 'address_model'.
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build/property.jam:337: in property.validate from module property
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build/build-request.jam:216: in convert-command-line-element from module build-request
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build/build-request.jam:153: in build-request.from-command-line from module build-request
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build-system.jam:612: in load from module build-system
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/kernel/modules.jam:283: in import from module modules
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/kernel/bootstrap.jam:142: in boost-build from module
    /home/tiger123/boost/boost_1_47_0/boost-build.jam:17: in module scope from module


    Any thoughts?

    Leave a comment:


  • Tiger123
    replied
    Hi Guys,

    I am also having configuration problems for cufflinks.

    I got the error as below for ./configure

    checking for boostlib >= 1.38.0... configure: error: We could not detect the boost libraries (version 1.38 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option. If you are sure you have boost installed, then check your version number looking in <boost/version.hpp>. See http://randspringer.de/boost for more documentation.

    I installed the latest version of boost. But, my system is 32-bit. I tried to reinstall a 64-bit linux, which I failed in my system. Is there any solution to this problem? Thanks.

    Leave a comment:


  • hibachings2013
    replied
    here got the same error too !

    Hi All,

    I am trying to install cufflinks btw got the same error too.


    checking for python platform... darwin
    checking for python script directory... ${prefix}/lib/python2.7/site-packages
    checking for python extension module directory... ${exec_prefix}/lib/python2.7/site-packages
    checking for boostlib >= 1.38.0... configure: error: We could not detect the boost libraries (version 1.38 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option. If you are sure you have boost installed, then check your version number looking in <boost/version.hpp>. See http://randspringer.de/boost for more documentation.


    so i'd specify the path to BOOST_ROOT as xi wang suggested rather than i give the path to boost_1_46_1.
    sorry for a newbie question here, how do we know where the BOOST_ROOT is?

    Thanks a lot in advance,
    Last edited by hibachings2013; 07-11-2011, 12:09 PM.

    Leave a comment:


  • emucaki
    replied
    Well that's just one of over a dozen warnings that occur during the make process, I just pasted the last one cause I thought that might be the one triggering the stop.

    Leave a comment:


  • jmarshall
    replied
    Originally posted by emucaki View Post
    GList.hh(413): remark #981: operands are evaluated in unspecified order
    You are using Intel's compiler and you have configured cufflinks so as to compile with -Werror.

    This is a relatively useless warning, and it's hard to see why it's being triggered by this code. It seems that the usual advice is to switch the warning off: http://software.intel.com/en-us/foru...ad.php?t=62309.

    Leave a comment:


  • emucaki
    replied
    Gonna bump this thread again. I was able to get through all the boost and sam/bam issues for this installation (I've successfully installed bowtie and tophat as well), but now with Cufflinks I'm having a 'make' error (it is a 64 bit system).

    GList.hh(413): remark #981: operands are evaluated in unspecified order
    if (Found(item, result)) return true;
    ^

    compilation aborted for clustering.cpp (code 2)
    make[2]: *** [clustering.o] Error 1
    make[2]: Leaving directory `/work/emucaki/goblin/Cufflinks/cufflinks-0.9.1/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/work/emucaki/goblin/Cufflinks/cufflinks-0.9.1'
    make: *** [all] Error 2
    Any ideas?

    Leave a comment:


  • repinementer
    replied
    FluxCapacitor and FluxStimulator

    Have you installed these?
    Seems pretty google code RNASEQ tools.

    Leave a comment:


  • Utrecht
    replied
    That's right, there are pre-compiled binaries for 64 bit systems and/or Macs. Much easier, eh? :-)

    Leave a comment:


  • repinementer
    replied
    yes 32 bit is not working

    yes i used bjam.
    yes i agree some thing wrong with 32 bit
    seems 64 bit doesnt have any configure file so no need to run the commands??????????

    Code:
    ./configure --prefix=/path/to/cufflinks/install --with-boost=/path/to/boost
    make
    make install
    but ./command (ex: ./cufflinks) are working fine

    [bogugk@Trivia cufflinks-0.8.2.Linux_x86_64]$ ./cufflinks ./test_data.sam
    Counting hits in map
    Total map density: 104.000000
    Processing bundle [ test_chromosome:52-550 ] with 99 non-redundant alignments
    Last edited by repinementer; 06-15-2010, 12:44 AM. Reason: adding commands

    Leave a comment:

Latest Articles

Collapse

  • seqadmin
    Best Practices for Single-Cell Sequencing Analysis
    by seqadmin



    While isolating and preparing single cells for sequencing was historically the bottleneck, recent technological advancements have shifted the challenge to data analysis. This highlights the rapidly evolving nature of single-cell sequencing. The inherent complexity of single-cell analysis has intensified with the surge in data volume and the incorporation of diverse and more complex datasets. This article explores the challenges in analysis, examines common pitfalls, offers...
    06-06-2024, 07:15 AM
  • seqadmin
    Latest Developments in Precision Medicine
    by seqadmin



    Technological advances have led to drastic improvements in the field of precision medicine, enabling more personalized approaches to treatment. This article explores four leading groups that are overcoming many of the challenges of genomic profiling and precision medicine through their innovative platforms and technologies.

    Somatic Genomics
    “We have such a tremendous amount of genetic diversity that exists within each of us, and not just between us as individuals,”...
    05-24-2024, 01:16 PM

ad_right_rmr

Collapse

News

Collapse

Topics Statistics Last Post
Started by seqadmin, Yesterday, 06:54 AM
0 responses
10 views
0 likes
Last Post seqadmin  
Started by seqadmin, 06-14-2024, 07:24 AM
0 responses
16 views
0 likes
Last Post seqadmin  
Started by seqadmin, 06-13-2024, 08:58 AM
0 responses
16 views
0 likes
Last Post seqadmin  
Started by seqadmin, 06-12-2024, 02:20 PM
0 responses
17 views
0 likes
Last Post seqadmin  
Working...
X