Seqanswers Leaderboard Ad

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • twotwo
    replied
    Originally posted by GenoMax View Post
    Are you using the directions for "Getting started" located here: http://tophat.cbcb.umd.edu/tutorial.shtml?

    Update: TopHat developers have updated that page to take out the reference to "address-model". Based on the current info there you can omit the last three options (--toolset=gcc architecture=x86 address_model=64).

    See my post #70 this thread. The address-model requires a "-" (hyphen) and not an underscore.
    never mind my other reply. When I changed address-model from underscore to hyphen, the three options worked!!! Thank you so much!!! I felt much better.

    Leave a comment:


  • twotwo
    replied
    Originally posted by GenoMax View Post
    Are you using the directions for "Getting started" located here: http://tophat.cbcb.umd.edu/tutorial.shtml?

    Update: TopHat developers have updated that page to take out the reference to "address-model". Based on the current info there you can omit the last three options (--toolset=gcc architecture=x86 address_model=64).

    See my post #70 this thread. The address-model requires a "-" (hyphen) and not an underscore.
    Thanks for being so helpful! Yes, I did not update my tophat since I already have my SAM files. Should I update the tophat if I only want to run cuffdiff?
    And if I used
    1. ./bootstrap.sh
    2. ./b2 install --prefix=/home/twotwo/software/boost153
    Did boost install well? Should I still need to run bjam?

    Thanks so much!

    Leave a comment:


  • GenoMax
    replied
    Originally posted by twotwo View Post
    The OS is the linux. And I removed some of the option:
    bjam --prefix=/home/twotwo/software/boost153/ link=static runtime-link=static stage install
    Then it works. Can I install without the option of:
    --toolset=gcc architecture=x86 address_model=64
    Is there any difference?
    Are you using the directions for "Getting started" located here: http://tophat.cbcb.umd.edu/tutorial.shtml?

    Update: TopHat developers have updated that page to take out the reference to "address-model". Based on the current info there you can omit the last three options (--toolset=gcc architecture=x86 address_model=64).

    See my post #70 this thread. The address-model requires a "-" (hyphen) and not an underscore.
    Last edited by GenoMax; 06-24-2013, 10:37 AM.

    Leave a comment:


  • twotwo
    replied
    Originally posted by GenoMax View Post
    Can you provide additional details?

    What OS? What version of boost are you trying to compile? What is the exact command line you are using? Even if the error appears to be the same it may help us diagnose the problem if you can post it here.
    The OS is the linux. And I removed some of the option:
    bjam --prefix=/home/twotwo/software/boost153/ link=static runtime-link=static stage install
    Then it works. Can I install without the option of:
    --toolset=gcc architecture=x86 address_model=64
    Is there any difference?

    Leave a comment:


  • GenoMax
    replied
    It appears that boost has not been compiled correctly. Do you see bjam in /home/twotwo/software/boost153/?

    The link you posted is the way to build boost. You will need to replace PREFIX with the path you want for your boost libraries which would be (--prefix=/home/twotwo/software/boost153).
    Last edited by GenoMax; 06-24-2013, 10:10 AM. Reason: Clarified a file path

    Leave a comment:


  • twotwo
    replied
    Originally posted by GenoMax View Post
    Can you provide additional details?

    What OS? What version of boost are you trying to compile? What is the exact command line you are using? Even if the error appears to be the same it may help us diagnose the problem if you can post it here.
    Thanks for replying so quick!
    bjam --prefix=/home/twotwo/software/boost153 --toolset=gcc architecture=x86 address_model=64 link=static runtime-link=static stage install


    And I got the following error:
    /home/twotwo/software/boost_1_53_0/tools/build/v2/build/property.jam:328: in validate1 from module property
    error: Invalid property '<address_model>64': unknown feature 'address_model'.
    /home/twotwo/software/boost_1_53_0/tools/build/v2/build/property.jam:337: in property.validate from module property
    /home/twotwo/software/boost_1_53_0/tools/build/v2/build/build-request.jam:216: in convert-command-line-element from module build-request
    /home/twotwo/software/boost_1_53_0/tools/build/v2/build/build-request.jam:154: in build-request.from-command-line from module build-request
    /home/twotwo/software/boost_1_53_0/tools/build/v2/build-system.jam:613: in load from module build-system
    /home/twotwo/software/boost_1_53_0/tools/build/v2/kernel/modules.jam:283: in import from module modules
    /home/twotwo/software/boost_1_53_0/tools/build/v2/kernel/bootstrap.jam:142: in boost-build from module
    /home/twotwo/software/boost_1_53_0/boost-build.jam:17: in module scope from module


    In the bjam command, I put the prefix with another folder boost153. However, even I used /home/twotwo/software/boost_1_53_0, I have the same error.

    By the way, I just found the following command:
    ./bootstrap.sh
    ./b2 install --prefix=PREFIX
    from the following web:

    Is this also the way to install boost? Thanks so much!
    However, after I run those two command, I still cannot run bjam command that I showed above...

    Leave a comment:


  • GenoMax
    replied
    Originally posted by twotwo View Post
    I have the same problem. Any comments???
    Can you provide additional details?

    What OS? What version of boost are you trying to compile? What is the exact command line you are using? Even if the error appears to be the same it may help us diagnose the problem if you can post it here.

    Leave a comment:


  • twotwo
    replied
    Originally posted by Tiger123 View Post
    Some additional information about the results got when I build the boost using:

    bjam --prefix=\usr\local --toolset=gcc architecture=x86 address_model=32 link=static runtime-link=static stage install

    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build/property.jam:328: in validate1 from module property
    error: Invalid property '<address_model>32': unknown feature 'address_model'.
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build/property.jam:337: in property.validate from module property
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build/build-request.jam:216: in convert-command-line-element from module build-request
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build/build-request.jam:153: in build-request.from-command-line from module build-request
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/build-system.jam:612: in load from module build-system
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/kernel/modules.jam:283: in import from module modules
    /home/tiger123/boost/boost_1_47_0/tools/build/v2/kernel/bootstrap.jam:142: in boost-build from module
    /home/tiger123/boost/boost_1_47_0/boost-build.jam:17: in module scope from module


    Any thoughts?
    I have the same problem. Any comments???

    Leave a comment:


  • GenoMax
    replied
    Dave,

    Now my head is starting to hurt

    I feel that all these problems are because of additional directive in red:

    --with-boost=/usr/local/boost_1_53_0 --with-boost-libdir=/usr/local/lib

    Can you try the compile removing the second option?

    Everything related to your boost libraries should be under the original location where you had compiled boost.

    Can you tell me where exactly did you initially compile the boost libraries? In /usr/local/boost_1_53_0 or in /usr/local.

    The reason I had asked you to create the "boost" top level directory was that way both "include" and "lib" from boost would be nicely segregated under that directory. Then when you compile cufflinks all you will need to include would be "--with-boost=path_to_top_level_boost" directory. No other boost related directives should be needed as long as your library had compiled correctly.
    Last edited by GenoMax; 05-15-2013, 03:48 PM.

    Leave a comment:


  • Dave-bo_Baggins
    replied
    I was troubleshooting and looking into the error messages and I thoughts Id share some progress, well I hope progress

    Looking at the error statement again

    g++ -Wall -Wno-strict-aliasing -g -gdwarf-2 -Wunused -Wuninitialized -march=i686 -O3 -DNDEBUG -pthread -I/usr/local/boost_1_53_0/include -I/usr/local/include/bam/include -I/usr/local/include/Eigen/include -o cufflinks -L/usr/local/lib -L/usr/local/include/bam/lib cufflinks.o libcufflinks.a libgc.a -lboost_thread -lboost_system -lbam -lz
    /usr/local/lib/libboost_thread.a(thread.o): In function `__gnu_cxx::__exchange_and_add_dispatch(int*, int) [clone .constprop.241]':
    thread.cpp.text.unlikely+0x22): undefined reference to `__atomic_fetch_add_4'


    I noticed:
    -I/usr/local/boost_1_53_0/include
    -I/usr/local/include/bam/include


    I noticed that while there is an include subdirectory for Eigen there was none for /boost_1_53_0 or /bam. What I did for the bam subdirectory was to copy my header files to the /usr/local/include/bam directory. I went back to the cufflinks gettign started manual
    and read "Copy the samtools binary to some directory in your PATH." Would I be correct in assuming that I should copy the contents of Desktop/samtools-0.1.19 to the /usr/local/ folder ? Would it make sense to create an include folder in the /boost_1_53_0 and /bam directories and fill it with the appropriate files ?

    The line that Im still trying to decipher is the

    thread.cpp.text.unlikely+0x22): undefined reference to `__atomic_fetch_add_4'

    I figure it has something to do with not being able to find the thread.cpp in the library directory which in the connfigure statement I defined as : --with-boost-libdir=/usr/local/lib. did a locate *read.cpp and found the following locations:
    /usr/local/boost_1_53_0/libs/thread/example/thread.cpp
    /usr/local/boost_1_53_0/libs/thread/src/pthread/thread.cpp
    /usr/local/boost_1_53_0/libs/thread/src/win32/thread.cpp

    Leave a comment:


  • Dave-bo_Baggins
    replied
    Originally posted by GenoMax View Post
    Dave,

    The extra "//" are there because you used an additional trailing "/" in your "--with-bam=/usr/local/include/bam/ and --with-eigen=/usr/local/include/Eigen/". Omit the trailing slashes on these two directives.

    Are there ~200 odd files in the boost/include directory now, indicating successful boost build?
    Hey GenoMax,

    I re-issued the compile statement this time removing the trailing slashes.
    and everything compiles no errors.

    ./configure --prefix=/home/dave/Desktop/cufflinks-2.1.1 --with-boost=/usr/local/boost_1_53_0 --with-boost-libdir=/usr/local/lib --with-bam=/usr/local/include/bam --with-eigen=/usr/local/include/Eigen

    I get similar error when I issue the make command:

    g++ -Wall -Wno-strict-aliasing -g -gdwarf-2 -Wunused -Wuninitialized -march=i686 -O3 -DNDEBUG -pthread -I/usr/local/boost_1_53_0/include -I/usr/local/include/bam/include -I/usr/local/include/Eigen/include -o cufflinks -L/usr/local/lib -L/usr/local/include/bam/lib cufflinks.o libcufflinks.a libgc.a -lboost_thread -lboost_system -lbam -lz
    /usr/local/lib/libboost_thread.a(thread.o): In function `__gnu_cxx::__exchange_and_add_dispatch(int*, int) [clone .constprop.241]':
    thread.cpp.text.unlikely+0x22): undefined reference to `__atomic_fetch_add_4'
    collect2: error: ld returned 1 exit status
    make[2]: *** [cufflinks] Error 1
    make[2]: Leaving directory `/home/dave/Desktop/cufflinks-2.1.1/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/dave/Desktop/cufflinks-2.1.1'
    make: *** [all] Error 2

    The include and lib subdirectories were created in the /usr/local/ directory
    Click image for larger version

Name:	directory2.jpg
Views:	1
Size:	69.7 KB
ID:	304166
    there are still no include or lib sub directories in the boost subdirectory itself. In the /usr/local/boost subdirectory there are about 150 files all .hpp files

    Leave a comment:


  • GenoMax
    replied
    Dave,

    The extra "//" are there because you used an additional trailing "/" in your "--with-bam=/usr/local/include/bam/ and --with-eigen=/usr/local/include/Eigen/". Omit the trailing slashes on these two directives.

    Are there ~200 odd files in the boost/include directory now, indicating successful boost build?

    Leave a comment:


  • Dave-bo_Baggins
    replied
    Originally posted by GenoMax View Post
    Dave,

    You were missing a "/" at the beginning of --prefix

    In any case were "include" and "lib" created under "/home/mrmary/ngs/applications/"? If you were doing the compilation again I would suggest creating a "boost" directory as so "/home/mrmary/ngs/applications/boost".

    I also did not bother to get the svn version. I just downloaded the source tar ball from here.
    Genomax

    Hope you are doing well. I have been trying to install on my home computer. Today I was back at my work station. I reinstalled boost in the /usr/local all seemed well. When I went to my cufflinks directory to type out the ./configure statement I accidentally hit enter after configure but IT WORKED I retyped and entered the whole thing:
    ./configure --prefix=/home/dave/Desktop/cufflinks-2.1.1/ --with-boost=/usr/local/boost_1_53_0 --with-boost-libdir=/usr/local/lib --with-bam=/usr/local/include/bam/ --with-eigen=/usr/local/include/Eigen/

    -- cufflinks 2.1.1 Configuration Results --
    C++ compiler: g++ -Wall -Wno-strict-aliasing -g -gdwarf-2 -Wunused -Wuninitialized -march=i686 -O3 -DNDEBUG -pthread -I/usr/local/boost_1_53_0/include -I/usr/local/include/bam//include -I/usr/local/include/Eigen//include
    GCC version: gcc (Ubuntu/Linaro 4.7.3-1ubuntu1) 4.7.3
    Host System type: i686-pc-linux-gnu
    Install prefix: /home/dave/Desktop/cufflinks-2.1.1/
    Install eprefix: ${prefix}

    The Make didnt work however and I'm sorting through that.

    make all-recursive
    make[1]: Entering directory `/home/dave/Desktop/cufflinks-2.1.1'
    Making all in src
    make[2]: Entering directory `/home/dave/Desktop/cufflinks-2.1.1/src'

    g++ -Wall -Wno-strict-aliasing -g -gdwarf-2 -Wunused -Wuninitialized -march=i686 -O3 -DNDEBUG -pthread -I/usr/local/boost_1_53_0/include -I/usr/local/include/bam//include -I/usr/local/include/Eigen//include -o cufflinks -L/usr/local/lib -L/usr/local/include/bam//lib cufflinks.o libcufflinks.a libgc.a -lboost_thread -lboost_system -lbam -lz
    /usr/local/lib/libboost_thread.a(thread.o): In function `__gnu_cxx::__exchange_and_add_dispatch(int*, int) [clone .constprop.241]':
    thread.cpp.text.unlikely+0x22): undefined reference to `__atomic_fetch_add_4'
    collect2: error: ld returned 1 exit status
    make[2]: *** [cufflinks] Error 1
    make[2]: Leaving directory `/home/dave/Desktop/cufflinks-2.1.1/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/dave/Desktop/cufflinks-2.1.1'
    make: *** [all] Error 2


    The // thing strikes my eye esp when I compared it to the code given on the post you linked in your first or one of your first responce http://seqanswers.com/forums/showthread.php?t=19805

    I think i burned out my retinas over the last few days

    Dave

    Leave a comment:


  • GenoMax
    replied
    Dave,

    You were missing a "/" at the beginning of --prefix
    --prefix=/home/mrmary/ngs/applications/
    In any case were "include" and "lib" created under "/home/mrmary/ngs/applications/"? If you were doing the compilation again I would suggest creating a "boost" directory as so "/home/mrmary/ngs/applications/boost".

    I also did not bother to get the svn version. I just downloaded the source tar ball from here.

    Leave a comment:


  • Dave-bo_Baggins
    replied
    Originally posted by GenoMax View Post
    Dave,

    There is a typo in the bjam build command that is included on the cufflinks "getting started" page. The address model directive needs a "-" (hyphen) and not an "_".

    Can you try (32 or 64 depending on if you are using 32-bit OS or 64-bit)?

    Code:
    address-model=32 [B]or [/B]address-model=64
    Hey GenoMax

    Thanks for you responses

    I deleted my previous boost installation and stared over again:

    ./bootstrap.sh --prefix=home/mrmary/ngs/applications/
    Building Boost.Build engine with toolset gcc... tools/build/v2/engine/bin.linuxx86/b2
    Detecting Python version... 2.7
    Detecting Python root... /usr
    Unicode/ICU support for Boost.Regex?... /usr
    Generating Boost.Build configuration in project-config.jam...

    Bootstrapping is done. To build, run:

    ./b2

    bjam --prefix=home/mrmary/ngs/applications/ --toolset=gcc architecture=x86 address-model=32 link=static runtime-link=static stage install

    warning: mismatched versions of Boost.Build engine and core
    warning: Boost.Build engine (bjam) is 03.1.19
    warning: Boost.Build core (at /home/mrmary/ngs/applications/boost_1_53_0/tools/build/v2) is 2011.12-svn
    /home/mrmary/ngs/applications/boost_1_53_0/tools/build/v2/util/path.jam:476: in path.makedirs
    rule MAKEDIR unknown in module path.
    /home/mrmary/ngs/applications/boost_1_53_0/tools/build/v2/build/configure.jam:190: in configure.set-log-file
    /home/mrmary/ngs/applications/boost_1_53_0/tools/build/v2/build-system.jam:725: in load
    /home/mrmary/ngs/applications/boost_1_53_0/tools/build/v2/kernel/modules.jam:283: in import
    /home/mrmary/ngs/applications/boost_1_53_0/tools/build/v2/kernel/bootstrap.jam:142: in boost-build
    /home/mrmary/ngs/applications/boost_1_53_0/boost-build.jam:17: in module scope


    I tried also:
    bjam --prefix=home/mrmary/ngs/applications/ --toolset=gcc architecture=x86 address-model=64 link=static runtime-link=static stage install

    I got the same warning but it also started to compile and I saw many lines of course but something that caught my eye were lines like the following:

    common.copy home/mrmary/ngs/applications/lib/libboost_serialization.so.1.53.0
    common.copy home/mrmary/ngs/applications/include/boost/mpl/aux_/preprocessed/bcc/plus.hpp

    I did a locate applications/lib, and a locate applications/include but didnt find anything. From what I am seeing online lines like that indicate a broken libdir configuration. I looked at the project-configure.jam and found the lines:

    # These settings are equivivalent to corresponding command-line
    # options.
    option.set prefix : home/mrmary/ngs/applications/ ;
    option.set exec-prefix : home/mrmary/ngs/applications/ ;
    option.set libdir : home/mrmary/ngs/applications//lib ;
    option.set includedir : home/mrmary/ngs/applications//include ;

    Looking at the above bolded parts of the file paths, Im guessing this is why the include and lib files werent built. I think I have to specify the libdir and the includedir, I'm looking that up as we speak

    Also when everything finished compiling I got the following:
    ...failed updating 2 targets...
    ...skipped 6 targets...
    ...updated 11046 targets...

    Leave a comment:

Latest Articles

Collapse

  • seqadmin
    Recent Advances in Sequencing Analysis Tools
    by seqadmin


    The sequencing world is rapidly changing due to declining costs, enhanced accuracies, and the advent of newer, cutting-edge instruments. Equally important to these developments are improvements in sequencing analysis, a process that converts vast amounts of raw data into a comprehensible and meaningful form. This complex task requires expertise and the right analysis tools. In this article, we highlight the progress and innovation in sequencing analysis by reviewing several of the...
    05-06-2024, 07:48 AM
  • seqadmin
    Essential Discoveries and Tools in Epitranscriptomics
    by seqadmin




    The field of epigenetics has traditionally concentrated more on DNA and how changes like methylation and phosphorylation of histones impact gene expression and regulation. However, our increased understanding of RNA modifications and their importance in cellular processes has led to a rise in epitranscriptomics research. “Epitranscriptomics brings together the concepts of epigenetics and gene expression,” explained Adrien Leger, PhD, Principal Research Scientist...
    04-22-2024, 07:01 AM

ad_right_rmr

Collapse

News

Collapse

Topics Statistics Last Post
Started by seqadmin, 05-14-2024, 07:03 AM
0 responses
19 views
0 likes
Last Post seqadmin  
Started by seqadmin, 05-10-2024, 06:35 AM
0 responses
44 views
0 likes
Last Post seqadmin  
Started by seqadmin, 05-09-2024, 02:46 PM
0 responses
54 views
0 likes
Last Post seqadmin  
Started by seqadmin, 05-07-2024, 06:57 AM
0 responses
42 views
0 likes
Last Post seqadmin  
Working...
X