Header Leaderboard Ad

Collapse

Installing Newbler 2.5.3 on 64 bit Ubuntu...anyone???

Collapse

Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I installed a new directory for a "local" install rather than system. So the new directory is home/dane/454/

    The old directory is still in opt/454/bin with all the files.

    64bit Ubuntu, Im not sure which package the installer used. However, I tried replacing any of the i686 tarballs that might have been installed instead of the x86 and then the programs wouldn't assemble and would come up with syntax errors.

    Comment


    • #17
      No, do not mix files. If you see all the file in /opt/454/bin what gives you a

      file /opt/454/bin/sfffile

      What gives you

      /opt/454/bin/sfffile

      Sven

      Comment


      • #18
        Originally posted by sklages View Post
        No, do not mix files. If you see all the file in /opt/454/bin what gives you a

        file /opt/454/bin/sfffile

        What gives you

        /opt/454/bin/sfffile

        Sven
        /opt/454/bin/sfffile gives me permission denied so I have to run it with sudo.

        I went ahead and tried /454 which is where my new install is located and its telling me that the directory doesn't exist.

        Comment


        • #19
          Originally posted by Dane View Post
          /opt/454/bin/sfffile gives me permission denied so I have to run it with sudo.

          I went ahead and tried /454 which is where my new install is located and its telling me that the directory doesn't exist.
          When you have installed your package in /opt/454 with 'sudo' then you have to change
          the permissions (as well with 'sudo') accordingly, so that you can access the files/progs.

          About your "new" install you wrote you have installed it in "/home/dane/454/"; where
          comes the "/454" from?

          If your installation is in "/home/dane/454/" (hopefully without 'sudo'), you should alter
          your PATH accordingly,

          export PATH="/home/dane/454/bin:$PATH"

          Sven

          Comment


          • #20
            Originally posted by sklages View Post

            If your installation is in "/home/dane/454/" (hopefully without 'sudo'), you should alter
            your PATH accordingly,

            export PATH="/home/dane/454/bin:$PATH"

            Sven
            Awesome, that fixed the pathing, thank you very much for you help. Kudos

            Comment


            • #21
              Originally posted by rad View Post
              Assuming you have a bin directory in your $HOME, and its in your $PATH

              ln -s /bin/true ~/bin/rocks

              then run the installer.

              This worked perfectly for me!

              Thanks!

              Comment


              • #22
                Originally posted by WaltL View Post
                I worked on it most of the day and finally got it installed.

                It is not too difficult, but you cannot use the installer. I am performing a test assembly this morning and I will post installation instructions a bit later today.

                Walt
                Thanks a lot for the installation instructions! They worked perfect for me!

                (I had to change the filenames for step 6 and 7 from:
                newbler_CLI-2.5.3.x86_64.tgz to newbler_CLI_2.5.3.x86_64.tgz
                amplicon_GUI_2.5.3.noarch.tgz to amplicons_GUI_2.5.3.noarch.tgz)

                Comment


                • #23
                  gsAmplicon not working

                  I followed all of the instructions for install and I get the GUI when I type in gsAmplicon but there is a bug in my program. When I try to start a new project, nothing happens. I don't get the other tabs to work. I've tried re-installing and still had the same problem. gsMapper and gsAssembler seem to work just fine. Has anyone else had this problem? BTW, I have Java 1.6.0_20 which may cause the problem?
                  Last edited by aligenie; 03-30-2011, 10:38 AM.

                  Comment


                  • #24
                    The amplicons_CLI_2.5.3.i686.tgz package was missing from the installation how-to steps 6 and 7. Including it made gsAmplicon to start.

                    Comment


                    • #25
                      Thanks to the Roche programmers I have been in misery for two days trying to start gsAmplicon project... Here is what I have figured out.

                      I have not been able to run it on Ubuntu, but I have installed CentOS v.6.0 from LiveCD under the Oracle VM Virtual Box. Make sure when you create RedHat 64-bit virtual machine to allocate generous amount of RAM (I put 8Gb out of 16Gb that I have), otherwise installation will not run. After installing the CentOS in the virtual machine I have also installed JDK through package manager (System->Administration->Add/Remove Software -> Find "JDK" -> install OpenJDK Runtime Environment), but my guess this step is not necessary. What is essential is to install packages mandatory for the Roche software by typing

                      >su
                      #yum install zlib.i686 libXi.i686 libXtst.i686 libXaw.i686


                      The packages zlib.i386 libXi.i386 libXtst.i386 libXaw.i386 are no longer available through yum. Under Ubuntu yum can't find these packages. After installing these prerequisites gs Amplicon Variant Analyzer runs like a charm.

                      Happy variant finding!

                      Comment


                      • #26
                        Like the earlier post of jvhaarst in this thread the installer works just fine in recent ubuntu x64 versions. Make sure you can use a gui (remote or local xserver).
                        Apply the fixes listed here also for the rocks problem. This did it all ok for me on several machines.

                        start X console/server
                        $sudo ./setup.sh
                        warnings gtk pixmap
                        error unable to locate lspci in /sbin

                        Fix:
                        $sudo aptitude update
                        $sudo aptitude install pxmap
                        $which lspci
                        ->/usr/bin
                        $sudo ln -s /usr/bin/lspci /sbin/lspci

                        Error: finding rocks 2>$1
                        Fix: create symlink
                        $sudo ln -s /bin/true /sbin/rocks
                        Run sudo ./setup.sh ==> goes to installer gui

                        Comment


                        • #27
                          Thanks for the installation instructions, if you have java installed you need to make a link to /bin/java
                          to make it run:
                          $ which java
                          /usr/local/bin/jre1.6.0_24/bin/java
                          /bin$ sudo ln -s /usr/local/bin/jre1.6.0_24/bin/java ./

                          Comment


                          • #28
                            Originally posted by rad View Post
                            Assuming you have a bin directory in your $HOME, and its in your $PATH

                            ln -s /bin/true ~/bin/rocks

                            then run the installer.
                            this approach helped me install newbler 2.6 on ubuntu. thank you!

                            Comment


                            • #29
                              Originally posted by JakobSJ View Post
                              this approach helped me install newbler 2.6 on ubuntu. thank you!
                              Hello,

                              We are currently trying to install Newbler and the other packages (2.6 update) on Ubuntu. This thread helped us a lot, however we are still encountering one big issue.

                              During the gsRunProcessor installation, we have this error showing up :

                              [16:33:23] rpm -U /opt/maj/maj_2.6/DataProcessing_2.6_All/packages/gsReporter-2.6-1.x86_64.rpm

                              rpm: RPM should not be used directly install RPM packages, use Alien instead!
                              rpm: However assuming you know what you are doing...
                              attention: /opt/maj/maj_2.6/DataProcessing_2.6_All/packages/gsReporter-2.6-1.x86_64.rpm: Entête V3 DSA/SHA1 Signature, key ID e50b562c: NOKEY
                              erreur: Dépendances requises:
                              /bin/sh est nécessaire pour gsReporter-2.6-1.x86_64

                              Basically, it says that it can't find /bin/sh on our system. That's because rpm can't check on ubuntu which package is installed and which is not. We found the solution "use the rpm command with the --nodeps option", but we can't modify the setup.sh script (binary file).

                              How did you do to solve this problem ?
                              Thank you so much, we are desperate to install the whole GS analysis package properly !!

                              Comment


                              • #30
                                This post may solve us a long headaching problem. Thanks!!

                                Comment

                                Working...
                                X